Koozali.org formerly Contribs.org

smeserver-sysmon on sme8?

smeserver-sysmon on sme8?
« on: September 07, 2011, 02:25:28 AM »
Has anyone managed to install successfully this package on sme8?
Thanks for any info.

- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline mdo

  • *
  • 355
Re: smeserver-sysmon on sme8?
« Reply #1 on: September 07, 2011, 05:03:12 AM »
Hi Chris

We alternatively used a version from Nethesis which comes very close in its functionality. I think it is still considered a beta version. I hope it is OK that I publish this here. I had hoped that this would make it into the contribs repository.

http://smeserver.nethesis.it/

http://smeserver.nethesis.it/releases/8/i386/smeserver-sysmon-6.2-1.el5.sme.noarch.rpm

wget http://smeserver.nethesis.it/releases/8/i386/smeserver-sysmon-6.2-1.el5.sme.noarch.rpm
yum localinstall smeserver-sysmon-6.2-1.el5.sme.noarch.rpm

Michael
...

Re: smeserver-sysmon on sme8?
« Reply #2 on: September 07, 2011, 11:04:34 AM »
Thanks Michael, I am sure it is OK to pass this link here.  I had found this package a while back, but it is not working for me - I used the deps found in the sme8 contribs repo, is this what you do?  Or do you get your deps from the sme7-contribs repo?  Or somewhere else?
Thanks
chris
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline mdo

  • *
  • 355
Re: smeserver-sysmon on sme8?
« Reply #3 on: September 07, 2011, 11:09:46 AM »
For all contrib installations on SME8 while in beta, I have both repositories enabled, sme7contribs and smecontribs.

db yum_repositories show sme7contribs
sme7contribs=repository
    GPGCheck=yes
    MirrorList=http://distro.ibiblio.org/pub/linux/distributions/smeserver/mirrorlist/smecontribs-7
    Name=SME 7 - contribs
    Visible=no
    status=enabled

db yum_repositories show smecontribs 
smecontribs=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://distro.ibiblio.org/pub/linux/distributions/smeserver/mirrorlist/smecontribs-8
    Name=SME Server - contribs
    Visible=no
...

Re: smeserver-sysmon on sme8?
« Reply #4 on: September 07, 2011, 12:28:34 PM »
Thansk Micheal.
Working for me now, enabled both repos and done:

wget http://smeserver.nethesis.it/releases/8/i386/smeserver-sysmon-6.2-1.el5.sme.noarch.rpm
yum localinstall smeserver-sysmon-6.2-1.el5.sme.noarch.rpm

#Results:
Installed:
smeserver-sysmon.noarch 0:6.2-1.el5.sme                                                                                                                                       

Dependency Installed:
fping.i386 0:2.4b2-7.el5                                   
perl-rrdtool.i386 0:1.2.30-1.el5.rf                         
rrdtool.i386 0:1.2.30-1.el5.rf       

All graphs showing OK.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline mgb

  • ****
  • 558
Re: smeserver-sysmon on sme8?
« Reply #5 on: September 07, 2011, 01:38:34 PM »
ok
« Last Edit: September 07, 2011, 01:40:15 PM by mgb »
Thanks all for helping
Skype yosii2009

Re: smeserver-sysmon on sme8?
« Reply #6 on: April 10, 2012, 12:15:02 PM »
Quote
Working for me now, enabled both repos and done:

How did you enable these repos ? tried the way I thought it should be done but no success.

Thanks
Peter
...

Offline TerryF

  • grumpy old man
  • *
  • 1,199
Re: smeserver-sysmon on sme8?
« Reply #7 on: April 10, 2012, 12:59:22 PM »
How did you enable these repos ? tried the way I thought it should be done but no success.
Thanks
Peter

Did you do it THIS way
--
qui scribit bis legit

Re: smeserver-sysmon on sme8?
« Reply #8 on: April 10, 2012, 02:12:29 PM »
How did you enable these repos ? tried the way I thought it should be done but no success.

Thanks
Peter

Just tested this again.  All you need is to enable smecontribs, all deps are there.  I prefer enabling additional repo from command line just for this operation, safer.  So:

Code: [Select]
[root@test8b7 ~]# cd /opt[as good a place as any...]

#Download package:
Code: [Select]
[root@test8b7 opt]# wget http://smeserver.nethesis.it/releases/8/i386/smeserver-sysmon-6.2-1.el5.sme.noarch.rpm[snip]
2012-04-10 21:54:32 (19.0 KB/s) - `smeserver-sysmon-6.2-1.el5.sme.noarch.rpm' saved [20893/20893]

#Now install:
Code: [Select]
[root@test8b7 opt]# yum --enablerepo=smecontribs localinstall smeserver-sysmon-6.2-1.el5.sme.noarch.rpm[snip]
Total download size: 1.3 M
Is this ok [y/N]: y
[snip]
Installed:
smeserver-sysmon.noarch 0:6.2-1.el5.sme                                                                                                                                       
Dependency Installed:
fping.i386 0:2.4-1.b2.3.el5.rf     libart_lgpl.i386 0:2.3.17-4     perl-rrdtool.i386 0:1.2.30-1.el5.rf     rrdtool.i386 0:1.2.30-1.el5.rf     sysstat.i386 0:7.0.2-11.el5   
Complete!

Code: [Select]
[root@test8b7 opt]# signal-event post-upgrade; signal-event rebootBroadcast message from root (pts/0) (Tue Apr 10 22:01:59 2012):
The system is going down for reboot NOW!

All graphs showing OK.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Offline Knyte

Re: smeserver-sysmon on sme8?
« Reply #9 on: May 23, 2012, 06:12:58 PM »
Thanks Chris!  Just got the graphs working thanks to your post.
SME 8.1 (currently restoring to SME 9.2) running in ESXi 5.5

Offline PeteB

Re: smeserver-sysmon on sme8?
« Reply #10 on: June 05, 2012, 10:54:34 PM »
Yoopi! First contrib I succeeded in installing on 8.0
I've been battling with messages similar to "No package smeserver-hwinfo available" and wondering what sort of things I should have seen or known or asked.
(I have had a SME server running since v6.5, mostly without paying much attention to it, with Ibays for music -Jinzora- and photos.)

Re: smeserver-sysmon on sme8?
« Reply #11 on: September 11, 2012, 01:13:16 PM »
A new version is now available in the SME8 Contribs section, thanks to Unnilennium
Check: http://bugs.contribs.org/show_bug.cgi?id=6333
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Re: smeserver-sysmon on sme8?
« Reply #12 on: September 12, 2012, 05:22:50 AM »
Moving to contribs section.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.