Koozali.org formerly Contribs.org

[ANNOUNCE] smeserver-service_control

[ANNOUNCE] smeserver-service_control
« on: January 14, 2008, 09:39:20 AM »
Hello everyone,

I just finished a new contrib for SME Server V7.x and V8.x.

This contrib allow you to adjust status of all services contains in the server.
TCP Port can be changed for services that accept this parameter.

For installation, you have to download the rpm from this link:
RPM:
smeserver-service_control-1.0-1.noarch.rpm
and launch, from command line :
Code: [Select]
yum localinstall smeserver-service_control-*.rpm
sRPM:
smeserver-service_control-1.0-1.src.rpm

Regards,
MasterSleepy.

Re: [ANNOUNCE] smeserver-service_control
« Reply #1 on: January 14, 2008, 09:54:33 PM »
Installed this contrib and it's working nicely.

Thanx Mastersleepy!  :cool:

Re: [ANNOUNCE] smeserver-service_control
« Reply #2 on: January 15, 2008, 04:17:02 AM »
Mastersleepy.
Installed this contrib. Dangerous but useful contrib I think.
You must know what you click. No warning or confirmation.
One wrong click, you are in trouble.

Also it create new 'Configuration' group in left panel of server-manager, although there is a panel group named Configuration. Maybe because of space after 'Configuration' ?

Good work!

Re: [ANNOUNCE] smeserver-service_control
« Reply #3 on: January 15, 2008, 08:02:21 AM »
Hello,

Thanks for this feedback.
The bug in the server-manager is now fixed.
I planed to add a confirmation screen in the next release, maybe again this week.

Now I've published a 1.0-3 version.
URL still the same:
smeserver-service_control-1.0-3.noarch.rpm.

Regards,
MasterSleepy.

Re: [ANNOUNCE] smeserver-service_control
« Reply #4 on: January 15, 2008, 08:21:55 AM »
Hello,

Thanks for this feedback.
The bug in the server-manager is now fixed.
I planed to add a confirmation screen in the next release, maybe again this week.

Now I've published a 1.0-3 version.
URL still the same:
smeserver-service_control-1.0-3.noarch.rpm.

Regards,
MasterSleepy.

Can I just update it by: yum localinstall smeserver-service_control-1.0-3.noarch.rpm ?

Re: [ANNOUNCE] smeserver-service_control
« Reply #5 on: January 15, 2008, 08:53:41 AM »
Thanks for this contrib MasterSleepy,  :pint:
I'll test it ASAP.

Ciao

Umberto

Re: [ANNOUNCE] smeserver-service_control
« Reply #6 on: January 15, 2008, 09:58:45 AM »
Can I just update it by: yum localinstall smeserver-service_control-1.0-3.noarch.rpm ?

No use
Code: [Select]
yum localupdate smeserver-service_control-1.0-3.noarch.rpm
Regs,
MasterSleepy.

Re: [ANNOUNCE] smeserver-service_control
« Reply #7 on: January 15, 2008, 10:09:49 AM »
No use
Code: [Select]
yum localupdate smeserver-service_control-1.0-3.noarch.rpm
Regs,
MasterSleepy.

Thanx, that worked!

Re: [ANNOUNCE] smeserver-service_control
« Reply #8 on: January 21, 2008, 08:53:34 AM »
Hello all,

A new version is available (1.1-1).
This new version include a confirmation screen for each action (Thx to thomasch)

RPM:
smeserver-service_control-1.1-1.noarch.rpm

sRPM:
smeserver-service_control-1.1-1.src.rpm

For command installation:
Code: [Select]
rpm -Uvh "http://www.vanhees.cc/index.php?name=CmodsDownload&file=index&req=getit&lid=329"
Regards,
MasterSleepy.


Re: [ANNOUNCE] smeserver-service_control
« Reply #9 on: January 27, 2008, 11:14:43 AM »
Hi MasterSleepy, thanks again for this useful contrib.
I've noticed that there is a small problem with the nut service, loook at this picture



I've translated your contrib in italian, if you think can be useful I'll send you the translated function file.

Ciao

Umberto

Re: [ANNOUNCE] smeserver-service_control
« Reply #10 on: January 27, 2008, 11:33:17 AM »
Installed and install works well. Umberto, I do not see what you have in my version, just "Enable".
I toggled it off and on to see if there was a change.

Re: [ANNOUNCE] smeserver-service_control
« Reply #11 on: January 27, 2008, 12:02:07 PM »
I toggled it off and on to see if there was a change.

Solved, I've switched on and then off the NUT service, now all seems ok.  :?:

Ciao

Umberto

Offline william_syd

  • ****
  • 1,608
  • Nothing to see here.
    • http://www.magicwilly.info
Re: [ANNOUNCE] smeserver-service_control
« Reply #12 on: January 28, 2008, 05:34:06 AM »
Solved

?

If there is a invalid setting that is how this contrib displays it.

Test with config setprop nut status blah

Reload the control page and see the effect. Use the page to put it back how you like.

So the question is, if you did not play with the Nut service, why did it have incorrect data?
Regards,
William

IF I give advise.. It's only if it was me....