Koozali.org formerly Contribs.org

Remote FTP Problem

ephraims

Remote FTP Problem
« on: September 12, 2006, 03:33:04 PM »
When i try to install remote user access i get the following error below. Please help


[root@microairserver bitsinstall]# rpm -Uvh smeserver-remoteuseraccess-1.0-1.noa
rch.rpm
Preparing...                ########################################### [100%]
   1:smeserver-remoteuseracc########################################### [100%]
ERROR in /etc/e-smith/templates-custom//etc/proftpd.conf/05ServerAdmin: Program
fragment delivered error <<Can't locate esmith/FtpDB.pm in @INC (@INC contains:
/usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.
6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i38
6-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/v
endor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vend
or_perl .) at /etc/e-smith/templates-custom//etc/proftpd.conf/05ServerAdmin line
 2.
BEGIN failed--compilation aborted at /etc/e-smith/templates-custom//etc/proftpd.
conf/05ServerAdmin line 2.>> at template line 1
ERROR in /etc/e-smith/templates-custom//etc/proftpd.conf/05ServerName: Program f
ragment delivered error <<Can't locate esmith/FtpDB.pm in @INC (@INC contains: /
usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6
.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386
-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/ve
ndor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendo
r_perl .) at /etc/e-smith/templates-custom//etc/proftpd.conf/05ServerName line 2
.
BEGIN failed--compilation aborted at /etc/e-smith/templates-custom//etc/proftpd.
conf/05ServerName line 2.>> at template line 1
ERROR in /etc/e-smith/templates-custom//etc/proftpd.conf/05port: Program fragmen
t delivered error <<Can't locate esmith/FtpDB.pm in @INC (@INC contains: /usr/li
b/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6.1/i38
6-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386-linux
 /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_p
erl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendor_perl
 .) at /etc/e-smith/templates-custom//etc/proftpd.conf/05port line 2.
BEGIN failed--compilation aborted at /etc/e-smith/templates-custom//etc/proftpd.
conf/05port line 2.>> at template line 1
ERROR in /etc/e-smith/templates-custom//etc/proftpd.conf/40IBayAccess: Program f
ragment delivered error <<Can't locate esmith/FtpDB.pm in @INC (@INC contains: /
usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/5.6
.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i386
-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5/ve
ndor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/vendo
r_perl .) at /etc/e-smith/templates-custom//etc/proftpd.conf/40IBayAccess line 9
.
BEGIN failed--compilation aborted at /etc/e-smith/templates-custom//etc/proftpd.
conf/40IBayAccess line 9.>> at template line 1
ERROR in /etc/e-smith/templates-custom//etc/proftpd.conf/60AnonymousIBay: Progra
m fragment delivered error <<Can't locate esmith/FtpDB.pm in @INC (@INC contains
: /usr/lib/perl5/5.6.1/i386-linux /usr/lib/perl5/5.6.1 /usr/lib/perl5/site_perl/
5.6.1/i386-linux /usr/lib/perl5/site_perl/5.6.1 /usr/lib/perl5/site_perl/5.6.0/i
386-linux /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl /usr/lib/perl5
/vendor_perl/5.6.1/i386-linux /usr/lib/perl5/vendor_perl/5.6.1 /usr/lib/perl5/ve
ndor_perl .) at /etc/e-smith/templates-custom//etc/proftpd.conf/60AnonymousIBay
line 8.
BEGIN failed--compilation aborted at /etc/e-smith/templates-custom//etc/proftpd.
conf/60AnonymousIBay line 8.>> at template line 1
ERROR: Template processing failed for //etc/proftpd.conf: 5 fragments generated
errors
 at /sbin/e-smith/expand-template line 49

ephraims

updtating proftpd
« Reply #1 on: September 12, 2006, 04:04:43 PM »
I beleive i am unabel to update the proftpd file.. How do i change the permission on this file to what it has to be?

I am having this problem after a restore.

I did a 911 backup of the server and a restore all seamed to be ok then i put the server back in and the ftp is not working.

Also wen i save any pages in the server manager i get an error but it all still seams to work.

THe errors in server manager are all in raltion to proftpd

I also ran this but it did not help
wget http://sme.swerts-knudsen.dk/downloads/Updates/6.0.1/ProFTPd/proftpd-1.2.10-es1.i386.rpm
rpm -Uvh proftpd-1.2.10-es1.i386.rpm
/sbin/e-smith/signal-event remoteaccess-update

Any other suggestions

ephraims

Where can i get
« Reply #2 on: September 12, 2006, 11:07:07 PM »
Does anybody know where i can get this rpm. I must have had it installed prior to the reload i beleive it is giving me the problems that i am having. I am unable to uninstall it because i did not install it on the server after the reload but i think it is causing me the problems. I tried MUZZO website for the rpm but it says not autorised. Any ideas where i can get this rpm

e-smith-ftp-manager-0.4-2.noarch.rpm

ephraims

Found Module
« Reply #3 on: September 13, 2006, 05:50:48 AM »
I managed to find the ftp manager module and reinstalled it and i am not getting error messages any more.

Then problem i am having now is that the remote user access module is not working.
The problem is a bit strange

1. If i ftp as a user all is good it takes me straight to there home folder
2. If i modify there setting for there chroot for there ftp in the remote access panel in server manager the ftp stops it gives me an invalid user name and password error.
3. If i reset them back to there home folder it will still not work. That user is now unable to ftp at all it keeps giving them and invalid password error.

The error logs in sme also says Authentication failuer

Does anybody have any ideas?

Remote FTP Problem
« Reply #4 on: September 14, 2006, 04:31:09 AM »
You might want to take a look around (google search) and make sure that its the correct version for your version of SME.  Something I have noticed is that thier are several sites where one can find  contribs but many dont have any documentation on what version the contrib works on.  Sounds like you might of installed a crontrib made for a previous version on a later version since its not working like its supposed to.
...

Remote FTP Problem
« Reply #5 on: September 14, 2006, 04:32:47 AM »
Also if it is the contrib I am thinking off did you restart the ftp after making the change ?
...