Koozali.org formerly Contribs.org

421 per host concurrency limit reached

pwinkler

421 per host concurrency limit reached
« on: August 03, 2006, 04:28:20 AM »
We are using SME 7.0 final

We have 43 imap clients using outlook

We keep getting this message in outlook:  

"The IMAP server has issued an unrecognized greeting"

and when you click "Details"

"421 per host concurrency limit reached
 Protocol: IMAP
 Server: 192.168.1.3
 Port: 143"

I have searched the forums & tried the following:

* IMAP connection problems and timeouts for no apparent reasons at about more than 30 IMAP boxes

This might help:

    /sbin/e-smith/config setprop imap ConcurrencyLimit 200
    /etc/e-smith/events/actions/imap-conf
    svc -t /service/imap

but as someone else noted there is no imap-conf at /etc/e-smith/events/actions/imap-conf

so we tried this:

config setprop imap ConcurrencyLimit 2000
signal-event email-update

from this thread
http://forums.contribs.org/index.php?topic=30834.0

and this is the current imap cfg (which has not changed despite the above)

 db configuration show imaps
imaps=service
    ConcurrencyLimit=400
    ConcurrencyLimitPerIP=12
    TCPPort=993
    access=public
    status=enabled

Pls help

Offline JonB

  • *
  • 351
421 per host concurrency limit reached
« Reply #1 on: August 03, 2006, 05:04:40 AM »
You are modifying the database for imap but you are showing the database configuration for imaps

Try

db configuration show imap

Jon
...

Re: 421 per host concurrency limit reached
« Reply #2 on: August 03, 2006, 06:12:54 AM »
Quote from: "pwinkler"

so we tried this:

config setprop imap ConcurrencyLimit 2000
signal-event email-update


The ConcurrencyLimit is the maximum number of IMAP sessions allowed. The ConcurrencyLimitPerIP is the limit for an individual client PC.

So, you have increased the total number of connections, but haven't changed the per-host concurrency limit.

Would you also be able to raise this in the bug tracker? We chose 12 as a decent limit for most networks, but we want to know more about your environment and why you are hitting that limit. Thanks.
............

Offline raem

  • *
  • 3,972
421 per host concurrency limit reached
« Reply #3 on: August 03, 2006, 06:36:57 AM »
pwinkler

Note there are both db entries on sme7
config show imap
config show imaps

So when you make db changes, specifiy the correct db entry you wish to change.
...

pwinkler

421 per host concurrency limit reached
« Reply #4 on: August 03, 2006, 06:55:36 PM »
Thanks for your prompt replies, much appreciated

As I was changing the per ip connection settings ( as suggested by Gordon) it suddenly dawned on me that most of these users are connecting from a windows terminal server and so all the imap connections from that server are using the same IP! Most users have multiple email addresses so i have changed the per IP limit to 150 - don't know if that is going to work until the morning when they start connecting but it seems logical.


BTW what is the differenc between imap & imaps?

pwinkler

421 per host concurrency limit reached
« Reply #5 on: August 04, 2006, 05:05:33 AM »
I have made the following changes:

 db configuration show imaps
imaps=service
ConcurrencyLimit=4000
ConcurrencyLimitPerIP=150
TCPPort=993
access=public
status=enabled

 db configuration show imap
imaps=service
ConcurrencyLimit=4000
ConcurrencyLimitPerIP=150
TCPPort=993
access=public
status=enabled

but we are still experiencing the same prob so I have converted some users with only one email acct to pop3

When only a few people are connected it seems ok but when eveybody connects we get the outlook "The IMAP server has issued an unrecognized greeting"  message repeatedly

Some users have hundreds of mb of emails in multiple folders & multiple email accts and they are the ones that seem to have the most issues with outlook locking up and email transport being slow.

We had the same users on a SME v.6.0.1 custom iso for years that the hardware died on recently that we have now migrated to a new server.

We did have an issue with the v6 but changing the conncurent connections fixed it.

421 per host concurrency limit reached
« Reply #6 on: August 04, 2006, 05:09:35 AM »
Quote from: "pwinkler"
I have made the following changes:
[...]
ConcurrencyLimitPerIP=150


I think you'll find that 43*12 = 516 which is a lot larger than 150

If all of your users appear to be coming from the same IP you're going to want a value which can handle that.
............

421 per host concurrency limit reached
« Reply #7 on: August 04, 2006, 05:48:13 AM »
Quote from: "gordonr"
Quote from: "pwinkler"
I have made the following changes:
[...]
ConcurrencyLimitPerIP=150


I think you'll find that 43*12 = 516 which is a lot larger than 150

If all of your users appear to be coming from the same IP you're going to want a value which can handle that.


Or have a special 'peers' file for that IP address, which allows a special higher per-IP limit. See the ipsvd documentation.

Offline mdo

  • *
  • 355
421 per host concurrency limit reached
« Reply #8 on: August 04, 2006, 08:41:50 AM »
Quote

 db configuration show imaps
imaps=service
ConcurrencyLimit=4000
ConcurrencyLimitPerIP=150
TCPPort=993
access=public
status=enabled

db configuration show imap
imaps=service
ConcurrencyLimit=4000
ConcurrencyLimitPerIP=150
TCPPort=993
access=public
status=enabled


That does not look correct to me. You show us the 2 different commands
db configuration show xxxx
but then after the second command which is supposed to show the settings for imap, the output is actually showing the imapS settings!!???
Look at the port. It even says imaps=service

Michael
...

pwinkler

421 per host concurrency limit reached
« Reply #9 on: August 04, 2006, 01:23:44 PM »
I have now changed the setting to the following, (maybe it's overkill)

[root@mail1 ~]# db configuration show imap
imap=service
    ConcurrencyLimit=40000
    ConcurrencyLimitPerIP=1500
    TCPPort=143
    access=private
    status=enabled

hope this works

PelgerM

421 per host concurrency limit reached
« Reply #10 on: August 15, 2006, 12:11:46 PM »
hello,

i tried this, but it seems that these values are simply ignored....
the same error keeps coming...

the commands
Code: [Select]

config setprop imap ConcurrencyLimit 4000
config setprop imaps ConcurrencyLimit 4000
config setprop imap ConcurrencyLimitPerIP 2000
config setprop imaps ConcurrencyLimitPerIP 2000


output from #db configuration show imap
Code: [Select]

imap=service
    ConcurrencyLimit=4000
    ConcurrencyLimitPerIP=2000
    TCPPort=143
    access=private
    status=enabled


the reason is, that we have actually 2 subnetworks with the mailserver on the old one, with the connection to the internet, and a seperate internal router to connect the 2 networks. i though about pushing the ConcurrencyLimitPerIP high enough so that everyone from the new subnet can access... but still the message
Quote
"The IMAP server has issued an unrecognized greeting"

with "Details"

"421 per host concurrency limit reached
Protocol: IMAP
Server: 1.1.1.203
Port: 143"

keeps popin um after a short time...

what have i done wrong?
or is this the totally wrong way?

thanks in advance...

oh, and it is the SME7beta0.9 version... if this could matter...

Offline byte

  • *
  • 2,182
421 per host concurrency limit reached
« Reply #11 on: August 15, 2006, 12:47:40 PM »
Quote from: "PelgerM"

oh, and it is the SME7beta0.9 version... if this could matter...


It's likely to be the problem, as some major bugs have been fixed during that release to final release. Upgrade would be the way to go.
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline Tib

  • *
  • 571
    • http://www.tibors.net
421 per host concurrency limit reached
« Reply #12 on: August 15, 2006, 01:02:17 PM »
hmm this thread is intersting ...

since I updated my thunderbird it now shows warnings and I get ... You may have exceeded the maximum number of connections to this server... I have 3 Imap mail addresses that I connect to in one hit.

It says that I can try and fix this by lowering the number of cached connections ... so I changed it to 3/imap. This still does not fix it ... 3x3=9

Standard cached connections in Thunderbird is 5 ... so if you have more then one imap account then you already have problems.

SME6.0 never had this problem so something must have changed in SME7.

Now I haven't changed any setting since I installed SME7.0 Final but I did upgrade from I think as low as beta to RC1 to 2 to 3 then final and my configs are as follows:

[edit] Come to think of it I may have changed the ConcurrencyLimit to 400 ... but thats it.

config show imap is:

imap=service
    ConcurrencyLimit=400
    ConcurrencyLimitPerIP=6
    TCPPort=143
    access=private
    status=enabled
   
config show imaps is:

imaps=service
    ConcurrencyLimit=400
    ConcurrencyLimitPerIP=6
    TCPPort=993
    access=public
    status=enabled

so if this is the normal setting then maybe it should be upped a little in the base install to stop problems for a lot of ppl ... I origionally thought it was a Thunderbird problem I had.

I will check the bug tracker for an entry as well.

Regards,

Tib

Offline Tib

  • *
  • 571
    • http://www.tibors.net
421 per host concurrency limit reached
« Reply #13 on: August 15, 2006, 01:40:54 PM »
Just did some more testing

doing a signal-event email-update was not enough.

I had to stop the imap and imaps servers and restart to make the
config setprop imap ConcurrencyLimitPerIP 20
config setprop imaps ConcurrencyLimitPerIP 20

changes to stick.

But even with this setup

imap=service
ConcurrencyLimit=400
ConcurrencyLimitPerIP=20
TCPPort=143
access=private
status=enabled

I still get the same error message when I start up thunderbird ... mind you when I look at the logs there is only a 3/20 connection happening.

after I do a lot of searching of e-mails etc I finnaly get a 9/20 conection

eg:

2006-08-15 21:34:24.145478500 tcpsvd: info: status 9/400
2006-08-15 21:34:24.146008500 tcpsvd: info: pid 18362 from 192.168.1.101
2006-08-15 21:34:24.146012500 tcpsvd: info: concurrency 18362 192.168.1.101 9/20
2006-08-15 21:34:24.146014500 tcpsvd: info: start 18362 0:192.168.1.5 ::192.168.1.101:49923 ./peers/192.168.1
2006-08-15 21:34:24.148512500 imapfront-auth[18363]: * OK imapfront ready.
2006-08-15 21:34:24.153268500 2006.08.15 11:34:24 LOG5[18362:3086969056]: Using 'imap' as tcpwrapper service name
2006-08-15 21:34:24.159624500 2006.08.15 11:34:24 LOG5[18362:3086969056]: stunnel 3.22 on i686-redhat-linux-gnu PTHREAD+LIBWRAP with OpenSSL 0.9.7a Feb 19 2003
2006-08-15 21:34:24.160010500 2006.08.15 11:34:24 LOG5[18362:3086969056]: imap connected from 192.168.1.101:49923

Regards,

Tib

PelgerM

421 per host concurrency limit reached
« Reply #14 on: August 15, 2006, 03:06:40 PM »
well
after updating i get this line repeated every second
Code: [Select]

006-08-15 13:49:19.265986500 ./run: line 10: ./config: No such file or directory
2006-08-15 13:49:20.427042500 ./run: line 10: ./config: No such file or directory
2006-08-15 13:49:21.589507500 ./run: line 10: ./config: No such file or directory
2006-08-15 13:49:22.749384500 ./run: line 10: ./config: No such file or directory
2006-08-15 13:49:23.908219500 ./run: line 10: ./config: No such file or directory


well, i have no idea why...
but, ok... doesn't matter because i stopped imap (/etc/init.d/imap stop)
and the message stops repeating...

the real funny thing is that now, the concurrent connection settings are right and an access tothe imap service is perfectly possible...

If anyone can explain this... wow... i'm really interested in understandig this :D