Koozali.org formerly Contribs.org

pb joining an XP machin to an SME7rc2 PDC (solved)

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
pb joining an XP machin to an SME7rc2 PDC (solved)
« on: May 12, 2006, 10:18:27 AM »
Don't know if I'm doing something wrong but I cannot join an XP machin to the domain and I find nothing on the forum about it.
I have set the workgroup of the server in the server manager
i've enabled the pdc function
I apply the reg file (/home/e-smith/files/server-resources/regedit/winxplogon.reg) on the client
When I try to join the domain, it ask me for the admin name and password and when I enter it,  it respond that the username or password isn't correct.
I try several time, I even try to change the samba's admin user and it still don't work. Maybe I forgot a stupid thing. Can anyone help me?
C'est la fin du monde !!! :lol:

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: pb joining an XP machin to an SME7rc2 PDC
« Reply #1 on: May 12, 2006, 11:37:57 PM »
Quote from: "VIP-ire"
Don't know if I'm doing something wrong but I cannot join an XP machin to the domain and I find nothing on the forum about it.
I have set the workgroup of the server in the server manager
i've enabled the pdc function
I apply the reg file (/home/e-smith/files/server-resources/regedit/winxplogon.reg) on the client
When I try to join the domain, it ask me for the admin name and password and when I enter it,  it respond that the username or password isn't correct.
I try several time, I even try to change the samba's admin user and it still don't work. Maybe I forgot a stupid thing. Can anyone help me?


Do you enter you external domain as domain namefor the XP box or do you use the workgroup name as the domain on the XP box? The latter should normally work.

If it does not work... check the log files of your server.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #2 on: May 13, 2006, 12:32:55 PM »
yes I use the workgroup name.
There is nothing in the samba log or in the messages log.
For some other reason, I'm doing a fresh install. I hope it'll work this time
C'est la fin du monde !!! :lol:

jasonv

pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #3 on: May 15, 2006, 09:13:41 PM »
i didn't need to apply any registry patch to my xp clients to get them working with rc1. but, i can't get my fedora clients to authenticate against my sme pdc.

Offline jackl

  • ***
  • 136
pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #4 on: May 15, 2006, 11:09:49 PM »
VIP-ire

How long is your Admin Password?
The reason I ask is that I had similar problem with SME 6.0 with Samba 3.0 and if the password length for the admin account was 15 characters or greater it would not work with SAMBA, reducing the password to 14 characters it worked fine.  All other linux functions email etc worked fine with long password but not samba. Hope this might be of help to you.

Regards

Jack
......

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #5 on: May 16, 2006, 09:46:17 AM »
Well, I tried several password from 5 to 13 caracteres, it doesn't work. One thing strange is that I tried to make it work on two servers, one at my office, one at home. At the begining, the two servers wasn't able to be a pdc. Last week, I've done a fresh install on my home server, I reconfigure exactly the same way and then, it works (even with a 16 caracteres admin's password). the one at my office still don't. I'm trying to figure out why. I will post if I find the difference between the two server.
C'est la fin du monde !!! :lol:

Offline ldkeen

  • *
  • 391
pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #6 on: May 16, 2006, 01:31:28 PM »
Did you try both admin and root as the user. I've heard of cases where admin wouldn't work but root would, mainly on upgraded machines.
Lloyd

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
pb joining an XP machin to an SME7rc2 PDC (solved)
« Reply #7 on: May 17, 2006, 10:16:44 AM »
I think I found the problem. My root and admin passwords were desynchronized. It's beacause of this bug that at the instal time, we can't choose the keyboard type, so I initialize the admin password withe a qwerty keyboard without paying attention. Of course, I wasn't able to retype it on a azerty keyboard after so I reset it with the command passwd.
I don't remember having done that for the two servers but I think it's what happened.
I have reset the two passwords (root and admin) in single mode (as it's expain on grand-pa's site). Then I reboot and I re-reset it in the server manager (I think it synchronize the passwd and the ldap base but I'm not sure). now it works.

thank for your help everyone
C'est la fin du monde !!! :lol: