Koozali.org formerly Contribs.org

cc copy as a default config

droid_cebu

cc copy as a default config
« on: March 29, 2006, 11:57:04 AM »
Is it possible to configure SME to create cc copies on all outgoing mails to a desired mailbox as a default for all users?

Any advice is greatly appreciated. Thanks

Offline JonB

  • *
  • 351
cc copy as a default config
« Reply #1 on: March 29, 2006, 12:52:43 PM »
droid,

What you want is available from a plugin in qpsmtpd and is called Bcc

From the console as root

Code: [Select]
config setprop qpsmtpd Bcc enabled BccUser xxx@domain.com
signal-event email-update


where the BccUser is the email address you want all copies of all incoming and outgoing emails to go to.

Note that in some countries you are required by law to notify your users that you are keeping a copy of all their emails. You would be surprised how quickly it cuts down on personal email. However it also has the effect of an increase in the use of hotmail, Yahoo etc

Jon
...

wallyrp

cc copy as a default config
« Reply #2 on: March 30, 2006, 05:54:38 PM »
Good Morning,

I'm still looking for a way to block all BCC email as this is the preferred method of spammers. I know that this bucks the whole system and all but as a general rule of thumb, I don't need BCC.

cc copy as a default config
« Reply #3 on: March 30, 2006, 08:53:52 PM »
Quote from: "wallyrp"

I'm still looking for a way to block all BCC email ...


BCC is a feature of individual mail programs. It can't be blocked at the server (otherwise there would be a trivial way to block spam, wouldn't there? And there obviously isn't.).

droid_cebu

cc copy as a default config
« Reply #4 on: April 11, 2006, 03:14:30 PM »
Hi,

Thanks for the help. you did however miss the d on "enable"

It should be "config setprop qpsmtpd Bcc enabled BccUser xxx@domain.com

It worked great!

problem with cc copy as default config
« Reply #5 on: June 26, 2006, 08:00:29 AM »
Hi,

I ran the folowing command for cc as default config

config setprop qpsmtpd Bcc enabled BccUser xxx@domain.com
signal-event email-update

But I am not getting copies to the BccUser.

there is an entry in /var/log/qpsmtpd/current as follows

loading bcc mode cc all xxx@domain.com

can anybody point me as to how to debug this.

thanks in advance

Veeresh

Offline raem

  • *
  • 3,972
Re: problem with cc copy as default config
« Reply #6 on: June 26, 2006, 09:19:31 AM »
veeresh

Check your settings with
config show qpsmtpd

The Bcc & BccUser settings should match what you configured

qpsmtpd=service
Bcc=disabled
BccUser=maillog
DNSBL=disabled
LogLevel=6
MaxScannerSize=25000000
RBLList=sbl-xbl.spamhaus.org,whois.rfc-ignorant.org,dnsbl.njabl.org,relays.ordb.org
RHSBL=disabled
RequireResolvableFromHost=no
SBLList=dsn.rfc-ignorant.org
access=public
status=enabled
...

cc copy as a default config
« Reply #7 on: June 26, 2006, 12:36:01 PM »
Hi,

Thanks Ray


here is the result of
#config show qpsmtpd

qpsmtpd=service
Bcc=enabled
BccUser=xxx@mydomain.com
DNSBL=disabled
LogLevel=8
MaxScannerSize=25000000
RBLList=sbl-xbl.spamhaus.org,whois.rfc-ignorant.org,dnsbl.njabl.org,relays.ordb.org
RHSBL=disabled
RequireResolvableFromHost=no
SBLList=dsn.rfc-ignorant.org
access=public
status=enabled

but still i do not get BccUser copies

Veeresh

Offline raem

  • *
  • 3,972
cc copy as a default config
« Reply #8 on: June 26, 2006, 01:02:53 PM »
veeresh

> BccUser=xxx@mydomain.com

Did you literally enter this as xxx@mydomain.com or have you obfuscated your post ? You should enter the real email address of the cc recipient.

> DNSBL=disabled
> RHSBL=disabled

You might like to enable these settings for greatly improved spam rejection see

http://mirror.contribs.org/smeserver//contribs/rmitchell/smeserver/howto/Spam%20blocking%20HOWTO%20using%20qpsmtpd%20&%20RBL%20for%20sme%20server.htm
...

cc copy as a default config
« Reply #9 on: June 26, 2006, 01:29:01 PM »
Hi,

I obfuscated my post, it is not literally xxx@mydomain.com

any further leads

thanks

Offline JonB

  • *
  • 351
cc copy as a default config
« Reply #10 on: June 26, 2006, 02:11:06 PM »
Veeresh, works perfectly for me.

Is xxx@domain.com a user on your server or external?
Can you send an ordinary email to that user and receive it?
Can you send a Bcc email to that user and receive it?

Jon
...

cc copy as a default config
« Reply #11 on: June 26, 2006, 03:15:45 PM »
Hi,

Thanks RayMitchell and JonB,

It works fine.  

The problem was that i had logged in to the server as root for enabling BccUser.  After that I sent the mails from the console itself as root.
these were not copied to BccUser. But when I sent mails from the mail client as any other user i get copies to BccUser.

Is this by design.

Anyways thanks for the support.

Veeresh

aelculladajr

no function
« Reply #12 on: February 22, 2007, 08:23:40 AM »
i try to use the code given

config setprop qpsmtpd Bcc enabled BccUser xxx@domain.com
signal-event email-update

there is no result! i put my own account replace to "xxx@domain.com", the bcc is enabled i can recieve incoming but i can't recieve the outgoing mail

here is the result of
#config show qpsmtpd

qpsmtpd=service
Bcc=enabled
BccUser=aelculladajr@danielefurniture.net
DNSBL=disabled
LogLevel=8
MaxScannerSize=25000000
RBLList=sbl-xbl.spamhaus.org,whois.rfc-ignorant.org,dnsbl.njabl.org,relays.ordb.org
RHSBL=disabled
RequireResolvableFromHost=no
SBLList=dsn.rfc-ignorant.org
access=public
signal-event=email-update
status=enabled


pls help me!

cc copy as a default config
« Reply #13 on: February 22, 2007, 09:01:13 AM »
Quote from: "wallyrp"
Good Morning,

I'm still looking for a way to block all BCC email as this is the preferred method of spammers. I know that this bucks the whole system and all but as a general rule of thumb, I don't need BCC.


Yes, you almost certainly do. Bcc mail is just one case of mail where the envelope recipients do not match the header recipients. Mailing lists are another. Mail systems which don't understand the difference between the envelope and the headers are evil.
............

cc copy as a default config
« Reply #14 on: February 22, 2007, 09:05:42 AM »
Quote from: "veeresh"

The problem was that i had logged in to the server as root for enabling BccUser.  After that I sent the mails from the console itself as root.
these were not copied to BccUser. But when I sent mails from the mail client as any other user i get copies to BccUser.

Is this by design.


Yes. Mail injected on the server itself is not normally injected via SMTP and so does not pass through qpsmtpd. This means that mail from cron and similar is not stored in the BccUser's mailbox. In general, this is a good thing. Mail injected in the normal ways - SMTP clients and webmail (which is also SMTP) are handled.
............