Koozali.org formerly Contribs.org

ZoneMinder-1.22.0 for SME-7.0pre1 for test

chaapai

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« on: February 02, 2006, 02:58:33 PM »
Hello All

I adapt the new version of ZoneMinder 1.22.0 http://www.zoneminder.com for pre1
So you can test it :
[CHANGED]
Code: [Select]
/sbin/e-smith/db yum_repositories set Chaapai repository \
BaseURL ftp://ftp.chaapai.homelinux.net/yum-smeserver/7.0pre1/smechaapai/i386/ \
EnableGroups 1 \
GPGCheck 0 \
Name 'SME Server - Chaapai contribs' \
status enabled

/sbin/e-smith/expand-template /etc/yum.conf


check in /etc/yum.conf
Code: [Select]
...
[Chaapai]
name=SME Server - Chaapai contribs
baseurl=ftp://ftp.chaapai.homelinux.net/yum-smeserver/7.0pre1/smechaapai/i386
gpgcheck=0
enablegroups=1
...

and for finish
[CHANGED]
Code: [Select]
yum --enablerepo=base --enablerepo=updates install zm

log of install :
Code: [Select]
[root@serveur-crashtest1 ~]# db yum_repositories set Chaapai repository
> BaseURL ftp://ftp.chaapai.homelinux.net/yum-smeserver/7.0pre1/smechaapai/i386/
> EnableGroups 1
> GPGCheck 0
> Name 'SME Server - Chaapai contribs'
> status enabled
[root@serveur-crashtest1 ~]# /sbin/e-smith/expand-template /etc/yum.conf
[root@serveur-crashtest1 ~]# yum --enablerepo=base --enablerepo=updates install zm
Setting up Install Process
Setting up repositories
Chaapai 100% |=========================| 951 B 00:00
smeaddons 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
smeos 100% |=========================| 951 B 00:00
smeupdates 100% |=========================| 951 B 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 502 kB 00:05
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package zm.i386 0:1.22.0-01.sme7 set to be updated
--> Running transaction check
--> Processing Dependency: perl-Device-SerialPort for package: zm
--> Processing Dependency: perl(X10::ActiveHome) for package: zm
--> Processing Dependency: lame >= 3.96.1 for package: zm
--> Processing Dependency: perl-Compress-Zlib for package: zm
--> Processing Dependency: ffmpeg >= 0.4.9 for package: zm
--> Processing Dependency: perl(Device::SerialPort) for package: zm
--> Processing Dependency: perl-Archive-Zip for package: zm
--> Processing Dependency: zm-lat_ibay = 1.22.0 for package: zm
--> Processing Dependency: perl-MIME-Lite >= 3.01-2.2 for package: zm
--> Processing Dependency: libavcodec.so for package: zm
--> Processing Dependency: libavformat.so for package: zm
--> Processing Dependency: perl-Astro-SunTime for package: zm
--> Processing Dependency: perl-Archive-Tar for package: zm
--> Processing Dependency: perl-Time-modules for package: zm
--> Processing Dependency: perl-X10 for package: zm
--> Processing Dependency: libavutil.so for package: zm
--> Processing Dependency: perl-IO-Zlib for package: zm
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package perl-X10.noarch 0:0.03-1 set to be updated
---> Package perl-Archive-Tar.noarch 0:1.26-1 set to be updated
---> Package perl-MIME-Lite.noarch 0:3.01-2.2.el4.rf set to be updated
---> Package lame.i386 0:3.96.1-el42 set to be updated
---> Package perl-Compress-Zlib.i386 0:1.41-1 set to be updated
---> Package perl-Time-modules.noarch 0:2003.1126-1 set to be updated
---> Package zm-lat_ibay.i386 0:1.22.0-01.sme7 set to be updated
---> Package perl-IO-Zlib.noarch 0:1.04-1 set to be updated
---> Package ffmpeg.i386 0:0.4.9-cvs20051119 set to be updated
---> Package perl-Device-SerialPort.i386 0:1.002-1.2.el4.rf set to be updated
---> Package perl-Archive-Zip.noarch 0:1.16-1 set to be updated
---> Package perl-Astro-SunTime.noarch 0:0.01-1 set to be updated
--> Running transaction check
--> Processing Dependency: libtheora.so.0 for package: ffmpeg
--> Processing Dependency: libvorbisenc.so.2 for package: ffmpeg
--> Processing Dependency: libfaac.so.0 for package: ffmpeg
--> Processing Dependency: libvorbis.so.0 for package: ffmpeg
--> Processing Dependency: libSDL-1.2.so.0 for package: ffmpeg
--> Processing Dependency: libX11.so.6 for package: ffmpeg
--> Processing Dependency: libogg.so.0 for package: ffmpeg
--> Processing Dependency: libxvidcore.so.4 for package: ffmpeg
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg
--> Processing Dependency: libgsm.so.1 for package: ffmpeg
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for SDL to pack into transaction set.
SDL-1.2.7-8.i386.rpm 100% |=========================| 9.3 kB 00:00
---> Package SDL.i386 0:1.2.7-8 set to be updated
---> Package imlib2.i386 0:1.2.1-1 set to be updated
---> Downloading header for libvorbis to pack into transaction set.
libvorbis-1.1.0-1.i386.rp 100% |=========================| 6.1 kB 00:00
---> Package libvorbis.i386 1:1.1.0-1 set to be updated
---> Package xvidcore.i386 0:1.1.0-beta2.1.el42 set to be updated
---> Package faac.i386 0:1.24-1.2.el42 set to be updated
---> Downloading header for xorg-x11-libs to pack into transaction set.
xorg-x11-libs-6.8.2-1.EL. 100% |=========================| 281 kB 00:03
---> Package xorg-x11-libs.i386 0:6.8.2-1.EL.13.20 set to be updated
---> Downloading header for libogg to pack into transaction set.
libogg-1.1.2-1.i386.rpm 100% |=========================| 4.3 kB 00:00
---> Package libogg.i386 2:1.1.2-1 set to be updated
---> Package libtheora.i386 0:1.0alpha4-2 set to be updated
---> Package gsm.i386 0:1.0.10-0.el42 set to be updated
--> Running transaction check
--> Processing Dependency: libasound.so.2 for package: SDL
--> Processing Dependency: libfontconfig.so.1 for package: xorg-x11-libs
--> Processing Dependency: libGL.so.1 for package: xorg-x11-libs
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: SDL
--> Processing Dependency: libungif.so.4 for package: imlib2
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libungif to pack into transaction set.
libungif-4.1.3-1.i386.rpm 100% |=========================| 6.4 kB 00:00
---> Package libungif.i386 0:4.1.3-1 set to be updated
---> Downloading header for xorg-x11-Mesa-libGL to pack into transaction set.
xorg-x11-Mesa-libGL-6.8.2 100% |=========================| 249 kB 00:01
---> Package xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.13.20 set to be updated
---> Downloading header for fontconfig to pack into transaction set.
fontconfig-2.2.3-7.i386.r 100% |=========================| 11 kB 00:00
---> Package fontconfig.i386 0:2.2.3-7 set to be updated
---> Downloading header for alsa-lib to pack into transaction set.
alsa-lib-1.0.6-5.RHEL4.i3 100% |=========================| 11 kB 00:00
---> Package alsa-lib.i386 0:1.0.6-5.RHEL4 set to be updated
--> Running transaction check

Dependencies Resolved

=============================================================================
Package
Arch Version
Repository Size
=============================================================================
Installing:



zm i386 1.22.0-01.sme7 Chaapai 1.4M
Installing for dependencies:



SDL i386 1.2.7-8 base 202 k
alsa-lib i386 1.0.6-5.RHEL4 base 302 k
faac i386 1.24-1.2.el42 Chaapai 73 k
ffmpeg i386 0.4.9-cvs20051119 Chaapai 1.3M
fontconfig i386 2.2.3-7 smeos 116 k
gsm i386 1.0.10-0.el42 Chaapai 37 k
imlib2 i386 1.2.1-1 Chaapai 547 k
lame i386 3.96.1-el42 Chaapai 581 k
libogg i386 2:1.1.2-1 base 16 k
libtheora i386 1.0alpha4-2 Chaapai 631 k
libungif i386 4.1.3-1 base 39 k
libvorbis i386 1:1.1.0-1 base 185 k
perl-Archive-Tar noarch 1.26-1 Chaapai 43 k
perl-Archive-Zip noarch 1.16-1 Chaapai 137 k
perl-Astro-SunTime noarch 0.01-1 Chaapai 4.2 k
perl-Compress-Zlib i386 1.41-1 Chaapai 263 k
perl-Device-SerialPort i386 1.002-1.2.el4.rf Chaapai 82 k
perl-IO-Zlib noarch 1.04-1 Chaapai 14 k
perl-MIME-Lite noarch 3.01-2.2.el4.rf Chaapai 65 k
perl-Time-modules noarch 2003.1126-1 Chaapai 33 k
perl-X10 noarch 0.03-1 Chaapai 35 k
xorg-x11-Mesa-libGL 386 6.8.2-1.EL.13.20 base 373 k
xorg-x11-libs i386 6.8.2-1.EL.13.20 base 2.6 M
xvidcore i386 1.1.0-beta2.1.el42 Chaapai 230 k
zm-lat_ibay i386 1.22.0-01.sme7 Chaapai 6.9 k
Transaction Summary
=============================================================================
Install 26 Package(s)
Update 0 Package(s)
Remove 0 Package(s)
Total download size: 9.2 M
Is this ok [y/N]: y
Downloading Packages:

(1/26): SDL-1.2.7-8.i386. 100% |=========================| 202 kB 00:01
(2/26): perl-X10-0.03-1.n 100% |=========================| 35 kB 00:00
(3/26): libungif-4.1.3-1. 100% |=========================| 39 kB 00:00
(4/26): imlib2-1.2.1-1.i3 100% |=========================| 547 kB 00:00
(5/26): libvorbis-1.1.0-1 100% |=========================| 185 kB 00:00
(6/26): xvidcore-1.1.0-be 100% |=========================| 230 kB 00:00
(7/26): lame-3.96.1-el42. 100% |=========================| 581 kB 00:00
(8/26): perl-Compress-Zli 100% |=========================| 263 kB 00:00
(9/26): xorg-x11-Mesa-lib 100% |=========================| 373 kB 00:04
(10/26): faac-1.24-1.2.el 100% |=========================| 73 kB 00:00
(11/26): zm-lat_ibay-1.22 100% |=========================| 6.9 kB 00:00
(12/26): fontconfig-2.2.3 100% |=========================| 116 kB 00:00
(13/26): perl-IO-Zlib-1.0 100% |=========================| 14 kB 00:00
(14/26): ffmpeg-0.4.9-cvs 100% |=========================| 1.3 MB 00:00
(15/26): xorg-x11-libs-6. 100% |=========================| 2.6 MB 00:04
(16/26): libogg-1.1.2-1.i 100% |=========================| 16 kB 00:00
(17/26): perl-Time-module 100% |=========================| 33 kB 00:00
(18/26): perl-MIME-Lite-3 100% |=========================| 65 kB 00:00
(19/26): perl-Astro-SunTi 100% |=========================| 4.2 kB 00:00
(20/26): libtheora-1.0alp 100% |=========================| 631 kB 00:00
(21/26): gsm-1.0.10-0.el4 100% |=========================| 37 kB 00:00
(22/26): alsa-lib-1.0.6-5 100% |=========================| 302 kB 00:02
(23/26): perl-Archive-Zip 100% |=========================| 1.7 kB 00:00
(24/26): zm-1.22.0-01.sme 100% |=========================| 1.4 MB 00:00
(25/26): perl-Archive-Tar 100% |=========================| 43 kB 00:00
(26/26): perl-Device-Seri 100% |=========================| 82 kB 00:00
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: perl-Time-modules ####################### [ 1/26]
Installing: perl-Astro-SunTime ####################### [ 2/26]
Installing: perl-Device-SerialPort ####################### [ 3/26]
Installing: libogg ####################### [ 4/26]
Installing: perl-Compress-Zlib ####################### [ 5/26]
Installing: lame ####################### [ 6/26]
Installing: perl-Archive-Zip ####################### [ 7/26]
Installing: libvorbis ####################### [ 8/26]
Installing: perl-X10 ####################### [ 9/26]
Installing: perl-Archive-Tar ####################### [ 10/26]
Installing: alsa-lib ####################### [ 11/26]
Installing: gsm ####################### [ 12/26]
Installing: libtheora ####################### [ 13/26]
Installing: perl-MIME-Lite ####################### [ 14/26]
Installing: perl-IO-Zlib ####################### [ 15/26]
Installing: fontconfig ####################### [ 16/26]
Installing: zm-lat_ibay ####################### [ 17/26]
Installing: faac ####################### [ 18/26]
Installing: xvidcore ####################### [ 19/26]
Installing: xorg-x11-libs ####################### [ 20/26]
Installing: SDL ####################### [ 21/26]
Installing: libungif ####################### [ 22/26]
Installing: imlib2 ####################### [ 23/26]
Installing: ffmpeg ####################### [ 24/26]
Installing: xorg-x11-Mesa-libGL ####################### [ 25/26]
Creating ibay 'zoneminder' (Uid:5001).
Installing:
zm
#######################
[26/26]
Install ZoneMinder DB 1.22.0
Starting ZoneMinder: [ OK ]
************* Installation terminated **************
Please, go to http://your_server/zoneminder and
change admin password of zoneminder
login= admin passwd= admin

Installed: zm.i386 0:1.22.0-01.sme7
Dependency Installed: SDL.i386 0:1.2.7-8 alsa-lib.i386 0:1.0.6-5.RHEL4 faac.i386 0:1.24-1.2.el42 ffmpeg.i386 0:0.4.9-cvs20051119 fontconfig.i386 0:2.2.3-7 gsm.i386 0:1.0.10-0.el42 imlib2.i386 0:1.2.1-1 lame.i386 0:3.96.1-el42 libogg.i386 2:1.1.2-1 libtheora.i386 0:1.0alpha4-2 libungif.i386 0:4.1.3-1 libvorbis.i386 1:1.1.0-1 perl-Archive-Tar.noarch 0:1.26-1 perl-Archive-Zip.noarch 0:1.16-1 perl-Astro-SunTime.noarch 0:0.01-1 perl-Compress-Zlib.i386 0:1.41-1 perl-Device-SerialPort.i386 0:1.002-1.2.el4.rf perl-IO-Zlib.noarch 0:1.04-1 perl-MIME-Lite.noarch 0:3.01-2.2.el4.rf perl-Time-modules.noarch 0:2003.1126-1 perl-X10.noarch 0:0.03-1 xorg-x11-Mesa-libGL.i386 0:6.8.2-1.EL.13.20 xorg-x11-libs.i386 0:6.8.2-1.EL.13.20 xvidcore.i386 0:1.1.0-beta2.1.el42 zm-lat_ibay.i386 0:1.22.0-01.sme7
Complete!
[root@serveur-crashtest1 ~]#


Have a nice day !

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #1 on: February 02, 2006, 07:15:45 PM »
Looks good Chaapai!  Just one suggestion, could you remove this line:
/sbin/e-smith/db yum_repositories setprop base status enabled

...and then your yum command can be:
yum --enablerepo=base install zm

there may also be some updates for rpms from from Centos, in which case you could add "--enablerepo=updates" to that as well.

The reason for doing it like this is to avoid installing rpms that the developers don't intend you to install through a regular yum update.  That is why base and updates are disabled by default now.

Also please email staff_at_contribs.org and request a directory on contribs.org to store your files :-)

chaapai

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #2 on: February 02, 2006, 08:06:46 PM »
re-hello all !

Thank you, i have removed the line, so, for others don't forget to do a
(little error in log: setprop and not set ...outch)

Code: [Select]
db yum_repositories setprop base repository status disabled
/sbin/e-smith/expand-template /etc/yum.conf


have a nice day

Offline fpausp

  • *
  • 728
ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #3 on: February 10, 2006, 12:11:40 AM »
Hi Chaapai,

What Hardware do you use with sme7 and zoneminder ?
I have a hauppauge impact vcb but i like a more powerful card (4 cams), the card should run without any changes on sme7 (just plug and play) ?

fpausp
Viribus unitis

chaapai

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #4 on: February 10, 2006, 12:10:09 PM »
Hello all!

I use the last technology for server, my config his a powerfull Duron 1Ghz with 640 mo SDRAM PC133, two hdd40 go  :-D
For cameras, i have a old quickcam express (usb)  and a Xguard (4cams) each canal of xguard is captured at ~2.5 fps
for more info on my config:
phpsysinfo: http://www.chaapai.homelinux.net/w_stats/index.php
and monitoring server:http://www.chaapai.homelinux.net/w_stats/cgi-bin/sys_monitoring

Well, your "hauppauge impact vcb" use bttv driver, so you can install bttv driver and your card:
enable my repository,
tape yum install kernel-module-bttv, for install bttv driver
halt your server and put your card
restart your server
check your log in /var/log/message to see if your card is detected.
config zoneminder with :
Code: [Select]
device: /dev/videoX channel: 0 X depend of your config (see in /var/log/message)
device: /dev/videoX channel: 1
device: /dev/videoX channel: 2
 

if you have problems with your card you can add in /etc/modprobe.conf  (WARNING TEMPLATE: /etc/e-smith/modprobe.conf)
Code: [Select]
options bttv card=82 tuner=4
and reboot (add this line only if you have problem)

Offline fpausp

  • *
  • 728
ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #5 on: February 10, 2006, 06:43:37 PM »
Hi,

Yes thats working but only on /dev/video0 (0) and /dev/video0 (1). I have done a test with (2) and (3) but they are black.

regards
fpausp
Viribus unitis

Offline ldkeen

  • *
  • 385
ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #6 on: March 14, 2006, 09:37:07 AM »
Hi Chaapai,
I've been trying to install on 7.0pre4 for a couple of days now and keep getting this error:

Code: [Select]

==============================================================
WARNING: Additional commands may be required after running yum
==============================================================
Setting up Install Process
Setting up repositories
ftp://ftp.chaapai.homelinux.net/yum-smeserver/7.0pre1/smechaapai/i386/repodata/repomd.xml: [Errno 4] IOError: [Errno ftp error] timed out
Trying other mirror.
Cannot open/read repomd.xml file for repository: Chaapai
failure: repodata/repomd.xml from Chaapai: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from Chaapai: [Errno 256] No more mirrors to try.
================================================================
No new rpms were installed. No additional commands are required.
================================================================


I thought maybe there may have been a problem with the server but its beenlike that for a few days. Any ideas??
Regards Lloyd

jazbokes

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #7 on: March 18, 2006, 09:21:01 PM »

Offline byte

  • *
  • 2,183
ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #8 on: April 12, 2006, 06:31:12 PM »
Great work chaapai, I've been having a problem d/l the files as well, is it possible to upload them to contribs.org so we can have a stable link?

Thanks again for your efforts this seems ideal what I'm after !
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

mlinden

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #9 on: May 23, 2006, 11:05:48 PM »
Hello Chaapai,


Whitch driver did you used for your old quickcam express (usb).

Regards,

mlinden

Offline fpausp

  • *
  • 728
ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #10 on: June 02, 2006, 09:49:05 AM »
Hi,

I like to install zm on rc2, is that possible with rpm´s from chaapai ?

I tried to download pre1 or pre2 but i got everytime the rc2 ???

regards
fpausp
Viribus unitis

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #11 on: August 02, 2006, 03:37:49 AM »
Hi chaapai,

I tried installing the bttv driver using yum, but it was looking for the pre1 image in /boot/
I've used SME for some time now, but I'm still a linux novice.
were you planning on updating the repository to reflect the stable SME 7?
otherwise I'll have to use another distro that is idiot proof :hammer:
cheers
.........

dazza76

Zoneminder sme7
« Reply #12 on: August 07, 2006, 08:44:12 AM »
Any chance of an update to 1.22.2
as there is some important fixes
or a breif howto

Cheers Darren

novatux

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #13 on: August 17, 2006, 12:46:43 PM »
well  first sorry for my poor english

I install zoneminder in a new SME server 7.0 Final with de CHAAPAI indications. I only change minus things (previus activate centos rpos for YUM and install more package of Centos )

Well zoneminder run OK, only I have a problem no with zoneminder, the problem is with the module necesary for my video-capture pci target.

is that
with lspci -v
Code: [Select]

02:0d.0 Multimedia video controller: Zoran Corporation ZR36057PQC Video cutting chipset (rev 02)
        Subsystem: Miro Computer Products AG DC10 Plus
        Flags: bus master, fast devsel, latency 64, IRQ 225
        Memory at feafe000 (32-bit, non-prefetchable) [size=4K]


I download driver of zoran target driver-zoran-0.9.5.tar.gz

but my problem is when y make, the system say my that.
Code: [Select]

[root@antares driver-zoran-0.9.5]# make
Making Unified Zoran (zr360x7) driver for 2.6.9-34.0.2.ELsmp kernel...
make[1]: Entering directory /lib/modules/2.6.9-34.0.2.ELsmp/kernel'
make[1]: *** No hay ninguna regla para construir el objetivo modules'.  Alto.
make[1]: Leaving directory /lib/modules/2.6.9-34.0.2.ELsmp/kernel'
make: *** [here] Error 2


I'm not an expert in linux system, its posible help me please¿?

Thanks

NovaTUX el mas novato de los TUX

ZoneMinder-1.22.0 for SME-7.0pre1 for test
« Reply #14 on: August 22, 2006, 10:31:40 AM »
Quote from: "jazbokes"
Try this mirror site;

ftp://ftp.zinside.org/pub/yum-smeserver/7.0pre1/smechaapai/i386/

Hi
I've tried both sites and still get the error
Code: [Select]
Error: failure: CentOS/RPMS/perl-Compress-Zlib-1.41-1.2.el4.rf.i386.rpm from smeos: [Errno 256] No more mirrors to try.
================================================================
No new rpms were installed. No additional commands are required.
================================================================


Any ideas please?
N