Koozali.org formerly Contribs.org

Contribs.org Forums => SME Server 9.x => Topic started by: darmasanthi on October 23, 2018, 10:43:33 AM

Title: New Installation SMESERVER 9.2 - Yum Update Error
Post by: darmasanthi on October 23, 2018, 10:43:33 AM
Hi,
I just installing new smeserver 9.2,
i cannot running the yum update,
i have this error messages

[root@controller ~]# yum update
Loaded plugins: fastestmirror, smeserver
Setting up Update Process
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.centos.org/?release=6&arch=x86_64&repo=os error was
14: PYCURL ERROR 6 - "Couldn't resolve host 'mirrorlist.centos.org'"
Error: Cannot find a valid baseurl for repo: base

I try to ping to the internet gateway (IP) without any issues,
I can ping to 8.8.8.8, but cannot ping to google.com
and i try to ping centos.org there is no reply, but i can ping to : 85.12.30.226

please kindly your help, what is the cause of this problem

regards,
darmasanthi
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Drifting on October 23, 2018, 11:31:59 AM
Not that I am an expert of anything.

But what is the configuration you are running? Server? Gateway Server? How many Nic's? And their IP's? Might be able to suggest a few things for you then.

Paul.
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: darmasanthi on October 23, 2018, 11:37:05 AM
Not that I am an expert of anything.

But what is the configuration you are running? Server? Gateway Server? How many Nic's? And their IP's? Might be able to suggest a few things for you then.

Paul.

The server are running with Server only, with 2 NIC's, the IP: 192.168.0.3/24 with gateway : 192.168.0.1

thank you,
darmasanthi
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Drifting on October 23, 2018, 11:45:24 AM
Hi,
I would go back to basics, disable one of your nic in the bios, then go to the console and reconfigure it all again. Sounds like your DNS is not resolving? Make sure you do not put entries for the DNS, SME is a great DNS resolver in itself. As long as your DFG is right, and by what you say it looks it, and is probably your router, then all should be well. I assume you used the router with other machines and can confirm you can resolve names from them?

Sorry if I am teaching my grandmother etc...

Paul.
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: darmasanthi on October 23, 2018, 11:56:58 AM
Hi,
I would go back to basics, disable one of your nic in the bios, then go to the console and reconfigure it all again. Sounds like your DNS is not resolving? Make sure you do not put entries for the DNS, SME is a great DNS resolver in itself. As long as your DFG is right, and by what you say it looks it, and is probably your router, then all should be well. I assume you used the router with other machines and can confirm you can resolve names from them?

Sorry if I am teaching my grandmother etc...

Paul.

Hi Paul
I had been trying that way, by disabling one of the NIC and processing reconfigure - but with no luck

regards,
darmasanthi
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Drifting on October 23, 2018, 01:02:38 PM
From a terminal, what does ifconfig give you? Post it here.

Probably something annoyingly simple, I know those only too well :-)
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Daniel B. on October 23, 2018, 01:57:09 PM
The problem is a DNS resolving one. Either you have configured a DNS forwarder which doesn't work, or your sme can't outbound on port 53 to do it's own resolving
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: darmasanthi on March 07, 2019, 12:16:15 PM
From a terminal, what does ifconfig give you? Post it here.

Probably something annoyingly simple, I know those only too well :-)

Hi, just have time,
here is the info we got:

[root@controller ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:1E:67:53:13:BC
          inet addr:192.168.0.3  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:705312791 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1023486487 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:146838087343 (136.7 GiB)  TX bytes:1058995033018 (986.2 GiB)
          Interrupt:16 Memory:d0900000-d0920000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1364597 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1364597 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:111601357 (106.4 MiB)  TX bytes:111601357 (106.4 MiB)

regards,
darmasanthi
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Jean-Philippe Pialasse on March 07, 2019, 01:55:37 PM
Fresh install of sme 9.2, not updated
Two identical NIC I presume
I also presume you set nic bonding.


Known issue  as per the release page on wiki

SME 9.2 ISO only, DO NOT enable nic bonding on an initial install when server only mode is selected.
If your hardware has two network adapters installed or there are two nics configured in a VM and you have selected server only mode during the install you will be offered the opportunity to enable bonding of the nics, the current SME 9.2 ISO has an issue with this initial configuration and a loss of connectivity will result on reboot. DO NOT enable bonding on initial install, carry out a yum update after initial install and then reconfigure and enable bonding if that is your wish.


Reconfigure server without nic bonding.

Update

Reconfigure with nic bonding.

Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: Jean-Philippe Pialasse on March 07, 2019, 01:58:30 PM
Ok no from your last post i see no nic bonding.


This more likely a firewall issue as point Daniel. You might need to configure your gateway as dns server for the sme , or pinhole the gateway firewall to allo sme to access dns port 53 over the internet.
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: darmasanthi on April 24, 2019, 12:18:47 AM
Ok no from your last post i see no nic bonding.


This more likely a firewall issue as point Daniel. You might need to configure your gateway as dns server for the sme , or pinhole the gateway firewall to allo sme to access dns port 53 over the internet.

had been trying this method, but with no luck,
until I found on some forums mention that need to change the /etc/resolv.conf
by adding the "nameserver ip-gateway"

after that the yum upadate is running without any issues.

But, this is not good, since after the server is restarted, I still have the same issues

regards,
darmasanthi
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: ReetP on April 24, 2019, 01:24:11 AM
So what was originally in your /etc/resolv.conf ?

Also what does this show?

Code: [Select]
config show dnscache
Title: Re: New Installation SMESERVER 9.2 - Yum Update Error
Post by: janet on April 24, 2019, 02:05:59 AM
darmasanthi

What is this gateway device you mentioned earlier ?
"gateway : 192.168.0.1"

Is it another Koozali sme server & is it in server gateway mode, or is it some other device (Router) ?

In the configuration of the problematic sme server (that is in server only mode), did you specify the gateway IP in the "Configure this server" screens in the admin console ?

You need to tell secondary sme servers where the gateway is so that DNS resolving can work correctly.