Koozali.org formerly Contribs.org

Obsolete Releases => SME 8.x Contribs => Topic started by: windowsxp on March 23, 2016, 02:55:26 PM

Title: Sogo Installation SME 8.2
Post by: windowsxp on March 23, 2016, 02:55:26 PM
Hy everboy,
i cant install Sogo on SME 8.2. Can it be that it is no longer the repository available.
We restore a backup on 8.2. Are my Sogo data now away?

Best regards
XP
Title: Re: Sogo Installation SME 8.2
Post by: Stefano on March 23, 2016, 05:40:29 PM
please, define "I can't install Sogo on SME 8.2", thank you

what did you do? have you any error?
Title: Re: Sogo Installation SME 8.2
Post by: windowsxp on March 24, 2016, 09:35:17 AM
Excluding Packages from CentOS - os
Finished
Reducing Inverse SOGo Repository to included packages only
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package smeserver-sogo.noarch 0:1.1-3.el5.sme set to be updated
--> Processing Dependency: sogo >= 2.1.1b-1 for package: smeserver-sogo
--> Processing Dependency: sogo-tool for package: smeserver-sogo
--> Processing Dependency: sope49-gdl1-mysql for package: smeserver-sogo
--> Processing Dependency: memcached for package: smeserver-sogo
--> Running transaction check
---> Package memcached.i386 0:1.4.5-1.el5 set to be updated
--> Processing Dependency: libevent-1.4.so.2 for package: memcached
--> Processing Dependency: libevent for package: memcached
---> Package sogo.i386 0:2.3.9-1.el5 set to be updated
--> Processing Dependency: sope49-gdl1-contentstore >= 2.3.9 for package: sogo
--> Processing Dependency: gnustep-base >= 1.23 for package: sogo
--> Processing Dependency: sope49-cards >= 2.3.9 for package: sogo
--> Processing Dependency: sope49-sbjson for package: sogo
--> Processing Dependency: libmemcached for package: sogo
--> Processing Dependency: sope49-ldap for package: sogo
--> Processing Dependency: sope49-appserver for package: sogo
--> Processing Dependency: sope49-core for package: sogo
---> Package sogo-tool.i386 0:2.3.9-1.el5 set to be updated
---> Package sope49-gdl1-mysql.i386 0:4.9-20160316_1664.el5.1 set to be updated
--> Processing Dependency: sope49-gdl1 for package: sope49-gdl1-mysql
--> Running transaction check
---> Package gnustep-base.i386 0:1.23.0-1 set to be updated
--> Processing Dependency: gnustep-make >= 2.6.0 for package: gnustep-base
--> Processing Dependency: libobjc.so.1 for package: gnustep-base
--> Processing Dependency: libffi.so.5 for package: gnustep-base
---> Package libevent.i386 0:1.4.13-1 set to be updated
---> Package libmemcached.i386 0:0.34-1 set to be updated
---> Package sope49-appserver.i386 0:4.9-20160316_1664.el5.1 set to be updated
--> Processing Dependency: sope49-mime for package: sope49-appserver
--> Processing Dependency: sope49-xml for package: sope49-appserver
---> Package sope49-cards.i386 0:2.3.9-1.el5 set to be updated
---> Package sope49-core.i386 0:4.9-20160316_1664.el5.1 set to be updated
---> Package sope49-gdl1.i386 0:4.9-20160316_1664.el5.1 set to be updated
---> Package sope49-gdl1-contentstore.i386 0:2.3.9-1.el5 set to be updated
---> Package sope49-ldap.i386 0:4.9-20160316_1664.el5.1 set to be updated
---> Package sope49-sbjson.i386 0:2.3.1-20160316_1664.el5.1 set to be updated
--> Running transaction check
---> Package gnustep-base.i386 0:1.23.0-1 set to be updated
--> Processing Dependency: gnustep-make >= 2.6.0 for package: gnustep-base
---> Package libffi.i386 0:3.0.5-1.el5 set to be updated
---> Package libobjc.i386 0:4.1.2-55.el5 set to be updated
---> Package sope49-mime.i386 0:4.9-20160316_1664.el5.1 set to be updated
---> Package sope49-xml.i386 0:4.9-20160316_1664.el5.1 set to be updated
--> Finished Dependency Resolution
gnustep-base-1.23.0-1.i386 from sogo has depsolving problems
  --> Missing Dependency: gnustep-make >= 2.6.0 is needed by package gnustep-base-1.23.0-1.i386 (sogo)
Error: Missing Dependency: gnustep-make >= 2.6.0 is needed by package gnustep-base-1.23.0-1.i386 (sogo)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Whats the Problem?
Title: Re: Sogo Installation SME 8.2
Post by: Stefano on March 24, 2016, 10:21:41 AM
it seems that you have to include gnustep-make package in your Sogo repo config

Code: [Select]
db yum_repositories set sogo repository \
    BaseURL http://inverse.ca/downloads/SOGo/RHEL5/\$basearch \
    EnableGroups yes \
    GPGCheck no \
    Name "Inverse SOGo Repository" \
    IncludePkgs gnustep-base,gnustep-make,libmemcached,libwbxml,sogo*,sope49* \
    Visible yes \
    status disabled

note: not tested, should work, please give us feedback.. it it works, please edit wiki page accordingly (ask for a wiki access if you don't have any)
Title: Re: Sogo Installation SME 8.2
Post by: windowsxp on May 31, 2016, 02:59:32 PM
Sorry for my late answer .

The solution from Stefano works, thanks  8-)
Title: Re: Sogo Installation SME 8.2
Post by: Jean-Philippe Pialasse on June 01, 2016, 05:58:40 AM
updated wiki

https://wiki.contribs.org/Sogo#For_SME_8

added it also for SME9, I guess the problem would be the same

Title: Re: Sogo Installation SME 8.2
Post by: guest22 on June 01, 2016, 06:34:43 AM
added it also for SME9, I guess the problem would be the same


No, it is not the same. We should not change repo configurations based on guesses.
Title: Re: Sogo Installation SME 8.2
Post by: Jean-Philippe Pialasse on June 01, 2016, 06:43:23 AM

No, it is not the same. We should not change repo configurations based on guesses.
the same software will need the same dependencies.

https://pkgs.org/search/gnustep-make

shows that gnustep-make is not available for centos5, but is for centos6 and centos7.
The version available in the sogo repo is however older than those of centos6 . However gnustep-base is more recent.
Title: Re: Sogo Installation SME 8.2
Post by: guest22 on June 01, 2016, 07:07:33 AM
The wiki holds a category for repositories. For SoGo it is https://wiki.contribs.org/Sogo-repo


So the Sogo wiki page now differs from the Sogo-repo, hence I never copy the repo config into a wiki page, but refer to the 'official' repository.


Anyway, I have always used https://wiki.contribs.org/Sogo-repo to install SoGo on a Koozali SME Server 9.x, never had a problem.
Title: Re: Sogo Installation SME 8.2
Post by: Jean-Philippe Pialasse on June 01, 2016, 07:25:30 AM
The wiki holds a category for repositories. For SoGo it is https://wiki.contribs.org/Sogo-repo


So the Sogo wiki page now differs from the Sogo-repo, hence I never copy the repo config into a wiki page, but refer to the 'official' repository.

then please proceed with the correct wiki template syntaxe to fill the holes with the repo page values.
Title: Re: Sogo Installation SME 8.2
Post by: guest22 on June 01, 2016, 07:28:41 AM
then please proceed with the correct wiki template syntaxe to fill the holes with the repo page values.


No idea what this means, but more importantly, we're going off topic. Signing off from this topic.
Title: Re: Sogo Installation SME 8.2
Post by: stephdl on June 01, 2016, 08:08:30 AM
I'm not at home currently, i will have a look on this asap
Title: Re: Sogo Installation SME 8.2
Post by: stephdl on June 06, 2016, 07:52:49 PM
 gnustep-make                                               x86_64                                   2.6.2-1.el6                                                   epel                                      265 k

 gnustep-make is available in epel also