Koozali.org formerly Contribs.org

Obsolete Releases => SME 7.x Contribs => Topic started by: kryptos on April 17, 2013, 11:12:49 AM

Title: smeserver-dar2 problem restoring folders
Post by: kryptos on April 17, 2013, 11:12:49 AM
Hi all,

Recently was asked to restore folders from the backup generated from my Dar Archive menu. I have tried the restore procedure from this menu. But when I check the destination folder that I choose where the restore will be save It only creates a folder but not the files in it.

this is my settings when doing the restore.

Disaster Recovery: Disabled
Restore: home/files/ibays/ibayfoldername/files/somefolder
Restore to: /root/serverback


No errors during this process but no files being recovered.  I have tried DR options before it works but not with selective restore. Any ideas what I have missing here?


Regards,
Rocel
Title: Re: smeserver-dar2 problem restoring folders
Post by: piran on April 17, 2013, 12:41:01 PM
WAS: Restore: /home/files/ibays/ibayfoldername/files/somefolder
NOW: Restore: home/files/ibays/ibayfoldername/files/somefolder
Title: Re: smeserver-dar2 problem restoring folders
Post by: Stefano on April 17, 2013, 03:25:43 PM
@piran: is it documented?
Title: Re: smeserver-dar2 problem restoring folders
Post by: kryptos on April 17, 2013, 07:57:29 PM
WAS: Restore: /home/files/ibays/ibayfoldername/files/somefolder
NOW: Restore: home/files/ibays/ibayfoldername/files/somefolder

Sorry I was using the second option without the "/" before home. I just edit my first post.

Title: Re: smeserver-dar2 problem restoring folders
Post by: kryptos on April 17, 2013, 08:04:15 PM
@piran: is it documented?

It was not documented but it was just explained briefly in the restore page itself. Hope that it will be thoroughly explained on the wiki like restore only a file and restoring folder is buggy as far as what I have encountered I might be wrong though.

Regards,
Rocel
Title: Re: smeserver-dar2 problem restoring folders
Post by: piran on April 17, 2013, 08:29:02 PM
Sorry for the delay (called out for some hospital run duty).

@Stefano: Yes (-ish). The contrib's instructive example clearly
but briefly shows that no "/" is used. Easily overlooked though
which was why I...

@kryptos: ...typed it up as I did, to emphasize the required but
missing "/". I have used the DAR2 contrib for years to selectively
replace accidently overwritten or deleted files - never failed me.
YMMV (Well, clearly it did vary! It has always worked for me.)
Title: Re: smeserver-dar2 problem restoring folders
Post by: piran on April 17, 2013, 08:36:37 PM
@kryptos: The messages log should help you sleuth
out what or where it is going wrong for you. It's very
probably a permissions thing. If you go for the restore
to "/" (ie the original place) then any permissions should
match up without much further thought:-)
Title: Re: smeserver-dar2 problem restoring folders
Post by: kryptos on April 18, 2013, 10:06:55 AM
yup did as you have emphasized still no restore files where restored.Also the logs says it successful no error message.


Will look into permission I though it doesn't matter.

Regards.
Rocel
Title: Re: smeserver-dar2 problem restoring folders[solved]
Post by: kryptos on April 19, 2013, 08:33:51 AM
Successfully able to restore the folder. the culprit is as I have notice if restoring a folder it needs to add "/" at the end. So it would be like this.


restore: home/e-smith/files/ibays/someibayname/files/somefoldername/

note: no "/"  in beginning and with "/" at the end.

restore to: /anyfolderdestanation/


I now as able to restore the missing folders. Thanks SME

Regards,
Rocel