Koozali.org formerly Contribs.org

Legacy Forums => Experienced User Forum => Topic started by: berdie on July 12, 2005, 12:10:56 PM

Title: 7.0 alpha with external proxy
Post by: berdie on July 12, 2005, 12:10:56 PM
Hi everyone,

I would like to test the 7.0-alpha, but for internet-access I need an external proxy with port-number, user and password.
I think this is possible in the actually 6.01-Version.
Would this be available in the 7.0-Version again?
How can I configure this in 7.0-alpha without the server-console?

Rgds.

Dietmar
Title: Re: 7.0 alpha with external proxy
Post by: CharlieBrady on July 12, 2005, 11:14:20 PM
Quote from: "berdie"

I would like to test the 7.0-alpha, but for internet-access I need an external proxy with port-number, user and password.
I think this is possible in the actually 6.01-Version.
Would this be available in the 7.0-Version again?
How can I configure this in 7.0-alpha without the server-console?


6.x only has support for an anonymous parent cache - there is on mechanism to provide a username and password for the upstream cache.

To configure 7.0 alpha to use a parent cache, do:

config set SquidParent x.x.x.x
config set SquidParnentPort nnn
signal-event proxy-update

If you do need to authenticate to your upstream cache, then you will need to create a custom template, and add
"login=user:password" to the cache-peer line in squid.conf.
Title: 7.0 alpha with external proxy
Post by: berdie on July 15, 2005, 11:28:08 AM
Hi Charly,

thanks a lot for your info. But unfortunally this don't help me.
I think, I forgot to say that I also need the way to config my SME 7alpha in connection to another DNS-controller.
Can you help me again?

Rgds.

Dietmar
Title: 7.0 alpha with external proxy
Post by: tariqf on June 04, 2007, 06:40:52 PM
I have tried this on sme 7.1.3 but whenever I try to use internet from a client I get this error in /var/log/messages and a page in the browser saying "unable to forward this request at this time"


Jun  4 17:39:08 wild-auth squid[19170]: Failed to select source for 'http://www.google.com/'
Jun  4 17:39:08 wild-auth squid[19170]:   always_direct = -1
Jun  4 17:39:08 wild-auth squid[19170]:    never_direct = 1
Jun  4 17:39:08 wild-auth squid[19170]:        timedout = 0



Any idea what I can do to make this work?