Koozali.org formerly Contribs.org

Legacy Forums => Experienced User Forum => Topic started by: Jim Danvers on October 15, 2003, 03:52:35 AM

Title: <<6.0b3>> HTTP Directory Browsing Solved (almost
Post by: Jim Danvers on October 15, 2003, 03:52:35 AM
Ok guys...

After messing with this thing on and off throughout the day (I am supposed to actually ~do~ something while here @work after all.... lol! ) I have managed to get this thing working, BUT - I suspect that my solution is temporary at present due to the way that SME re-builds .conf files if/whenever the box gets restarted.

Long story short, I thought that I had it solved by perusing through this thread:  http://forums.contribs.org/index.php?topic=17005.msg65931#msg65931

I took the /etc/e-smith/templates/etc/httpd/conf/httpd.conf/90e-smithAccess40ibays file and copied it to the place where custom templates go (can these paths be any deeper???  What a pia to have to keep typing over & over!! ) and added the line per the suggestion by the person called Sascha.  I then expanded the template (I think, guess...  {shrug shoulders - never done this before... } using this command as referenced from the e-smith/custom web page:

/sbin/e-smith/expand-template /etc/httpd/conf/httpd.conf

I think (I've tried so many things I can't remenber 'em all!) I then simply re-booted the server.  Didn't work.  ;(

So.....   I grabbed any data that I had in the existing ibay and backed it up to someplace else (ghost image files) and blew it away.  I re-created it (using a slightly different name) and then tried a variation of Rich Lafferty's suggestion which is the post right before the Sascha persons idea.   I edited the httpd.conf file ~directly~ (the one in use at /etc) and changed the relevant line so that it reads like so (screen shot):

#------------------------------------------------------------
# ghostimages ibay directories (pc image files storage)
#------------------------------------------------------------


    Options Indexes
    Options +FollowSymlinks +Includes
    AllowOverride None
    order deny,allow
    deny from all
    allow from all


I then dumped the saved image files back into the ibay ../files directory and created a symlink to it.  I used an explicit directory path this time in the sym also, ie; /home/e-smith/files/ibays/.. etc...  instead of my previous symlink of ../files like I did previously (as the link will be viewed from a web browser out of the ../html directory).  Seem like ../files should (and probably will?) work - but I decided to just hit it explicitly....

Anyway - it works!  ;)  ;)  ;)

Problem is... its likely to go away the next time I have to restart this machine, right? ;(  ;(  ;(

How or what do I do to make it perm?  It has to be in the custom fragment file thing (I would assume)...  I'm tired and hungry (again!) - back to this later.

Thanks much for any help folks!

-=- jd -=-
Title: Re: <<6.0b3>> HTTP Directory Browsing Solved (al
Post by: Ergin on October 15, 2003, 10:28:20 AM
You can save your settings at

/etc/e-smith/templates-custom/etc/httpd/conf/httpd/conf/

If you read Gallery Howto av Dan Brown at
http://www.familybrown.org/howtos/gallery-howto-sme55.html you'll understand how this works. Good luck.
Title: <<6.0b3>> HTTP Directory Browsing Solved (almost
Post by: goose on March 03, 2004, 04:18:09 PM
You complain about deep directory structure and typing it all. Have you tried Midnight Commander?

 :idea: Type "mc" in the command shell