Koozali.org formerly Contribs.org

Legacy Forums => Experienced User Forum => Topic started by: Daniel on January 07, 2002, 02:49:35 AM

Title: win 2k/xp joining a samba domain
Post by: Daniel on January 07, 2002, 02:49:35 AM
hi there,

i'm running e-smith server 5.0, with update 3 installed

i was trying to join a windows 2000/XP computer to my samba domain.

i  did the updates to the lates version of samba and followed the instuctions
http://www.myezserver.com/docs/mitel/samba-upgrade-howto.html

i created the user root, so i could add the computer to the domain. but every time i tryed to join the domain i would get the following error. "The procedure number is out of range."

i installed SP1 and SP2 on my computer, but still no luck.

so i installed windows xp.

still got the same problem.

any thoughts?
Title: Re: win 2k/xp joining a samba domain
Post by: Rick on January 07, 2002, 11:14:03 AM
have you checked the registry as per the how to?

I'm interested to know before I upgrade from 4.12 to 5 as all my client machines run XP

Windows 2000/XP Registry Settings

It is suggested that you check the following registry entries which should be set to (0).  This is the default under W2K (but check to confirm) however under XP the default is (1) and definitely needs changing:

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Netlogon\Parameters]
"requirestrongkey"=dword:00000000
"requiresignorseal"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Netlogon\Parameters]
"requirestrongkey"=dword:00000000
"requiresignorseal"=dword:00000000
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters]
"requirestrongkey"=dword:00000000
"requiresignorseal"=dword:00000000
Title: Re: win 2k/xp joining a samba domain
Post by: Daniel on January 07, 2002, 03:46:55 PM
yes, i checked the settings, but i still get the same error.
Title: Re: win 2k/xp joining a samba domain
Post by: Bill Blyth on January 08, 2002, 03:29:20 PM
Try this.

On the win2k/XP client go to.

Administrative tools/local security policy/local policies/security options.

Enable the line that reads: Send encrypted password to connect to third-party SMB servers.

Good luck.
Title: Re: win 2k/xp joining a samba domain
Post by: Daniel on January 08, 2002, 04:34:25 PM
no, still be the same error.
Title: Re: win 2k/xp joining a samba domain
Post by: Dave Reinhardt on January 11, 2002, 07:55:46 AM
You said>>Administrative tools/local security policy/local policies/security options.

  Enable the line that reads: Send encrypted password to connect to third-party SMB servers.

Do you know where this is in winXP.

I have a XP machine that has no problems accessing the server 4.1.2

I have a new full version winXP that can only access some of the iBays on the server.

I have checked the registry.
the one that has no problems says:
[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Netlogon\Parameters]
  "requirestrongkey"=dword:00000000
  "requiresignorseal"=dword:00000001

Looking for some ideas...
Dave
Title: Re: win 2k/xp joining a samba domain
Post by: Ari on January 19, 2002, 02:49:07 AM
Just out of morbid curiousity....

Is it XP Home or XP Pro?

There's a reason I ask.

XP Home does NOT support domain logon, just workgroups.
Title: Re: win 2k/xp joining a samba domain
Post by: Dave Reinhardt on January 19, 2002, 03:06:18 AM
Sorry, I should have included they are both XP home
Also I ran the XP network wizard on the floppy disc in another win98 computer and it removed all my IP addresses.
Title: Re: win 2k/xp joining a samba domain
Post by: Lucky Dragon on April 24, 2007, 11:34:12 AM
Quote from: "Bill Blyth"
Try this:
On the win2k/XP client go to:
Administrative tools/local security policy/local policies/security options.
Enable the line that reads: Send encrypted password to connect to third-party SMB servers.

I was also having trouble getting this working, but your suggestion resolved my issue. I checked the suggested registry keys first, but they were already set correctly.

Thanks!!!  :D
Title: win 2k/xp joining a samba domain
Post by: MasthaX on May 05, 2007, 08:06:27 PM
I have done all this above but without any luck, i checked the keys and edited my local policy