Koozali.org formerly Contribs.org

bugs?

Christian

bugs?
« on: August 12, 2000, 01:06:47 AM »
I've discovert maybe two bugs in e-smith v4.0.

1. When I set in e-smith-manager at remoteacces Telnet acces: Privat
    It's still possible to acces the e-smith server by telnet from the wan.
    When I set it at Noacces it is not possible anymore.

2.  When I want use an I-bay as fileshare I get the following problem:

   - First I create a new I-bay
   - Then I set the rights
   - When I copy the files in the new I-bay I get a right problem.

When I greate one directory in the root of files, it's fine.
When I greate within this new directory a second (files
ewdirectory) directory, the second directory get the right's form the user that's greates it. Not the right I set in e-smith manager.

temp Solution:

I copy the files and then on e-smith-manager set the right diverent and press save.
Then I set the original rights back and press save again. Now all tge driectories have the rights I set in e-smith-manager.

If there are any questions, please ask.

Gordon Rowell

RE: bugs?
« Reply #1 on: August 12, 2000, 02:41:47 AM »
Christian wrote:

> I've discovert maybe two bugs in e-smith v4.0.
>
> 1. When I set in e-smith-manager at remoteacces Telnet acces:
> Privat It's still possible to acces the e-smith server by
> telnet from the wan. When I set it at Noacces it is not
> possible anymore.

I do not believe _access_ is possible. The telnet port may be
visible to a port scanner, but the tcp_wrappers system will drop the
connection after a short delay.

I have taken this offline for further information, but I do not believe
a bug exists here.

Please send security related bug reports to bugs@e-smith.com, not
to a public bulletin board. Allow the vendor time to analyse the bug
and respond appropriately with a rebuttal or a fix.

> 2.  When I want use an I-bay as fileshare I get the following
> problem:
>
> - First I create a new I-bay - Then I set the rights - When I
> copy the files in the new I-bay I get a right problem.
>
> When I greate one directory in the root of files, it's fine.
> When I greate within this new directory a second (files
> ewdirectory) directory, the second directory get the right's
> form the user that's greates it. Not the right I set in e-smith
> manager.
>
> temp Solution:
>
> I copy the files and then on e-smith-manager set the right
> diverent and press save. Then I set the original rights back
> and press save again. Now all tge driectories have the rights I
> set in e-smith-manager.

Please apply the e-smith-base update in
ftp://ftp.e-smith.org/pub/e-smith/e-smith-4.0/updates/RPMS/noarch/

> If there are any questions, please ask.

We have done so in private email.

Gordon

christian

RE: bugs?
« Reply #2 on: August 14, 2000, 01:20:09 PM »
It seems to be resolved some how.

I did get a prompt for a username and password. But I changed
de rights serveral times for testing and it seems to OK now.

I'm not sure what I did wrong.

I think you can discard my bug report.

Sorry...
I will be more carefull next time!

Christian