Koozali.org formerly Contribs.org

php 5.3.3 on SME 10

Offline umbi

php 5.3.3 on SME 10
« on: November 02, 2021, 01:06:50 AM »
Hi

I tried an upgrade from sme 9.2 to 10.  I have one website there is not working php higher as php 5.3.3.
To fix all compatibilities e need tooo long time. So i will make a new site, but i need temporary access on only one i_bay with php 5.3.3 to work on it.

my question:

is it possible to run temporary php 5.3.3 on fresh installed sme 10 ?

Thank you in advance for any help
« Last Edit: November 02, 2021, 01:36:54 AM by umbi »

Offline umbi

Re: php 5.3.3 on SME 10
« Reply #1 on: November 02, 2021, 03:54:16 AM »
ok i have found in the net that Centos7 cant PHP 5.3 ....

Sorry for this question

Offline TerryF

  • grumpy old man
  • *
  • 1,644
Re: php 5.3.3 on SME 10
« Reply #2 on: November 02, 2021, 05:17:07 AM »
yep, think you are up that creek sans paddle, quick search throws up some refs but looks to be a dead horse
--
qui scribit bis legit

Offline ReetP

  • *
  • 3,127
Re: php 5.3.3 on SME 10
« Reply #3 on: November 10, 2021, 10:24:54 PM »
CentOS 7 has PHP 5.4 as default.

I'd imagine it will run on that, but you are just delaying the inevitable.

The longer you delay the harder it will be to upgrade.

You really should be looking at PHP 8+
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation