Koozali.org formerly Contribs.org

Erreur de PHP

Erreur de PHP
« on: October 03, 2021, 05:55:22 AM »
Bonjour tout le monde,

après une simple mise à jour (yum update), j'ai un soucis de PHP sur certaine de mes Ibays.
Cela se matérialise avec une magnifique erreur 503 Service Unavailable.

Dans les logs, on retrouve l'erreur :
Code: [Select]
No such file or directory: AH02454: FCGI: attempt to connect to Unix domain socket /var/run/php-fpm/php80-wph.sock (*) failed
wph étant le nom de mon Ibays et php80 la version de PHP que j'ai configuré.
J'ai essayé de configurer une autre version, cela ne change rien.
J'ai essayé de réinstaller PHP, cela ne change rien.
J'ai essayé de créer d'autres Ibays, cela ne change rien.

Mon PHP est HS. Que faire ?

Je suis preneur de toutes idées.
Claude


Offline ReetP

  • *
  • 3,029
Re: Erreur de PHP
« Reply #1 on: October 03, 2021, 10:54:40 AM »
Ok, so first you need to give us some more background. Run these and post the output.

Code: [Select]
/sbin/e-smith/audittools/newrpms
Code: [Select]
/sbin/e-smith/audittools/templates
Code: [Select]
grep -rn php80 /etc/
Code: [Select]
ll /var/run/php-fpm

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Online Jean-Philippe Pialasse

  • *
  • 1,908
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Erreur de PHP
« Reply #2 on: October 07, 2021, 08:42:02 PM »
il y ´a t il des depots tiers de configuré?

que contiennent les logs d’erreur apache et php80 ?

que dit
systemctl -l status php80-php-fpm

Re: Erreur de PHP
« Reply #3 on: October 13, 2021, 09:04:48 PM »
Bonjour,

désolé du délai de réponse.
Alors dans un premier temps, pour solutionner le problème, j'ai simplement fait un "yum history undo".

Je viens de refaire mes updates, avec en plus un php 8.1, et là, je n'y comprend rien, aucun soucis.

J'ai simplement en dépot celui de remi-safe.

Désolé, j'ai crié au loup trop tot.

Merci pour tout,
Claude

[Solved] Erreur de PHP
« Reply #4 on: October 13, 2021, 09:05:25 PM »
erreur de manip

Offline ReetP

  • *
  • 3,029
Re: Erreur de PHP
« Reply #5 on: October 13, 2021, 09:48:36 PM »
PEBKC....
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Erreur de PHP
« Reply #6 on: October 20, 2021, 06:34:37 PM »