Koozali.org formerly Contribs.org

[Solved]ProxyReverse + WebSocket = Erreur

[Solved]ProxyReverse + WebSocket = Erreur
« on: August 18, 2021, 02:17:14 AM »
Bonjour tout le monde,

J'ai un petit soucis de webSocket sur un SME 10.
Dans mon réseau local, j'ai un serveur SME10 et un serveur ProxMox (pour la virtualisation).
Depuis le SME10, j'ai crée un sous domaine qui pointe vers le serveur ProxMox (https://wiki.koozali.org/SME_Server:Documentation:ProxyPass).
Tout est ok.

Via ProxMox, pour mes VM, j'ai la possibilité d'avoir une console noVNC (très pratique). En local, cela fonctionne sans soucis.
Mais via Internet, j'ai une erreur de "WebSocket connection".
C'est une erreur "basique" et on trouve la solution sur Internet (https://wonderproxy.com/blog/proxying-proxmox-4-with-apache/)
J'ai activé le modules/mod_proxy_wstunnel.so et modifier mon VirtualHost pour prendre en compte la redirection.
Mais c'es toujours pareil.

J'ai fais des essaies sur une Debian 11 + Apache 2.4.48 et cela fonctionne.

Est-ce que quelqu'un a une idée, je suis preneur de tout.

Merci par avance,
Claude

PS : Toutes les explications dans les liens sont Ok
       J'avais oublié de décommenter (#) le LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so
       Donc forcément !!!!  :???: :???: :???:
« Last Edit: August 22, 2021, 08:13:42 PM by claude70 »

Re: [Solved]ProxyReverse + WebSocket = Erreur
« Reply #1 on: September 06, 2021, 09:40:13 AM »
Oups, j'avais oublié de répondre à ce post.

Problème résolu.
C'était de ma faute, j'avais #Commenté cette ligne :
LoadModule proxy_wstunnel_module modules/mod_proxy_wstunnel.so

Ne me demander pas pourquoi j'avais fait çà !!! Il devait être tard.

Bonne journée @ tout le monde