Koozali.org formerly Contribs.org

SME Server gateway & DHCP

SME Server gateway & DHCP
« on: July 21, 2021, 06:07:49 PM »
I'm trying to replace an external router with the gateway function in SME Server 8 beta 4 and I can't get the VM a DHCP lease from my ISP.

I take the cable modem & put it on PVE's eth0 then set eth0 & vmbr0 both to dhcp in /etc/network/interfaces.

I took a 10/100/1000 switch and connected it to PVE's eth1, and plugged a couple real boxes into the switch.

I changed all the VMs in PVE to now use vmbr1, which is linked to eth1.

I made the SME Server in KVM, deleted the NICs & added them again so that they're in proper order with it's R8139 on eth0/vmbr0 (since the cable modem's only 10/100) & the e1000 on eth1 (since the LAN is 10/100/1000).

I go through the SME Server installation & set it as a dedicated gateway, with it's DNS pointing to OpenDNS and without providing DHCP to the local network.
A Microsoft Small Business Server 2008 VM provides DHCP & DNS on 192.168.111.5 (vmbr1/eth1).

I have PVE's eth1 set to 192.168.111.1 in /etc/network/interfaces.
If I set SME Server's eth1 to the same as PVE's eth1 it complains, so I set it to 192.168.111.2 & set the workstation I use as a management console (on the switch) to use 192.168.111.3 as the IP, 192.168.111.2 as the gateway & 192.168.111.5 for DNS.

The problem is that even though the SME Server's external (eth0) NIC is set to populate via DHCP (from the cable modem), it doesn't.

I have a similar problem if I connect just the cable modem to the switch. The first device I add gets an address. Devices added afterward don't.

Is there a way to pass PVE's eth0 through to the SME Server so it can get/manage the external address?
I imagine PVE's external access would then have to happen through the gateway provided by the SME Server VM, but how?

Thank you.

Offline Jean-Philippe Pialasse

  • *
  • 1,995
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SME Server gateway & DHCP
« Reply #1 on: July 22, 2021, 12:47:30 PM »
Quote
SME Server 8 beta 4

why?

we are in 2021

SME 8 is EOL since 2017-03-31….
why still beta 4?  SME 8 was released completely years ago!

You got few trains late. update first to SME 10