Koozali.org formerly Contribs.org

Fail2ban update via yum fails

Fail2ban update via yum fails
« on: June 13, 2021, 07:44:51 AM »
Just ran yum update smeserver-fail2ban fail2ban --enablerepo=smecontribs

[root@gateway ~]# yum update smeserver-fail2ban fail2ban --enablerepo=smecontribs
Loaded plugins: changelog, fastestmirror, post-transaction-actions, priorities, smeserver
Loading mirror speeds from cached hostfile
 * base: mirror.colocity.com
 * smeaddons: mirror.internode.on.net
 * smecontribs: smeserver.de-labrusse.fr
 * smeextras: mirror.internode.on.net
 * smeos: mirror.internode.on.net
 * smeupdates: mirror.internode.on.net
 * updates: mirror.colocity.com
Resolving Dependencies
--> Running transaction check
---> Package fail2ban-firewalld.noarch 0:0.11.1-10.el7 will be obsoleted
--> Processing Dependency: fail2ban-firewalld = 0.11.1-10.el7 for package: fail2ban-0.11.1-10.el7.noarch
---> Package firewalld.noarch 0:0.6.3-13.el7_9 will be obsoleted
---> Package smeserver-fail2ban.noarch 9:0.1.18-12.el7.sme will be updated
---> Package smeserver-fail2ban.noarch 9:0.1.18-13.el7.sme will be obsoleting
--> Finished Dependency Resolution
Error: Package: fail2ban-0.11.1-10.el7.noarch (@epel)
           Requires: fail2ban-firewalld = 0.11.1-10.el7
           Removing: fail2ban-firewalld-0.11.1-10.el7.noarch (@epel)
               fail2ban-firewalld = 0.11.1-10.el7
           Obsoleted By: 9:smeserver-fail2ban-0.1.18-13.el7.sme.noarch (smecontribs)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Are we missing an allied update to smeserver-fail2ban or does this package need to have its deps/requires updated?

Am I missing something else?

TIA
..................

Offline sages

  • *
  • 117
    • http://www.sages.com.au
Re: Fail2ban update via yum fails
« Reply #1 on: June 13, 2021, 07:57:25 AM »
For some reason I can't find the reference to this. But, from memory, I had to uninstall smeserver-fail2ban and fail2ban, then do a new install of smeserver-fail2ban.
There was an issue with an update that didn't cleanly update. Once I did the uninstall and new install it worked ok.
[have searched bugs and the forum but can't find it)

[edit] had a better search
https://bugs.koozali.org/show_bug.cgi?id=11617
https://bugs.koozali.org/show_bug.cgi?id=10949

hint, when searching bugzilla instead of 'firewalld' try 'All firewalld' to include closed bugs
« Last Edit: June 13, 2021, 08:08:21 AM by sages »
...

Re: Fail2ban update via yum fails
« Reply #2 on: June 13, 2021, 08:11:25 AM »
Thanks for the heads ups
..................

Offline Jean-Philippe Pialasse

  • *
  • 1,773
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Fail2ban update via yum fails
« Reply #3 on: June 14, 2021, 04:05:43 AM »
version you installed form smetest was wrongly making deps on fail2ban, which depends on fail2ban-firewalld,which depends on firewalld, which can break masq, the firewall of sme server.

please have a check you do not have firewalld installed after that, if yes, remove it.

Re: Fail2ban update via yum fails
« Reply #4 on: June 19, 2021, 01:05:18 PM »
.. all true, did a complete uninstall & reinstall & all is good with the world again

Thanks

version you installed form smetest was wrongly making deps on fail2ban, which depends on fail2ban-firewalld,which depends on firewalld, which can break masq, the firewall of sme server.

please have a check you do not have firewalld installed after that, if yes, remove it.
..................