Koozali.org formerly Contribs.org

phpinfo hangs on SME 10rc1

Offline alext

phpinfo hangs on SME 10rc1
« on: May 21, 2021, 12:41:34 AM »
I just installed a fresh SME 10rc1 from CD Image.
Loaded phpinfo script into the primary ibay and tried to run it via Firefox on a windows workstation.
This resulted in a blank window.
Tried a simple php script from the same ibay which echoed a message and this succeeded.
Have I missed out something in the installation or configuration?

Thanks

PHP script is:

<?php
phpinfo();
?>
...

Offline Jean-Philippe Pialasse

  • *
  • 1,773
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: phpinfo hangs on SME 10rc1
« Reply #1 on: May 21, 2021, 04:22:36 AM »
phpinfo leaks potential sensitives informations. it is deactivated by default.

to allow access to this function, the essy way is to install the smeserver-webhosting  contrib and then remove phpinfo from the list of deactivated functions for the ibay where you need it. all is doable using the server manager once the contrib is installed. 

Offline alext

Re: phpinfo hangs on SME 10rc1
« Reply #2 on: May 21, 2021, 08:14:40 AM »
Thanks for the quick response Jean-Philippe.
Installed  smeserver-mod_dav followed by  smeserver-webhosting. Modified the Disabled Functions List and can now run phpinfo on my test ibay.

Cheers,
Alex
...

Offline Jean-Philippe Pialasse

  • *
  • 1,773
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: phpinfo hangs on SME 10rc1
« Reply #3 on: May 21, 2021, 03:36:41 PM »
with the contrib you will be able to set a lot of different php settings including the php version used by ibay.
default is php74