Koozali.org formerly Contribs.org

smeserver-samba from smedev dns issue Heads Up

Offline sages

  • *
  • 144
    • http://www.sages.com.au
smeserver-samba from smedev dns issue Heads Up
« on: May 04, 2021, 07:47:56 AM »
Just a heads up for anyone who manages to install smeserver-samba from smedev. It appears to add an entry into the database under 'dnscache' adding "ListenIP|127.0.0.3" this breaks DNS on the server.
I got caught out when I saved the configuration after breaking a sme10 install by trying the smeserver-samba update from smedev and restoring the database on a fresh install.
DNS wasn't working which was down to the extra entry mentioned above.
I don't know that this is a bug as such or just a result of trying an dev update.
...

Offline Jean-Philippe Pialasse

  • *
  • 1,900
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: smeserver-samba from smedev dns issue Heads Up
« Reply #1 on: May 04, 2021, 01:04:45 PM »
you played with dragons. I wish you it was a test server, you were not supposed to install smeserver-samba as it was an attempt to have samba AD on SME 6 years ago. 
the implementation is not finished. And next step is indeed to handle samba DNS stack, before modifying all other core packages to work with AD, which will not happen for SME 10.0.

As always smedev is for dev purpose, and if you test something there do not do a yum update without a specific package name. 


Offline sages

  • *
  • 144
    • http://www.sages.com.au
Re: smeserver-samba from smedev dns issue Heads Up
« Reply #2 on: May 04, 2021, 01:27:41 PM »
I come from a long line of dragon slayers. I would also point out that they are all deceased.  :D

It seems to have a long trail of side effects that I haven't completely resolved. Including my primary DNS server needing DNSSEC to be disabled. And qpsmtpd needing resolvable_fromhost disabling as it was rejecting all my incoming email.
It's been a fun four days.  :sad:
I've got a suspicion there is an underlying TLS or such issue that is impacting things as well. I'm just working through comparison of an sme9 install and another sme10rc1 install chasing down config differences.
I'm pretty sure it's something in a template that's still out of wack as I did a fresh install but restoring a config backup from the stuffed up sme10rc1 broke it again.
Just need to clean up the train wreck and get the dragons to join my ancestors  :P
...

Offline TerryF

  • grumpy old man
  • *
  • 1,563
Re: smeserver-samba from smedev dns issue Heads Up
« Reply #3 on: May 04, 2021, 01:52:19 PM »
I like your style :-) nothing like a walk on the wild side....
--
qui scribit bis legit

Offline ReetP

  • *
  • 3,019
Re: smeserver-samba from smedev dns issue Heads Up
« Reply #4 on: May 06, 2021, 10:13:38 PM »
That package is a server destroyer (as are others in there)

NEVER EVER EVER UPDATE from there.

Only INSTALL a SPECIFIC package when working with a dev.

We have said this many times.

I hope you have good backups.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation