Koozali.org formerly Contribs.org

Smeserver webapps-common yum error

Offline ldkeen

  • *
  • 401
Smeserver webapps-common yum error
« on: March 20, 2021, 09:11:53 AM »
Hi,
I have a server that was basically rebuilt from an affa backup and rise and I'm trying to install some of the mssing rpms including smeserver-webapps-common but get the following error:
Code: [Select]
yum install smeserver-webapps-common --enablerepo=fws,epel
Code: [Select]
---> Package smeserver-webapps-common.x86_64 0:0.3.2-1.el6.fws will be installed
--> Processing Dependency: smeserver-php-fpm for package: smeserver-webapps-common-0.3.2-1.el6.fws.x86_64
--> Finished Dependency Resolution
Error: Package: smeserver-webapps-common-0.3.2-1.el6.fws.x86_64 (fws)
           Requires: smeserver-php-fpm
Error: Package: glibc-2.12-1.149.el6_6.9.i686 (updates)
           Requires: glibc-common = 2.12-1.149.el6_6.9
           Installed: glibc-common-2.12-1.212.el6_10.3.x86_64 (@smeupdates)
               glibc-common = 2.12-1.212.el6_10.3
           Available: glibc-common-2.12-1.149.el6.x86_64 (base)
               glibc-common = 2.12-1.149.el6
           Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.4
           Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.7
           Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.9
           Available: glibc-common-2.12-1.209.el6_9.1.x86_64 (smeos)
               glibc-common = 2.12-1.209.el6_9.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Also I'm unable to access the server-manager from any browser or via the console (su admin). Firefox comes up with an error "SSL_ERROR_RX_RECORD_TOO_LONG" and Chrome has this error "ERR_SSL_PROTOCOL_ERROR". E-links shows"The requested URL /server-manager was not found on this server". I was able to renew the letsencrypt certificate and the SSL cert is valid in the email. Everything else seems to work OK just can't access the server-manager or install contribs. Any help would be appreciated.
Best Regards,
Lloyd

I can't seem to find a resolution to this problem

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #1 on: March 20, 2021, 06:49:33 PM »
Hi

SME 10 RC1 is about to get out in few hours. Let’s say 48-72 hours.


It more than time to get this way rather than trying to restore on sme9 which is eol for almost 4 months.


smeserver-php-fpm is in smecontribs so you need to activate this repo.  also you might need remi-safe enabled.



for glibc it is quite strange, hard to tell without the full yum transaction.


To note both smeserver-php-fpm and smeserver-webapps-common have been integrated to core in SME10. Only missing element from the last one is the part for certif based auth, which will need a reimplementation if one is using it.

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #2 on: March 20, 2021, 09:38:28 PM »
Thanks JP,
Unfortunately this server is remotely located and not easy to upgrade to SME10RC1 but I definitely plan to do that soon. I have tried to enable smecontribs and remi-safe as above but still failing. Could I have accidently installed a 32 bit package whilst I was try to fix this - I did uninstall and re-install some packages. This whole problem started happening after I installed Softether - I accidently enabled port 443 in the Windows config which killed the server manager but not sure what damaged I caused trying to fix it. Full Yum transaction below:
Code: [Select]
[root@server ~]# yum install smeserver-webapps-common --enablerepo=fws,epel,smecontribs,remi-safe
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Install Process
Loading mirror speeds from cached hostfile
 * epel: d2lzkl7pfhq30w.cloudfront.net
 * smeaddons: sme-mirror.tw.co.nz
 * smecontribs: sme-mirror.tw.co.nz
 * smeextras: sme-mirror.tw.co.nz
 * smeos: sme-mirror.tw.co.nz
 * smeupdates: sme-mirror.tw.co.nz
Resolving Dependencies
--> Running transaction check
---> Package smeserver-webapps-common.x86_64 0:0.3.2-1.el6.fws will be installed
..........
---> Package oniguruma5php.x86_64 0:6.9.6-1.el6.remi will be installed
---> Package php-bcmath.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-bcmath-5.3.3-46.el6_6.x86_64
---> Package php-fpm.x86_64 0:5.3.3-46.el6_6 will be installed
---> Package php72-php-pdo.x86_64 0:7.2.34-1.el6.remi will be installed
---> Package php73-php-pdo.x86_64 0:7.3.25-1.el6.remi will be installed
---> Package policycoreutils-python.x86_64 0:2.0.83-19.47.el6_6.1 will be installed
--> Processing Dependency: policycoreutils = 2.0.83-19.47.el6_6.1 for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
--> Processing Dependency: libsemanage-python >= 2.0.43-4 for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
--> Processing Dependency: audit-libs-python >= 1.4.2-1 for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
--> Processing Dependency: setools-libs-python for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
--> Processing Dependency: libselinux-python for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
--> Processing Dependency: libcgroup for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
---> Package scl-utils.x86_64 0:20120927-27.el6_6 will be installed
--> Running transaction check
---> Package audit-libs-python.x86_64 0:2.3.7-5.el6 will be installed
--> Processing Dependency: audit-libs = 2.3.7-5.el6 for package: audit-libs-python-2.3.7-5.el6.x86_64
---> Package glibc.i686 0:2.12-1.149.el6_6.9 will be installed
--> Processing Dependency: glibc-common = 2.12-1.149.el6_6.9 for package: glibc-2.12-1.149.el6_6.9.i686
---> Package libcgroup.x86_64 0:0.40.rc1-15.el6_6 will be installed
---> Package libselinux-python.x86_64 0:2.0.94-7.el6 will be installed
---> Package libsemanage-python.x86_64 0:2.0.43-5.1.el6 will be installed
---> Package libzip5.x86_64 0:1.7.3-1.el6.remi will be installed
---> Package php-bcmath.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-bcmath-5.3.3-46.el6_6.x86_64
---> Package php-fpm.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-fpm-5.3.3-46.el6_6.x86_64
---> Package php-intl.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-intl-5.3.3-46.el6_6.x86_64
---> Package php-process.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-process-5.3.3-46.el6_6.x86_64
---> Package php-snmp.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-snmp-5.3.3-46.el6_6.x86_64
---> Package php-soap.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-soap-5.3.3-46.el6_6.x86_64
---> Package php-xmlrpc.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-xmlrpc-5.3.3-46.el6_6.x86_64
---> Package policycoreutils-python.x86_64 0:2.0.83-19.47.el6_6.1 will be installed
--> Processing Dependency: policycoreutils = 2.0.83-19.47.el6_6.1 for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
---> Package setools-libs-python.x86_64 0:3.3.7-4.el6 will be installed
--> Processing Dependency: setools-libs = 3.3.7-4.el6 for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.4)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.3)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1(VERS_1.2)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.1)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4(VERS_4.0)(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libsefs.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libseaudit.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libqpol.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libpoldiff.so.1()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
--> Processing Dependency: libapol.so.4()(64bit) for package: setools-libs-python-3.3.7-4.el6.x86_64
---> Package tcl.x86_64 1:8.5.7-6.el6 will be installed
--> Running transaction check
---> Package audit-libs.i686 0:2.3.7-5.el6 will be installed
---> Package glibc.i686 0:2.12-1.149.el6_6.9 will be installed
--> Processing Dependency: glibc-common = 2.12-1.149.el6_6.9 for package: glibc-2.12-1.149.el6_6.9.i686
---> Package php-bcmath.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-bcmath-5.3.3-46.el6_6.x86_64
---> Package php-fpm.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-fpm-5.3.3-46.el6_6.x86_64
---> Package php-intl.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-intl-5.3.3-46.el6_6.x86_64
---> Package php-process.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-process-5.3.3-46.el6_6.x86_64
---> Package php-snmp.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-snmp-5.3.3-46.el6_6.x86_64
---> Package php-soap.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-soap-5.3.3-46.el6_6.x86_64
---> Package php-xmlrpc.x86_64 0:5.3.3-46.el6_6 will be installed
--> Processing Dependency: php-common(x86-64) = 5.3.3-46.el6_6 for package: php-xmlrpc-5.3.3-46.el6_6.x86_64
---> Package policycoreutils-python.x86_64 0:2.0.83-19.47.el6_6.1 will be installed
--> Processing Dependency: policycoreutils = 2.0.83-19.47.el6_6.1 for package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64
---> Package setools-libs.x86_64 0:3.3.7-4.el6 will be installed
--> Finished Dependency Resolution
Error: Package: glibc-2.12-1.149.el6_6.9.i686 (updates)
           Requires: glibc-common = 2.12-1.149.el6_6.9
           Installed: glibc-common-2.12-1.212.el6_10.3.x86_64 (@smeupdates)
               glibc-common = 2.12-1.212.el6_10.3
           Available: glibc-common-2.12-1.149.el6.x86_64 (base)
               glibc-common = 2.12-1.149.el6
           Available: glibc-common-2.12-1.149.el6_6.4.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.4
           Available: glibc-common-2.12-1.149.el6_6.5.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.5
           Available: glibc-common-2.12-1.149.el6_6.7.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.7
           Available: glibc-common-2.12-1.149.el6_6.9.x86_64 (updates)
               glibc-common = 2.12-1.149.el6_6.9
           Available: glibc-common-2.12-1.209.el6_9.1.x86_64 (smeos)
               glibc-common = 2.12-1.209.el6_9.1
Error: Package: php-xmlrpc-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: policycoreutils-python-2.0.83-19.47.el6_6.1.x86_64 (updates)
           Requires: policycoreutils = 2.0.83-19.47.el6_6.1
           Installed: policycoreutils-2.0.83-30.1.el6_8.x86_64 (@smeos)
               policycoreutils = 2.0.83-30.1.el6_8
           Available: policycoreutils-2.0.83-19.47.el6.x86_64 (base)
               policycoreutils = 2.0.83-19.47.el6
           Available: policycoreutils-2.0.83-19.47.el6_6.1.x86_64 (updates)
               policycoreutils = 2.0.83-19.47.el6_6.1
Error: Package: php-process-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: php-soap-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: php-fpm-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: php-bcmath-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: php-snmp-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
Error: Package: php-intl-5.3.3-46.el6_6.x86_64 (updates)
           Requires: php-common(x86-64) = 5.3.3-46.el6_6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@smeupdates)
               php-common(x86-64) = 5.3.3-50.el6_10
           Available: php-common-5.3.3-38.el6.x86_64 (base)
               php-common(x86-64) = 5.3.3-38.el6
           Available: php-common-5.3.3-40.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-40.el6_6
           Available: php-common-5.3.3-46.el6_6.x86_64 (updates)
               php-common(x86-64) = 5.3.3-46.el6_6
           Available: php-common-5.3.3-49.el6.x86_64 (smeos)
               php-common(x86-64) = 5.3.3-49.el6
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Sorry I had to chop some out as it exceeded the maximum allowed length.


Online TerryF

  • grumpy old man
  • *
  • 1,531
Re: Smeserver webapps-common yum error
« Reply #3 on: March 21, 2021, 03:48:05 AM »
Softether just disable it using 443 in the windows config app - probably telling you to suck eggs..

Now, just running up a sme9 vm had dumped them all :-) bbk dont want to use my only working sme9 - my home box :-)
--
qui scribit bis legit

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #4 on: March 21, 2021, 05:16:40 AM »
Thanks Terry,
This Softether install was from the old method, I have since deleted all the stuff in /opt and completely removed all traces of Softether including the Windows frontend. Now waiting to install the rpm version that JPP has created but I need to sort out these yum issues first.

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #5 on: March 21, 2021, 05:20:11 AM »
you find something ,

Package: glibc-2.12-1.149.el6_6.9.i686

should not be there on a x64

do rpm -q glibc glibc-common
Code: [Select]
# rpm -q glibc glibc-common
glibc-2.12-1.212.el6_10.3.x86_64
glibc-common-2.12-1.212.el6_10.3.x86_64

if you have both i686 and x86_64, then rpm -e the i686 version


but double check you have a x86_64 version before removing the other, no glibc is not good

« Last Edit: March 21, 2021, 05:22:09 AM by Jean-Philippe Pialasse »

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #6 on: March 21, 2021, 05:44:26 AM »
Hi JP,
It looks like I have the same version as you:

Code: [Select]
[root@server ~]# rpm -q glibc glibc-common                                     
glibc-2.12-1.212.el6_10.3.x86_64
glibc-common-2.12-1.212.el6_10.3.x86_64

But it appears to require a different version of glibc common

Code: [Select]
Requires: glibc-common = 2.12-1.149.el6_6.9       
         Installed: glibc-common-2.12-1.212.el6_10.3.x86_64 (@smeupdates)

This appears to be where is starts looking for the i686 stuff:
Code: [Select]
---> Package zlib.i686 0:1.2.3-29.el6 will be installed
--> Running transaction check
---> Package environment-modules.x86_64 0:3.2.10-1.el6_5 will be installed
--> Processing Dependency: libtcl8.5.so()(64bit) for package: environment-modules-3.2.10-1.el6_5.x86_64
---> Package fontconfig.x86_64 0:2.8.0-5.el6 will be installed
---> Package glibc.i686 0:2.12-1.149.el6_6.9 will be installed
Note the last line. I cant post the whole yum transaction as it contains too many lines.

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #7 on: March 21, 2021, 06:15:46 AM »
what gives

Code: [Select]
# cat /etc/centos-release
CentOS release 6.10 (Final)

Code: [Select]
# grep '/updates/'  /etc/yum.smerepos.d/sme-base.repo
baseurl=http://vault.centos.org/6.10/updates/$basearch/

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #8 on: March 21, 2021, 06:42:05 AM »
I get the following:
Code: [Select]
cat /etc/centos-release
CentOS release 6.10 (Final)
Code: [Select]
[root@server ~]# grep '/updates/'  /etc/yum.smerepos.d/sme-base.repo
baseurl=http://vault.centos.org/6.6/updates/$basearch/

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #9 on: March 21, 2021, 07:46:34 AM »
do
Code: [Select]
/etc/e-smith/events/actions/initialize-default-databases
signal-event yum-modify

and recheck

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #10 on: March 21, 2021, 08:06:35 AM »
Code: [Select]
[root@server ~]# /etc/e-smith/events/actions/initialize-default-databases
Migrating existing database networks
Migrating existing database yum_repositories
Migrating existing database backups
Migrating existing database domains
Migrating existing database mailpatterns
Migrating existing database yum_updates
Migrating existing database yum_installed
Migrating existing database configuration
Migrating existing database hosts
Migrating existing database openvpn-s2s
Migrating existing database yum_available
Migrating existing database spamassassin
Migrating existing database accounts
[root@server ~]# signal-event yum-modify
[root@server ~]# grep '/updates/'  /etc/yum.smerepos.d/sme-base.repo
baseurl=http://vault.centos.org/6.6/updates/$basearch/

No Change, same result.

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #11 on: March 21, 2021, 08:20:00 AM »
These are all the repos I have:
Code: [Select]
[root@server sme-base.repo]# db yum_repositories show
base=repository
    BaseURL=
    EnableGroups=no
    Exclude=initscripts,libgsf
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - os
    Visible=yes
    status=enabled
centosplus=repository
    BaseURL=http://vault.centos.org/6.6/centosplus/$basearch/
    EnableGroups=no
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - centosplus
    Visible=no
    status=disabled
contrib=repository
    BaseURL=http://vault.centos.org/6.6/contrib/$basearch/
    EnableGroups=no
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - contrib
    Visible=no
    status=disabled
epel=repository
    BaseURL=http://download.fedoraproject.org/pub/epel/$releasever/$basearch
    EnableGroups=no
    Exclude=perl-Razor-Agent
    GPGCheck=yes
    GPGKey=http://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL
    MirrorList=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-$releasever&arch=$basearch
    Name=Epel
    Visible=no
    status=disabled
extras=repository
    BaseURL=http://vault.centos.org/6.6/extras/$basearch/
    EnableGroups=no
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - extras
    Visible=no
    status=disabled
fasttrack=repository
    BaseURL=http://vault.centos.org/6.6/fasttrack/$basearch/
    EnableGroups=no
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - fasttrack
    Visible=no
    status=disabled
fws=repository
    BaseURL=http://repo.firewall-services.com/centos/$releasever
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://repo.firewall-services.com/RPM-GPG-KEY
    Name=Firewall Services
    Visible=no
    status=disabled
fws-testing=repository
    BaseURL=http://repo.firewall-services.com/centos-testing/$releasever
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://repo.firewall-services.com/RPM-GPG-KEY
    Name=Firewall Services testing
    Visible=no
    status=disabled
remi=repository
    BaseURL=http://rpms.famillecollet.com/enterprise/6/remi/$basearch/
    EnableGroups=no
    Exclude=mysql*,php-*,phpMyAdmin
    GPGCheck=yes
    GPGKey=http://rpms.famillecollet.com/RPM-GPG-KEY-remi
    Name=Remi - EL6
    Visible=yes
    status=disabled
remi-php55=repository
    BaseURL=http://rpms.famillecollet.com/enterprise/6/php55/$basearch/
    EnableGroups=no
    Exclude=php-horde-horde
    GPGCheck=yes
    GPGKey=http://rpms.famillecollet.com/RPM-GPG-KEY-remi
    Name=Remi-php55 - EL6
    Visible=yes
    status=disabled
remi-safe=repository
    BaseURL=http://rpms.famillecollet.com/enterprise/$releasever/safe/$basearch/
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://rpms.famillecollet.com/RPM-GPG-KEY-remi
    Name=Remi - safe
    Visible=yes
    status=enabled
smeaddons=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeaddons-9
    Name=SME Server - addons
    Visible=yes
    status=enabled
smecontribs=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smecontribs-9
    Name=SME Server - contribs
    Visible=no
    status=disabled
smedev=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smedev-9
    Name=SME Server - dev
    Visible=no
    status=disabled
smeextras=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeextras-9
    Name=SME Server - extras
    Visible=yes
    status=enabled
smeos=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeos-9
    Name=SME Server - os
    Visible=yes
    status=enabled
smetest=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smetest-9
    Name=SME Server - test
    Visible=no
    status=disabled
smeupdates=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeupdates-9
    Name=SME Server - updates
    Visible=yes
    status=enabled
smeupdates-testing=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeupdates-testing-9
    Name=SME Server - updates testing
    Visible=yes
    status=disabled
updates=repository
    BaseURL=http://vault.centos.org/6.6/updates/$basearch/
    EnableGroups=no
    Exclude=initscripts,libgsf
    GPGCheck=yes
    MirrorList=disabled
    Name=CentOS - updates
    Visible=yes
    status=enabled
Looks like they are all pointing to Centos 6.6
What if I change them all back to Centos 6.1:
Code: [Select]
db yum_repositories setprop base BaseURL http://vault.centos.org/6.1/extras/$basearch/
db yum_repositories setprop centosplus BaseURL http://vault.centos.org/6.1/extras/$basearch/
db yum_repositories setprop contrib BaseURL http://vault.centos.org/6.1/extras/$basearch/
db yum_repositories setprop extras BaseURL http://vault.centos.org/6.1/extras/$basearch/
db yum_repositories setprop fasttrack BaseURL http://vault.centos.org/6.1/extras/$basearch/
db yum_repositories setprop updates BaseURL http://vault.centos.org/6.1/extras/$basearch/

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #12 on: March 21, 2021, 03:37:27 PM »
you definitively do not want to point to 6.1 when 6.6 is already out of date

the command i have asked you to issue should have make point to the last available 6.10. unless you have manually forced 6.6.

please what is output of
Code: [Select]
config getprop yum eolversion

Offline ldkeen

  • *
  • 401
Re: Smeserver webapps-common yum error
« Reply #13 on: March 21, 2021, 07:46:09 PM »
Code: [Select]
config getprop yum eolversion
6.6
I don't think I have manually forced 6.6 but I did hit this issue:
Code: [Select]
Error : Cannot find a valid baseurl for repo: baseAnd tried a lot of fixes before I found the following:
https://forums.contribs.org/index.php/topic,54339.0.html
So it is possible I may have inadvertently forced to 6.6?

Offline Jean-Philippe Pialasse

  • *
  • 1,876
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Smeserver webapps-common yum error
« Reply #14 on: March 22, 2021, 03:19:07 AM »
well only way to set this is manually.


config delprop yum eolversion

the. rerun the command i already gave