Koozali.org formerly Contribs.org

auto boot without manual kernel selection

auto boot without manual kernel selection
« on: February 13, 2021, 06:23:42 AM »
gday

how does one prevent the manual kernel selection list during boot up ?
my reason for this is that i would like the server to just automatically reboot un-attended.
im guessing it has something to do with grub ?
apologies if this has been covered before, feel at ease to point me in the right direction.

thanks
« Last Edit: February 13, 2021, 11:47:23 AM by ozebloke »

Offline mmccarn

  • *
  • 2,563
Re: auto boot without manual kernel selection
« Reply #1 on: February 13, 2021, 04:58:10 PM »
Quote from: /boot/grub/grub.conf
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro rd_NO_PLYMOUTH root=/dev/mapper/vg_plex-root
#          initrd /initrd-[generic-]version.img
#boot=/dev/sdb
default=0
timeout=5
splashimage=(hd0,0)/grub/smeserver.xpm.gz
foreground 000000
background 4E95D3
title SME Server 9.2 (2.6.32-754.35.1.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-754.35.1.el6.x86_64 ro rd_NO_PLYMOUTH root=/dev/mapper/vg_plex-root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_L
        initrd /initramfs-2.6.32-754.35.1.el6.x86_64.img
title SME Server 9.2 (2.6.32-754.33.1.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-754.33.1.el6.x86_64 ro rd_NO_PLYMOUTH root=/dev/mapper/vg_plex-root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_L
        initrd /initramfs-2.6.32-754.33.1.el6.x86_64.img
title SME Server 9.2 (2.6.32-754.31.1.el6.x86_64)
        root (hd0,0)
        kernel /vmlinuz-2.6.32-754.31.1.el6.x86_64 ro rd_NO_PLYMOUTH root=/dev/mapper/vg_plex-root rd_NO_LUKS LANG=en_US.UTF-8 rd_LVM_L
        initrd /initramfs-2.6.32-754.31.1.el6.x86_64.img

* Edit grub.conf (/boot/grub/grub.conf on a SME 9.2 server)
* Indicate the default kernel counting from zero with default=0
* Indicate a timeout before booting the default with timeout=5

Offline ReetP

  • *
  • 2,886
Re: auto boot without manual kernel selection
« Reply #2 on: February 13, 2021, 08:33:08 PM »
my reason for this is that i would like the server to just automatically reboot un-attended.

It will always boot automatically.

It just has a 5 second pause by default.

Unless there's a really good reason to change it I'd leave it - you are only saving 5 seconds.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: auto boot without manual kernel selection
« Reply #3 on: February 14, 2021, 12:10:55 AM »
* Edit grub.conf (/boot/grub/grub.conf on a SME 9.2 server)
* Indicate the default kernel counting from zero with default=0
* Indicate a timeout before booting the default with timeout=5

thanks reetp & mmccarn

please see attachment grubconf.jpg
seems to have the correct settings
but it doesnt wait 5 then boot from 0

any thoughts ?

Online TerryF

  • grumpy old man
  • *
  • 1,453
Re: auto boot without manual kernel selection
« Reply #4 on: February 14, 2021, 01:43:47 AM »
When was system last updated?

See mmccarn's kernel version above..
--
qui scribit bis legit

Re: auto boot without manual kernel selection
« Reply #5 on: February 14, 2021, 08:04:55 AM »
When was system last updated?

See mmccarn's kernel version above..

gday
yes i did notice that.....
so, ive fully re-installed from my v9 dvd and performed ALL updates via the software installer in the server-manager
please see attached grubconf2.jpg
but no joy, it still waits for manual intervention
given that v9 is EOL (and i dont wish to waste any more of your time) i'm thinking i'll drop this topic, freshly install a v10 and start again from there.
thanks everyone   :-)

Online TerryF

  • grumpy old man
  • *
  • 1,453
Re: auto boot without manual kernel selection
« Reply #6 on: February 14, 2021, 05:09:38 PM »
No worries, but, would still be of benefit to find out why your install is not doing what mine and what seems most others does, on power on displays the kernel available screen, waits 5 secs and then begins the boot process, attached image is a unupdated install of sme9.2, see countdown has 4 seconds remaining before it starts the boot process using the highlighted kernel, the first on the list when there are multiple entries.
--
qui scribit bis legit

Re: auto boot without manual kernel selection
« Reply #7 on: February 15, 2021, 12:08:12 PM »
No worries, but, would still be of benefit to find out why your install is not doing what mine and what seems most others does, on power on displays the kernel available screen, waits 5 secs and then begins the boot process, attached image is a unupdated install of sme9.2, see countdown has 4 seconds remaining before it starts the boot process using the highlighted kernel, the first on the list when there are multiple entries.

gday

i cleaned out the same hardware & performed a fresh install of v10.
v10 hung several times at the earliest language & country setup selections offering to submit bug reports etc...

ok, so lets go back to v9 & continue this topic  8-)

i cleaned out the same hardware & performed a fresh install of v9 from the latest downloadable iso image burned to a dvd (checked files were the same as the v9 dvd i used previously). next, i performed the updates under server-manager / software installer - all good there.

but the problem persists - boots to the manual kernel list, no countdown timer showing, requires manual intervention.

may i add that i used this same hardware with v6 > v7 (32bit) up until about 2013, and it worked perfectly as expected with auto boot after 5 secs etc.

fyi the hardware is a Giada F102D-BK531 (64bit capable) - it was a rock solid performer & im wishing to re-instate it to the role it did so well back then (it replaced a low spec DL380 G3) - just self hosting of a simple website / email, & me hopefully learning a thing or two along the way.

maybe this is relevant - the machine bios indicates the 4gb ram, but the sme boot screen only indicates 640k / 3gb ram - am i looking at a 32 /64 bit compatibility issue ?

thoughts ?
« Last Edit: February 15, 2021, 12:23:26 PM by ozebloke »

Offline ReetP

  • *
  • 2,886
Re: auto boot without manual kernel selection
« Reply #8 on: February 15, 2021, 01:10:11 PM »
gday

i cleaned out the same hardware & performed a fresh install of v10.
v10 hung several times at the earliest language & country setup selections offering to submit bug reports etc...

Remember v10 is Alpha though we hope a Bet will be out shortly. You really need to read all the bugs, and make sure you install & update correctly - there are a lot of issue with a Alpha 5 install that have been rectified.

If you want a Rocket account to chat to us then please ask and we can give you further guidance for testing.

Quote

ok, so lets go back to v9 & continue this topic  8-)

i cleaned out the same hardware & performed a fresh install of v9 from the latest downloadable iso image burned to a dvd (checked files were the same as the v9 dvd i used previously). next, i performed the updates under server-manager / software installer - all good there.


Did you get any errors on updates? Likely you would have unless you made some changes to the yum settings as CentOS 6 is EOL and all packages have been moved to vault - there are threads on this elsewhere here.

There should be a mountain of updates....

Quote

but the problem persists - boots to the manual kernel list, no countdown timer showing, requires manual intervention.

Only thing I can see is a setting that prevents boot if a previous boot failed, but note sure that is in this version of grub, and it doesn't look to be set in any event.

Quote
may i add that i used this same hardware with v6 > v7 (32bit) up until about 2013, and it worked perfectly as expected with auto boot after 5 secs etc.

fyi the hardware is a Giada F102D-BK531 (64bit capable) - it was a rock solid performer & im wishing to re-instate it to the role it did so well back then (it replaced a low spec DL380 G3) - just self hosting of a simple website / email, & me hopefully learning a thing or two along the way.

maybe this is relevant - the machine bios indicates the 4gb ram, but the sme boot screen only indicates 640k / 3gb ram - am i looking at a 32 /64 bit compatibility issue ?

thoughts ?

You should check compatibility with CentOS 6, and now CentOS 7.

Likely graphics or somesuch are taking some RAM i guess.


Quote
given that v9 is EOL (and i dont wish to waste any more of your time) i'm thinking i'll drop this topic, freshly install a v10 and start again from there.

And that is the real answer because if there is an actual issue, it isn't going to get fixed.

I suggest that as you are still at this stage you go back, and start again with v10.

You should be able to get it installed and booting though as mentioned there are issues you can workaround.

If needs be do a test install with a vanilla CentOS 7 and check it all works first.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: auto boot without manual kernel selection
« Reply #9 on: March 30, 2021, 10:54:06 AM »
gday

again, thanks everyone for your input.

though i havent run a vanilla CentOS 6 or 7, i did attempt a v8.3.2011 x86_64 which was beyond my ability.

however i did run the hardware under Win7Pro64 & Linux Mint20 Cinnamon successfully.

both OS' appear to indicate all good 64bit compatibility.

so may i suggest the machine should be good to go forward with a v10 64bit install ?

ah, yes thanks, feel at ease to propose a rocket account to me.

Online TerryF

  • grumpy old man
  • *
  • 1,453
Re: auto boot without manual kernel selection
« Reply #10 on: March 30, 2021, 11:41:08 AM »
Rc1 is solid, multiple installs now to a HP Microserver N40L , SSD and HDs.. simple things,
single drive will NOT be setup as a degarded Raid1, use two drives same size and it will install a default Raid1.
In the summary install screen ONLy set timezone, keyboard and turn on newtowrk (last is not essential) thats it.

If you go into the partioning it resets to centos default and youy lose sme partitioning settings.

Hit the go button...configure sme10..I prefer to restore my sme9 backup from the console once I have setup remoteaccess and ssh in to do anything after that..

Have fun..
--
qui scribit bis legit

Re: auto boot without manual kernel selection
« Reply #11 on: March 30, 2021, 01:35:41 PM »
gday TerryF

thanks for your reply.

ive downloaded the v10 rc1 iso and burned to a dvd - seems all ok there.

fresh install to my machine via an external usb dvd.... eventually presents a language / locale screen, i select english australia.

then it hangs !

what am i doing wrong ??

Online TerryF

  • grumpy old man
  • *
  • 1,453
Re: auto boot without manual kernel selection
« Reply #12 on: March 30, 2021, 02:26:48 PM »
Hmm, few things there, how did/what di you use to create the DVD..why not use a USB its what I am using now..just make sure to create the USB with the tools listed in the wiki

After selecting language should get the popup warning you are installing a RC etc and have to press continue
--
qui scribit bis legit

Online TerryF

  • grumpy old man
  • *
  • 1,453
Re: auto boot without manual kernel selection
« Reply #13 on: March 30, 2021, 02:28:10 PM »
and, perhaps when first booting select test this media form the initial install menu just to make sure of the media
« Last Edit: March 30, 2021, 11:27:02 PM by TerryF »
--
qui scribit bis legit

Re: auto boot without manual kernel selection
« Reply #14 on: March 31, 2021, 02:31:08 AM »
I'd assume that's a centos installer issue?
Ive done over 20 now installs of base without issue however I was London and UK