Koozali.org formerly Contribs.org

Testing Affa to move to sme10

Testing Affa to move to sme10
« on: January 29, 2021, 01:16:51 AM »
Ive looked it appears this isnt an option to test yet?
I assume the official way to move will be by usb? Id like to test affa as ive moved from 7beta6 to 9.2 when i first started here
I know your all working hard to get 10 its support not a dig

James
« Last Edit: January 29, 2021, 01:18:34 AM by jameswilson »

Offline TerryF

  • grumpy old man
  • *
  • 1,322
Re: Testing Affa to move to sme10
« Reply #1 on: January 29, 2021, 01:27:09 AM »
https://bugs.contribs.org/show_bug.cgi?id=11024

Comments show where to get the package to test it


Added: add any results in the Bug
« Last Edit: January 29, 2021, 01:28:50 AM by TerryF »
--
qui scribit bis legit

Re: Testing Affa to move to sme10
« Reply #2 on: January 29, 2021, 01:44:26 PM »
Will do my job for the weekend

Re: Testing Affa to move to sme10
« Reply #3 on: January 29, 2021, 07:19:31 PM »
Ok I know you said add to bug report I will if thats what I need to do
installed affa as per the bug report.
Installed ok no errors

created backup and ran.
All ran ok

tried a rise. Only error during rise was about atalk

After rising password was changed. Data in ibays ok

But webserver not responding, on wan or lan. But responds to pings and can ssh into it.


Re: Testing Affa to move to sme10
« Reply #4 on: January 29, 2021, 07:48:28 PM »
update sorry webserver is there but refusing connections

think it might be something to do with lets encrypt ill carry on

Offline ReetP

  • *
  • 2,789
Re: Testing Affa to move to sme10
« Reply #5 on: January 30, 2021, 09:49:47 PM »
Don't think affa backups/restores the certs.

Refer to wiki and generate some new ones.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Testing Affa to move to sme10
« Reply #6 on: March 02, 2021, 12:41:32 AM »
Don't think affa backups/restores the certs.

Do you have this in your Affa config?
Quote
If you have a Letsencrypt certificate on the production server, then you should also include

Include=/etc/dehydrated
( Source: https://wiki.contribs.org/Affa )

Offline ReetP

  • *
  • 2,789
Re: Testing Affa to move to sme10
« Reply #7 on: March 02, 2021, 12:48:25 AM »
Both the Letsencrypt and atalk issues should be added to the bug.

Please report them there individually - one comment per issue.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,570
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Testing Affa to move to sme10
« Reply #8 on: March 03, 2021, 03:40:19 AM »
if you restore on a beta1 it should be able to restart even if the certs are not there and default to self signed cert


please attach /var/log/httpd/error_log


for atalk / netatalk support has been removed since sme8. if elements persist in affa it is time to get ride of then