Koozali.org formerly Contribs.org

Horde 5.2 on SME9

Offline mrjhb3

  • *
  • 1,188
    • John Bennett Services
Re: Horde 5.2 on SME9
« Reply #135 on: June 04, 2019, 02:54:39 AM »
New files have been uploaded. 

Yes, the horde5 modules have support for php7.  I've been running the scl on my test servers for a while.  php72, works just fine, with no errors that I have run across.  php73 throws some errors with ingo, but still seems to work.   I haven't had a chance to find out if the errors can simply be ignored for now.

Thank you,

John

......

Offline ReetP

  • *
  • 2,716
Re: Horde 5.2 on SME9
« Reply #136 on: June 04, 2019, 10:11:49 AM »
Cool. Thanks John.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Horde 5.2 on SME9
« Reply #137 on: June 06, 2019, 05:44:36 PM »
I have installed this on my test server (default settings) following your install instructions in 1st post.
Install went smooth and everything seems to work fine.
I will report if I find any issues

Thanks John for working on this.
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Re: Horde 5.2 on SME9
« Reply #138 on: July 23, 2019, 01:29:12 AM »
First, thanks to John for doing all this work. This is great!

We ran the Horde 5 update script on a test VM running SME 9.2. Here is the system info I notice you have requested in the past:
Code: [Select]
[root@sme ~]# pear -V
PEAR Version: 1.9.5
PHP Version: 5.3.3
Zend Engine Version: 2.3.0
Running on: Linux sme 2.6.32-754.17.1.el6.x86_64 #1 SMP Tue Jul 2 12:42:48 UTC 2019 x86_64
[root@sme ~]#
[root@sme ~]# php -v
PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
[root@sme ~]# mysql -V
mysql  Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1

Command pear list gave some results, but pear list -c horde returned zero results.

For the test VM, the install terminated normally and webmail opened up as desired. We did see an error when accessing the "add content" function. All in all, we see the installation as a success.  8-)

We then ran the update script on a server that has been in production for a long time. In this case, we saw lots of warnings at the end of the end of the yum install. Here is one that is typical; there were a great many. All referenced "/usr/share/pear/".
Code: [Select]
Transaction Check Error:
  file /usr/share/pear/Horde/Url/Exception.php from install of Horde_Url-2.2.6-1.el6.noarch conflicts with file from package php-horde-Horde-Url-2.2.3-1.el6.noarch

Here is the system info for the production server:
Code: [Select]
# pear -V
PEAR Version: 1.9.4
PHP Version: 5.3.3
Zend Engine Version: 2.3.0
Running on: Linux japatul 2.6.32-754.17.1.el6.x86_64 #1 SMP Tue Jul 2 12:42:48 UTC 2019 x86_64
#
# php -v
PHP 5.3.3 (cli) (built: Mar 22 2017 12:27:09)
Copyright (c) 1997-2010 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
#
# mysql -V
mysql  Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86_64) using readline 5.1

Command pear list returned a number of packages, but pear list -c horde returned a large number of results from pear.horde.org, pear.php.net and pecl.php.net. Nearly all of these are named in the conflict messages.

This system also has software collections installed and we are using PHP 7.1 and PHP 7.3 on selected iBays.

I don't recall what pear may have been used for on this server other than software collections. From reading the previous posts on this thread it looks like an update of pear packages may be necessary. That is just a guess.

I would be very grateful for your thoughts and suggestions.

- Mark

Offline mrjhb3

  • *
  • 1,188
    • John Bennett Services
Re: Horde 5.2 on SME9
« Reply #139 on: July 23, 2019, 04:05:06 AM »
I don't use the horde portal much at all any more, but I get an error as well, when clicking on add content.  On my test server, I fixed it by editing line 167, and changing &new to new.  I changed it on my production server as well.  Now add content works. 

If you don't get anything when running pear list -c horde, then something went wrong.  The packages that I update, are not compatible with any of the horde5 rpms from remi, which it seems you have previously installed on the production server.  I believe his changes the pear directory location, and adds a lot more information to the pear.conf file that I don't know about.  Somehow, you are going to need to resolve those conflicts.  How, I'm not 100% sure what the best way is. None of my horde5 rpm's start with php-horde, so that is how I know you have installed someone else's packages.

I have recently started using the software collections contrib, and am running my production server with php73 enabled.  I did have to make some small changes to reduce some of the log errors, but I didn't get rid of them all, as well as copy the current php scl pear.conf files, and create a symlink to the one I use for webmail.  I'm letting all of this soak on my home system, but all seems good so far.  I'll have to retest the portal fix on a base install, and then with the various php SCL versions enabled.  All of these changes will be included the next time I upload the files, so more people can test and confirm things are good.

I don't know how much, or if any, that I've helped here.

John
......

Re: Horde 5.2 on SME9
« Reply #140 on: July 23, 2019, 07:54:34 AM »
Of course it helps, John. I completely understand the time constraints and the challenge of keeping up with the changes in the environment and related packages.

I am glad to hear you are working with software collections. I think that is a great concept and hope it will be fruitful.

Please accept my encouragement. I look forward to your next update.
- Mark

Offline Jean-Philippe Pialasse

  • *
  • 1,510
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Horde 5.2 on SME9
« Reply #141 on: July 24, 2019, 03:49:23 AM »
php-horde-Horde-Rpc-2.1.8-1.el6.noarch.rpm is from epel
php-horde-Horde-Url-2.2.6-1.el6.noarch.rpm is also from epel


there are high chances you tried to install an extension for horde 3 a while ago.

remi would provide php-horde-Horde-Url-2.2.6-1.el6.remi.noarch.rpm.


rpm -qa|grep "php-horde" would help to see all the rpm installed.

and for John, adding somethinf like this to the corresponding spec files
could help those in the case of Mark to update without issue.

Provides php-horde-Horde-Url
« Last Edit: July 24, 2019, 03:51:28 AM by Jean-Philippe Pialasse »

Re: Horde 5.2 on SME9
« Reply #142 on: July 24, 2019, 05:06:47 PM »
Following Jean-Philippe's suggestion, I looked for related files.
Code: [Select]
# rpm -qa|grep "php-horde";I see a lot of files but none include reference to remi; e.g. php-horde-Horde-Url-2.2.3-1.el6.noarch is typical.

I then ran a check for remi packages. The results list only the php packages for software collections.
Code: [Select]
# rpm -qa | grep "remi.noarch";
php71-php-pear-1.10.9-2.el6.remi.noarch
php73-php-pear-1.10.9-2.el6.remi.noarch
php70-php-pear-1.10.9-2.el6.remi.noarch
php72-php-pear-1.10.9-2.el6.remi.noarch
php55-php-pear-1.10.9-2.el6.remi.noarch
php54-php-pear-1.10.9-2.el6.remi.noarch
php56-php-pear-1.10.9-2.el6.remi.noarch

Ran another variant...
Code: [Select]
# rpm -qa | grep "remi";which returned many more files but none include "horde" in the file name. All appear to be part of the software collections for php.

Still curious, I ran a more general search on the disk.
Code: [Select]
# updatedb;
# locate php-horde;
The results listed files in /usr/share/pear/ and /var/lib/yum/yumdb/. No surprises there.

I am perplexed. In the OP, I noted that the horde files on disk appear to be newer than those in John's package. The conflicting files are in the local pear repo.

I wonder whether I can simply remove the horde files from the local pear repo and run John's script again?
- Mark

Offline Jean-Philippe Pialasse

  • *
  • 1,510
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Horde 5.2 on SME9
« Reply #143 on: July 24, 2019, 08:42:40 PM »
I wonder whether I can simply remove the horde files from the local pear repo and run John's script again?

as i said they are from epel.
as long as you have the list of rpm you should be safe to remove them and reinstall them at worst.
just check if they are not required by other rpms and create an awfull cascade of removal. If a yum remove of this list only remove those rpm you are pretty safe, otherwise you might have to remember those other rpm and decide if it is worth the risk.

finally the new rpm as they conflict in providing files shoudl be a 1:1 replacement. Except the newer version might break older script depending on them if you keep some old horde 3 packages, which should not be the case with John script.

Re: Horde 5.2 on SME9
« Reply #144 on: January 24, 2021, 08:43:56 PM »
What's the chance this will be updated?

--> Finished Dependency Resolution
Error: Package: php-bcmath-5.3.3-49.el6.x86_64 (/php-bcmath-5.3.3-49.el6.x86_64)
           Requires: php-common(x86-64) = 5.3.3-49.el6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@updates)
               php-common(x86-64) = 5.3.3-50.el6_10
Error: Package: php-process-5.3.3-49.el6.x86_64 (/php-process-5.3.3-49.el6.x86_64)
           Requires: php-common(x86-64) = 5.3.3-49.el6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@updates)
               php-common(x86-64) = 5.3.3-50.el6_10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Installation of horde 5.x rpms for SME Server 9 is complete

Offline ReetP

  • *
  • 2,716
Re: Horde 5.2 on SME9
« Reply #145 on: January 24, 2021, 09:00:51 PM »
What's the chance this will be updated?

None whatsoever.

Please see notes about SME/CentOS 6 EOL.

You would have also hit this issue and workaround.

https://forums.contribs.org/index.php/topic,54339.0.html
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Horde 5.2 on SME9
« Reply #146 on: January 24, 2021, 09:11:04 PM »
None whatsoever.

Please see notes about SME/CentOS 6 EOL.

You would have also hit this issue and workaround.

https://forums.contribs.org/index.php/topic,54339.0.html

Thanks for the info, we have done what you linked to previously.  Was just hoping to get horde 5.2 working, but from previous messages about mismatched file versions wasn't sure if we should use:

 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

or try rolling back php.  If the above commands won't cause some sort of catastrophic failure/issue we would love to do this.  Again Thanks.

Offline mrjhb3

  • *
  • 1,188
    • John Bennett Services
Re: Horde 5.2 on SME9
« Reply #147 on: January 24, 2021, 09:52:55 PM »
What's the chance this will be updated?

--> Finished Dependency Resolution
Error: Package: php-bcmath-5.3.3-49.el6.x86_64 (/php-bcmath-5.3.3-49.el6.x86_64)
           Requires: php-common(x86-64) = 5.3.3-49.el6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@updates)
               php-common(x86-64) = 5.3.3-50.el6_10
Error: Package: php-process-5.3.3-49.el6.x86_64 (/php-process-5.3.3-49.el6.x86_64)
           Requires: php-common(x86-64) = 5.3.3-49.el6
           Installed: php-common-5.3.3-50.el6_10.x86_64 (@updates)
               php-common(x86-64) = 5.3.3-50.el6_10
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Installation of horde 5.x rpms for SME Server 9 is complete

Despite what has been said, yes I will get this updated.  I'm still running these and have php-process-5.3.3-50.el6_10.x86_64 installed on my home server.  I seem to have messed something up the last time I prepped things.  Look for updates to have been made sometime tomorrow.

Thank you,

John
......

Re: Horde 5.2 on SME9
« Reply #148 on: January 24, 2021, 11:52:59 PM »
Despite what has been said, yes I will get this updated.  I'm still running these and have php-process-5.3.3-50.el6_10.x86_64 installed on my home server.  I seem to have messed something up the last time I prepped things.  Look for updates to have been made sometime tomorrow.

Thank you,

John


Thank you.

Re: Horde 5.2 on SME9
« Reply #149 on: January 26, 2021, 05:03:40 AM »
Despite what has been said, yes I will get this updated.  I'm still running these and have php-process-5.3.3-50.el6_10.x86_64 installed on my home server.  I seem to have messed something up the last time I prepped things.  Look for updates to have been made sometime tomorrow.

Thank you,

John


Install went great.  I did have to modify VirturalHosts so my redirection worked, but that's minor (I can say that now, but it is amazing how long it took me to figure out to change 'DocumentRoot /home/httpd/html/horde/imp' to 'DocumentRoot /home/httpd/html/horde'.

Again thanks, many people are happy with the change  :D :-D