Koozali.org formerly Contribs.org

SME e il "nuovo" Thunderbird

SME e il "nuovo" Thunderbird
« on: November 17, 2020, 08:19:24 AM »
Utilizzo Thunderbird oramai da piĆ¹ di 15 anni e devo dire che mi sono sempre trovato benissimo, soprattutto in abbinamento con SME, tuttavia, con l'ultimo aggiornamento, ovvero il passaggio dalla versione 68.xx alla 78.xy sto avendo problemi praticamente con tutte le installazioni di SME (sono tutti 9.2 aggiornati).
Il problema consiste in un messaggio di errore smtp che al momento non ho sotto mano ma mi riprometto di postarlo appena possibile.
Come unica soluzione ho trovato di downgradare Thunderbird alla versione 68.10. Altre soluzioni?

Grazie in anticipo.

Offline mmccarn

  • *
  • 2,540
Re: SME e il "nuovo" Thunderbird
« Reply #1 on: November 17, 2020, 01:10:49 PM »
I do not think SME9.2 supports TLS v1.2.

Try enabling TLS 1.1 in Thunderbird 78:
https://support.mozilla.org/en-US/kb/thunderbird-78-faq#w_how-to-enable-outdated-security-protocols-tls-1-0-and-1-1 (italian)

Re: SME e il "nuovo" Thunderbird
« Reply #2 on: November 17, 2020, 05:37:18 PM »
Thank you for the answer. This trick is useful when the error is about "peer" but with SME the error is about certificates like this:

"Invio del messaggio non riuscito.
Utilizzo della chiave del certificato non appropriato per l'operazione richiesta.
La configurazione relativa a INDIRIZZOIP deve essere corretta".

Offline ReetP

  • *
  • 2,612
Re: SME e il "nuovo" Thunderbird
« Reply #3 on: November 18, 2020, 04:19:20 PM »
Hmmmm. My first search for "La configurazione relativa a INDIRIZZOIP deve essere corretta" revealed this.

Exactly the same as Mike found.

https://www.sltinformatica.net/2020/07/20/thunderbird-invio-del-messaggio-non-riuscito-il-peer-utilizza-una-versione-non-supportata-del-protocollo-di-sicurezza-la-configuraione-relativa-a-smtps-aruba-it-deve-essere-corretta/

For secure settings also read here:

https://wiki.contribs.org/SSL_Settings

TLS 1.2 should be enabled on s/qpsmtpd

You can test your server using the testing notes eg:

Code: [Select]
openssl s_client -connect youserver.com:465 -tls1_1
Code: [Select]
openssl s_client -connect youserver.com:465 -tls1_2
Can you also explain your client settings - SMTP port

Which certificates is SME using? Letsencrypt, self certificated?

Do you have a static or dynamic IP for your server?

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation