Koozali.org formerly Contribs.org

Wordpress is asking for imagick

Wordpress is asking for imagick
« on: November 08, 2020, 09:45:21 AM »
My wordpress install seems to be working fine, but I looked at "Site Health" tab and it said that recommended PHP module is not installed: imagick

So I issued a following command:

Code: [Select]
yum install php73-php-imagick
and I got following error message:

Quote
Error: Package: ImageMagick6-libs-6.9.11.35-1.el6.remi.x86_64 (remi-safe)
           Requires: liblcms2.so.2()(64bit)
Error: Package: ImageMagick6-libs-6.9.11.35-1.el6.remi.x86_64 (remi-safe)
           Requires: libopenjp2.so.7()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Should I even bother with trying to install imagick?
I believe it said it would improve performance?

 
« Last Edit: November 08, 2020, 09:50:25 AM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline mmccarn

  • *
  • 2,540
Re: Wordpress is asking for imagick
« Reply #1 on: November 08, 2020, 06:23:58 PM »
I think you need to add "-pecl" to the package name:
Code: [Select]
yum install php73-php-pecl-imagick
I think Wordpress will use imagick to automatically generate multiple sizes for each image, then use the best size for each viewing experience - saving bandwidth and speeding page load times.

Re: Wordpress is asking for imagick
« Reply #2 on: November 09, 2020, 05:51:50 AM »
I think you need to add "-pecl" to the package name:
Code: [Select]
yum install php73-php-pecl-imagick

When trying above code, I got the same error message as before:
Quote
Error: Package: ImageMagick6-libs-6.9.11.35-1.el6.remi.x86_64 (remi-safe)
           Requires: liblcms2.so.2()(64bit)
Error: Package: ImageMagick6-libs-6.9.11.35-1.el6.remi.x86_64 (remi-safe)
           Requires: libopenjp2.so.7()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Am I missing a repository?

Quote
# yum install php73-php-pecl-imagick
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: centos3.zswap.net
 * smeaddons: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: sjc.edge.kernel.org
base                                                     | 3.7 kB     00:00
remi-safe                                                | 3.0 kB     00:00
smeaddons                                                | 2.9 kB     00:00
smeextras                                                | 2.9 kB     00:00
smeos                                                    | 3.1 kB     00:00
smeupdates                                               | 2.9 kB     00:00
updates                                                  | 3.4 kB     00:00
Resolving Dependencies
« Last Edit: November 09, 2020, 05:55:07 AM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Re: Wordpress is asking for imagick
« Reply #3 on: November 09, 2020, 06:10:29 AM »
After looking carefully, it error message says that it is looking at missing dependencies in (remi-safe)
And in the second output shows that rami-safe is enabled.

Quote
remi-safe                                                | 3.0 kB     00:00
So it looks like the repository itself is missing the files :(
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline mmccarn

  • *
  • 2,540
Re: Wordpress is asking for imagick
« Reply #4 on: November 09, 2020, 01:16:51 PM »
I just installed ImageMagick from the remi-safe repo in September, and updated it 6 days ago, with no problems.

I don't have either libopenjp2.so or liblcms2.so installed; there may be something odd in your yum configuration...

Here is some config info from my SME92 test system:

Code: [Select]
# db yum_repositories show remi-safe
remi-safe=repository
    BaseURL=http://rpms.famillecollet.com/enterprise/$releasever/safe/$basearch/
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://rpms.famillecollet.com/RPM-GPG-KEY-remi
    Name=Remi - safe
    Visible=yes
    status=enabled

# nslookup rpms.famillecollet.com
Server: 192.168.200.11
Address: 192.168.200.11#53

Non-authoritative answer:
rpms.famillecollet.com canonical name = server.famillecollet.com.
Name: server.famillecollet.com
Address: 195.154.241.117

Code: [Select]
# /sbin/e-smith/audittools/repositories
base: enabled
centosplus: disabled
contrib: disabled
epel: disabled
extras: disabled
fasttrack: disabled
fws: disabled
fws-testing: disabled
remi-safe: enabled
smeaddons: enabled
smecontribs: disabled
smedev: disabled
smeextras: enabled
smeos: enabled
smetest: disabled
smeupdates: enabled
smeupdates-testing: disabled
updates: enabled

Code: [Select]
# /sbin/e-smith/audittools/newrpms
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: mirror.centos.iad1.serverforge.org
 * smeaddons: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: mirror.compevo.com
Extra Packages
ImageMagick6-libs.x86_64      6.9.11.35-1.el6.remi                    @remi-safe
gd-last.x86_64                2.3.0-2.el6.remi                        @remi-safe
lcms2.x86_64                  2.8-6.el6                               @epel     
libargon2.x86_64              20161029-7.el6.remi                     @remi-safe
libicu-last.x86_64            50.1.2-17.el6.remi                      @remi-safe
libmcrypt.x86_64              2.5.8-9.el6                             @epel     
libwebp.x86_64                0.4.3-3.el6                             @epel     
libzip5.x86_64                1.7.3-1.el6.remi                        @remi-safe
mod_fastcgi.x86_64            2.4.6-3.el6.fws                         @fws     
mod_proxy_wstunnel.x86_64     0.1-1.el6.fws                           @fws     
nextcloud.noarch              17.0.1-1.el6.sme                        @smecontribs
oniguruma5php.x86_64          6.9.5+rev1-4.el6.remi                   @remi-safe
openjpeg2.x86_64              2.3.0-6.el6                             @epel     
perl-Array-Compare.noarch     2.02-1.el6                              @epel     
perl-Class-C3.noarch          0.22-4.el6                              @epel     
perl-Class-MOP.x86_64         1.12-2.el6                              @epel     
perl-Devel-GlobalDestruction.x86_64
                              0.02-7.el6                              @epel     
perl-MRO-Compat.noarch        0.11-2.el6                              @epel     
perl-Moose.x86_64             1.15-1.el6                              @epel     
perl-Package-DeprecationManager.noarch
                              0.11-1.el6                              @epel     
perl-Package-Stash.noarch     0.32-1.el6                              @epel     
perl-Package-Stash-XS.x86_64  0.25-1.el6                              @epel     
perl-Sub-Name.x86_64          0.05-6.el6                              @epel     
perl-Try-Tiny.noarch          0.11-4.el6                              @epel     
php-pecl-zendopcache.x86_64   7.0.5-2.el6                             @epel     
php56-php-bcmath.x86_64       5.6.40-23.el6.remi                      @remi-safe
php56-php-cli.x86_64          5.6.40-23.el6.remi                      @remi-safe
php56-php-common.x86_64       5.6.40-23.el6.remi                      @remi-safe
php56-php-fpm.x86_64          5.6.40-23.el6.remi                      @remi-safe
php56-php-gd.x86_64           5.6.40-23.el6.remi                      @remi-safe
php56-php-imap.x86_64         5.6.40-23.el6.remi                      @remi-safe
php56-php-intl.x86_64         5.6.40-23.el6.remi                      @remi-safe
php56-php-ldap.x86_64         5.6.40-23.el6.remi                      @remi-safe
php56-php-mbstring.x86_64     5.6.40-23.el6.remi                      @remi-safe
php56-php-mcrypt.x86_64       5.6.40-23.el6.remi                      @remi-safe
php56-php-mysqlnd.x86_64      5.6.40-23.el6.remi                      @remi-safe
php56-php-opcache.x86_64      5.6.40-23.el6.remi                      @remi-safe
php56-php-pdo.x86_64          5.6.40-23.el6.remi                      @remi-safe
php56-php-pear.noarch         1:1.10.12-2.el6.remi                    @remi-safe
php56-php-pecl-jsonc.x86_64   1.3.10-1.el6.remi                       @remi-safe
php56-php-pecl-zip.x86_64     1.19.1-1.el6.remi                       @remi-safe
php56-php-process.x86_64      5.6.40-23.el6.remi                      @remi-safe
php56-php-snmp.x86_64         5.6.40-23.el6.remi                      @remi-safe
php56-php-soap.x86_64         5.6.40-23.el6.remi                      @remi-safe
php56-php-xml.x86_64          5.6.40-23.el6.remi                      @remi-safe
php56-php-xmlrpc.x86_64       5.6.40-23.el6.remi                      @remi-safe
php56-runtime.x86_64          3.0-1.el6.remi                          @remi-safe
php70-php-bcmath.x86_64       7.0.33-23.el6.remi                      @remi-safe
php70-php-cli.x86_64          7.0.33-23.el6.remi                      @remi-safe
php70-php-common.x86_64       7.0.33-23.el6.remi                      @remi-safe
php70-php-fpm.x86_64          7.0.33-23.el6.remi                      @remi-safe
php70-php-gd.x86_64           7.0.33-23.el6.remi                      @remi-safe
php70-php-imap.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-intl.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-json.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-ldap.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-mbstring.x86_64     7.0.33-23.el6.remi                      @remi-safe
php70-php-mcrypt.x86_64       7.0.33-23.el6.remi                      @remi-safe
php70-php-mysqlnd.x86_64      7.0.33-23.el6.remi                      @remi-safe
php70-php-opcache.x86_64      7.0.33-23.el6.remi                      @remi-safe
php70-php-pdo.x86_64          7.0.33-23.el6.remi                      @remi-safe
php70-php-pear.noarch         1:1.10.12-2.el6.remi                    @remi-safe
php70-php-pecl-mysql.x86_64   1.0.0-0.9.20151007git294ce3b.el6.remi   @remi-safe
php70-php-process.x86_64      7.0.33-23.el6.remi                      @remi-safe
php70-php-snmp.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-soap.x86_64         7.0.33-23.el6.remi                      @remi-safe
php70-php-xml.x86_64          7.0.33-23.el6.remi                      @remi-safe
php70-php-xmlrpc.x86_64       7.0.33-23.el6.remi                      @remi-safe
php70-runtime.x86_64          2.0-1.el6.remi                          @remi-safe
php71.x86_64                  2.0-1.el6.remi                          @remi-safe
php71-php-bcmath.x86_64       7.1.33-10.el6.remi                      @remi-safe
php71-php-cli.x86_64          7.1.33-10.el6.remi                      @remi-safe
php71-php-common.x86_64       7.1.33-10.el6.remi                      @remi-safe
php71-php-fpm.x86_64          7.1.33-10.el6.remi                      @remi-safe
php71-php-gd.x86_64           7.1.33-10.el6.remi                      @remi-safe
php71-php-imap.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-intl.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-json.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-ldap.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-mbstring.x86_64     7.1.33-10.el6.remi                      @remi-safe
php71-php-mcrypt.x86_64       7.1.33-10.el6.remi                      @remi-safe
php71-php-mysqlnd.x86_64      7.1.33-10.el6.remi                      @remi-safe
php71-php-opcache.x86_64      7.1.33-10.el6.remi                      @remi-safe
php71-php-pdo.x86_64          7.1.33-10.el6.remi                      @remi-safe
php71-php-pear.noarch         1:1.10.12-2.el6.remi                    @remi-safe
php71-php-pecl-imagick.x86_64 3.4.4-9.el6.remi                        @remi-safe
php71-php-pecl-mysql.x86_64   1.0.0-0.15.20160812git230a828.el6.remi  @remi-safe
php71-php-pecl-zip.x86_64     1.19.1-1.el6.remi                       @remi-safe
php71-php-process.x86_64      7.1.33-10.el6.remi                      @remi-safe
php71-php-snmp.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-soap.x86_64         7.1.33-10.el6.remi                      @remi-safe
php71-php-xml.x86_64          7.1.33-10.el6.remi                      @remi-safe
php71-php-xmlrpc.x86_64       7.1.33-10.el6.remi                      @remi-safe
php71-runtime.x86_64          2.0-1.el6.remi                          @remi-safe
php72-php-bcmath.x86_64       7.2.34-1.el6.remi                       @remi-safe
php72-php-cli.x86_64          7.2.34-1.el6.remi                       @remi-safe
php72-php-common.x86_64       7.2.34-1.el6.remi                       @remi-safe
php72-php-fpm.x86_64          7.2.34-1.el6.remi                       @remi-safe
php72-php-gd.x86_64           7.2.34-1.el6.remi                       @remi-safe
php72-php-imap.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-intl.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-json.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-ldap.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-mbstring.x86_64     7.2.34-1.el6.remi                       @remi-safe
php72-php-mysqlnd.x86_64      7.2.34-1.el6.remi                       @remi-safe
php72-php-opcache.x86_64      7.2.34-1.el6.remi                       @remi-safe
php72-php-pdo.x86_64          7.2.34-1.el6.remi                       @remi-safe
php72-php-pear.noarch         1:1.10.12-2.el6.remi                    @remi-safe
php72-php-pecl-apcu.x86_64    5.1.19-1.el6.remi                       @remi-safe
php72-php-pecl-imagick.x86_64 3.4.4-9.el6.remi                        @remi-safe
php72-php-pecl-inotify.x86_64 2.0.0-6.el6.remi                        @remi-safe
php72-php-pecl-mcrypt.x86_64  1.0.3-1.el6.remi                        @remi-safe
php72-php-pecl-mysql.x86_64   1.0.0-0.17.20160812git230a828.el6.remi  @remi-safe
php72-php-pecl-zip.x86_64     1.19.1-1.el6.remi                       @remi-safe
php72-php-process.x86_64      7.2.34-1.el6.remi                       @remi-safe
php72-php-smbclient.x86_64    1.0.0-1.el6.remi                        @remi-safe
php72-php-snmp.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-soap.x86_64         7.2.34-1.el6.remi                       @remi-safe
php72-php-xml.x86_64          7.2.34-1.el6.remi                       @remi-safe
php72-php-xmlrpc.x86_64       7.2.34-1.el6.remi                       @remi-safe
php72-runtime.x86_64          2.0-1.el6.remi                          @remi-safe
php73-php-bcmath.x86_64       7.3.24-1.el6.remi                       @remi-safe
php73-php-cli.x86_64          7.3.24-1.el6.remi                       @remi-safe
php73-php-common.x86_64       7.3.24-1.el6.remi                       @remi-safe
php73-php-fpm.x86_64          7.3.24-1.el6.remi                       @remi-safe
php73-php-gd.x86_64           7.3.24-1.el6.remi                       @remi-safe
php73-php-gmp.x86_64          7.3.24-1.el6.remi                       @remi-safe
php73-php-imap.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-intl.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-json.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-ldap.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-mbstring.x86_64     7.3.24-1.el6.remi                       @remi-safe
php73-php-mysqlnd.x86_64      7.3.24-1.el6.remi                       @remi-safe
php73-php-opcache.x86_64      7.3.24-1.el6.remi                       @remi-safe
php73-php-pdo.x86_64          7.3.24-1.el6.remi                       @remi-safe
php73-php-pear.noarch         1:1.10.12-2.el6.remi                    @remi-safe
php73-php-pecl-apcu.x86_64    5.1.19-1.el6.remi                       @remi-safe
php73-php-pecl-imagick.x86_64 3.4.4-9.el6.remi                        @remi-safe
php73-php-pecl-mcrypt.x86_64  1.0.3-1.el6.remi                        @remi-safe
php73-php-pecl-mysql.x86_64   1.0.0-0.20.20180226.647c933.el6.remi    @remi-safe
php73-php-pecl-zip.x86_64     1.19.1-1.el6.remi                       @remi-safe
php73-php-process.x86_64      7.3.24-1.el6.remi                       @remi-safe
php73-php-smbclient.x86_64    1.0.0-1.el6.remi                        @remi-safe
php73-php-snmp.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-soap.x86_64         7.3.24-1.el6.remi                       @remi-safe
php73-php-xml.x86_64          7.3.24-1.el6.remi                       @remi-safe
php73-php-xmlrpc.x86_64       7.3.24-1.el6.remi                       @remi-safe
php73-runtime.x86_64          2.0-1.el6.remi                          @remi-safe
smeserver-nextcloud.noarch    1.1.0-16.el6.sme                        @smecontribs
smeserver-php-fpm.x86_64      0.1.1-4.el6.sme                         @smecontribs
smeserver-webapps-common.x86_64
                              0.3.2-1.el6.fws                         @fws 

Code: [Select]
# grep -i imagemagick /var/log/yum/yum.log
Sep 12 07:27:53 Installed: ImageMagick6-libs-6.9.11.29-1.el6.remi.x86_64
Oct 31 09:09:03 Updated: ImageMagick6-libs-6.9.11.34-1.el6.remi.x86_64
Nov 03 06:04:51 Updated: ImageMagick6-libs-6.9.11.35-1.el6.remi.x86_64

# yum info ImageMagick6-libs
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: us.mirror.nsec.pt
 * smeaddons: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: mirrors.xtom.com
Installed Packages
Name        : ImageMagick6-libs
Arch        : x86_64
Version     : 6.9.11.35
Release     : 1.el6.remi
Size        : 7.6 M
Repo        : installed
From repo   : remi-safe
Summary     : Commands for ImageMagick
URL         : http://www.imagemagick.org/
License     : ImageMagick
Description : Provides the shared libraries and plugins of ImageMagick6.
            :
            : This package could be installed beside official RPM of ImageMagick
            : for applications requiring this libraries.

Code: [Select]
# grep php73.*imagick /var/log/yum/yum.log
Oct 31 10:24:45 Installed: php73-php-pecl-imagick-3.4.4-9.el6.remi.x86_64

# yum info php73-php-pecl-imagick
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: mirror.centos.iad1.serverforge.org
 * smeaddons: www.mirrorservice.org
 * smeextras: www.mirrorservice.org
 * smeos: www.mirrorservice.org
 * smeupdates: www.mirrorservice.org
 * updates: repos-lax.psychz.net
Installed Packages
Name        : php73-php-pecl-imagick
Arch        : x86_64
Version     : 3.4.4
Release     : 9.el6.remi
Size        : 493 k
Repo        : installed
From repo   : remi-safe
Summary     : Extension to create and modify images using ImageMagick
URL         : https://pecl.php.net/package/imagick
License     : PHP
Description : Imagick is a native php extension to create and modify images
            : using the ImageMagick API.
            :
            : Package built for PHP 7.3 as Software Collection (php73 by remi).

Re: Wordpress is asking for imagick
« Reply #5 on: November 10, 2020, 02:13:38 AM »
I don't have either libopenjp2.so or liblcms2.so installed; there may be something odd in your yum configuration...

Since you don't have libopenjp2.so or liblcms2.so installed, and your system works fine, should I force it to upgrade by adding this command?

Code: [Select]
yum install php73-php-pecl-imagick --skip-broken
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Re: Wordpress is asking for imagick
« Reply #6 on: November 10, 2020, 02:57:38 AM »
Fixed

I Did
Code: [Select]
sudo yum install wget https://download-ib01.fedoraproject.org/pub/epel/6/x86_64/Packages/o/openjpeg2-2.3.0-6.el6.x86_64.rpmAnd
Code: [Select]
sudo yum install wget https://download-ib01.fedoraproject.org/pub/epel/6/x86_64/Packages/l/lcms2-2.8-6.el6.x86_64.rpm
After that the install worked
Code: [Select]
yum install php73-php-pecl-imagick
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline ReetP

  • *
  • 2,612
Re: Wordpress is asking for imagick
« Reply #7 on: November 10, 2020, 11:16:46 AM »
Fixed

No, hacked.

Quote
I Did
Code: [Select]
sudo yum install wget https://download-ib01.fedoraproject.org/pub/epel/6/x86_64/Packages/o/openjpeg2-2.3.0-6.el6.x86_64.rpmAnd
Code: [Select]
sudo yum install wget https://download-ib01.fedoraproject.org/pub/epel/6/x86_64/Packages/l/lcms2-2.8-6.el6.x86_64.rpm

So you can see these came from EPEL so why didn't you just use the epel repo?

Add the epel repo.

https://wiki.contribs.org/Epel

Then just do this:

Code: [Select]
yum --enablerepo=epel install php73-php-pecl-imagick
That is "fixed".
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Wordpress is asking for imagick
« Reply #8 on: November 10, 2020, 08:38:23 PM »
So you can see these came from EPEL so why didn't you just use the epel repo?

Add the epel repo.

https://wiki.contribs.org/Epel

Thank you for the pointer, that is what I did not know, that is why I was reaching out for help.
I have enabled Epel repo now.


No, hacked.

How can it be hacked when I downloaded directly from Fedora Project page and they are the keeper of Epel repo?
« Last Edit: November 10, 2020, 08:54:48 PM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline ReetP

  • *
  • 2,612
Re: Wordpress is asking for imagick
« Reply #9 on: November 11, 2020, 12:22:15 AM »
How can it be hacked when I downloaded directly from Fedora Project page and they are the keeper of Epel repo?

Your method means that you will not get an update until the next time you bother to check. Installing rpms from who knows where is not good practice.

And because there is a method which then ensures you get timely updates from the repo.

For sure, you can use your method, but experience says that it will likely be your undoing at some future date when someone exploits your old package that you forgot to update. That's what hackers do - search for packages that people forgot about.

First would have been to ask if there was a usable repo seeing as the repo says 'epel' :

download-ib01.fedoraproject.org/pub/epel/6/x86_64/Packages/o/openjpeg2-2.3.0-6.el6.x86_64.rpm

A search on the wiki would have helped you.

Running the commands that Mike provided and checking first would have also helped you.

Code: [Select]
/sbin/e-smith/audittools/repositories
Code: [Select]
/sbin/e-smith/audittools/newrpms
And you could have asked for someone to run

Code: [Select]
yum info openjpeg2
People spent a lot of time and thought on building a system to enable things to work as seamlessly as possible and to try and keep you safe, and to save you from yourself. Do please make use of it where you can.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Wordpress is asking for imagick
« Reply #10 on: November 11, 2020, 03:58:19 AM »
Code: [Select]
yum remove php73-php-pecl-imagick
yum remove openjpeg2-2.3.0-6.el6.x86_64
yum remove lcms2-2.8-6.el6.x86_64

Added the epel repo.

Code: [Select]
yum --enablerepo=epel install php73-php-pecl-imagick :pint:
« Last Edit: November 11, 2020, 04:05:36 AM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline ReetP

  • *
  • 2,612
Re: Wordpress is asking for imagick
« Reply #11 on: November 11, 2020, 02:40:10 PM »
And THAT is properly fixed  :lol:
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,495
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Wordpress is asking for imagick
« Reply #12 on: November 12, 2020, 01:55:46 PM »
real fix is opening a bug

then copy the 3 needing rpm in smecontribs and update the spec file to requires them.
then it will be a fix with real seamless update for everybody.

Offline ReetP

  • *
  • 2,612
Re: Wordpress is asking for imagick
« Reply #13 on: November 12, 2020, 07:59:53 PM »
:rofl:

Perhaps the OP could open one.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation