Koozali.org formerly Contribs.org

SQLite extension: Not Installed

SQLite extension: Not Installed
« on: December 29, 2020, 10:32:32 PM »
I am trying to install an app in the iBay and I got a message that:
SQLite extension:   Not Installed

so I did:
Code: [Select]
yum -y install sqlite-devel
After I reconfigured and restarted the system, I still get the message:
SQLite extension:   Not Installed

What did I miss?
« Last Edit: December 29, 2020, 10:50:53 PM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline mmccarn

  • *
  • 2,546
Re: SQLite extension: Not Installed
« Reply #1 on: December 30, 2020, 12:52:06 PM »
I think what's missing is not sqlite itself but the php extension for sqlite.

Getting the php extension will depend on the version of php running in the ibay.

In an ibay of mine running php7.3, the 'sqlite3.so' extension came from 'php73-php-pdo'.

sqlite3.so for the SME-native php5.3 looks like it comes from 'php-pdo'.


Re: SQLite extension: Not Installed
« Reply #2 on: January 01, 2021, 08:54:35 PM »
Thank you mmccarn for your reply.
I am using php7.3

Would you be able to explain how you got php extension for sqlite?
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline mmccarn

  • *
  • 2,546
Re: SQLite extension: Not Installed
« Reply #3 on: January 01, 2021, 09:31:35 PM »
Assuming you have the Remi-safe repository configured and enabled, you would use

Code: [Select]
yum install php73-php-pdo

Re: SQLite extension: Not Installed
« Reply #4 on: January 01, 2021, 11:29:11 PM »
Looks like I already have it installed
While running above mentioned code, I see:
Quote
Package php73-php-pdo-7.3.25-1.el6.remi.x86_64 already installed and latest version
Nothing to do

So since I have already installed sqlite (as described in first post)
and since system tells me that php sqlite extension is installed,
what else could it be since I am still getting message:
SQLite extension:   Not Installed

---update------
I thought that default PHP install might be having an effect, so I tried installing extension for default PHP
so I did:
Code: [Select]
yum install php-pdobut no luck, I got a message:
Quote
Package php-pdo-5.3.3-50.el6_10.x86_64 already installed and latest version
Nothing to do

So hunt continues, any ideas?
« Last Edit: January 01, 2021, 11:35:03 PM by calisun »
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Re: SQLite extension: Not Installed
« Reply #5 on: January 02, 2021, 02:33:04 AM »
Another test, to make sure that the issue is not caused by PHP Software collections, I have disabled PHP Software collections for that iBay.
The installer confirmed that the default PHP is active and does not complain about old version, but it still complains:

Quote
PHP Version:   5.3.3
SQLite extension:   Not Installed
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline ReetP

  • *
  • 2,678
Re: SQLite extension: Not Installed
« Reply #6 on: January 02, 2021, 11:47:52 AM »
Probably needs loading via the php config.

You'll need a custom template.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline mmccarn

  • *
  • 2,546
Re: SQLite extension: Not Installed
« Reply #7 on: January 02, 2021, 02:56:00 PM »
What is the app that you are trying to install?


On my system, phpinfo() reports that sqlite 3.7.17 is enabled on an uncustomized ibay running php73, based on the default content of /etc/opt/remi/php73/php.d/30-pdo_sqlite.ini.

Quote from: /etc/opt/remi/php73/php.d/30-pdo_sqlite.ini
; Enable pdo_sqlite extension module
extension=pdo_sqlite


Offline ReetP

  • *
  • 2,678
Re: SQLite extension: Not Installed
« Reply #8 on: January 02, 2021, 05:22:46 PM »
:thumbsup:

Must be installed with the plugin then.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation