Koozali.org formerly Contribs.org

installing openproject.org

installing openproject.org
« on: July 19, 2020, 10:10:13 AM »
Has anybody ever tried installing OpenProject on SME Server?
https://www.openproject.org/download-and-installation/
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Online ReetP

  • *
  • 2,621
Re: installing openproject.org
« Reply #1 on: July 19, 2020, 04:36:49 PM »
Never heard of it.

Read the requirements:

https://docs.openproject.org/installation-and-operations/system-requirements/

Probably needs v10 to assist installation.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: installing openproject.org
« Reply #2 on: July 20, 2020, 04:33:49 AM »
You are correct, it says minimum requirement is CentOS/RHEL 7.x. Since SME 9.2 is based on CentOS 6.9, I assume it will not work.
SME user and community member since 2005.
Want to install Wordpress in iBay of SME Server?
See my step-by-step How-To wiki here:
http://wiki.contribs.org/Wordpress_Multisite

Offline TerryF

  • grumpy old man
  • *
  • 1,199
Re: installing openproject.org
« Reply #3 on: July 20, 2020, 11:13:53 AM »
So try it on sme10, do some simnple testing while at it, two birds one stone.. :-)
--
qui scribit bis legit

Online ReetP

  • *
  • 2,621
Re: installing openproject.org
« Reply #4 on: July 20, 2020, 11:31:43 AM »
You are correct, it says minimum requirement is CentOS/RHEL 7.x. Since SME 9.2 is based on CentOS 6.9, I assume it will not work.

That's for the rpm I would guess, but nonetheless it probably has other requirements that v9 cannot meet.


  • Runtime: Ruby Version = 2.6.x
  • Webserver: Apache or nginx
  • Application server: Puma
  • Database: PostgreSQL Version >= 9.5


At a guess you will need SCL for postgresql, ruby and newer PHP.

Beyond that you will just have to try it and see.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation