Koozali.org formerly Contribs.org

ClamAV Outdated

ClamAV Outdated
« on: July 13, 2020, 04:41:43 AM »
Dear All,

Can someone teach me how to update ClamAV to new version 0.102.3, because Now I can't sending out email until I disable ClamAV this function

I currently using 0.100.2 but when I do the yum update still only show 0.100.2.

Thank you.

B.rgds
Edward.
« Last Edit: July 15, 2020, 05:54:18 AM by edwardtseung »

Offline ReetP

  • *
  • 2,726
Re: ClamAV updated
« Reply #1 on: July 13, 2020, 07:47:59 AM »
Dear All,

Can someone teach me how to update ClamAV to new version 0.102.3, because Now I can't sending out email until I disable ClamAV this function

Why can't you send out mail? That is not due to the engine version.

0.100.x works. Just make sure your virus signatures are up to date.

Quote
I currently using 0.100.2 but when I do the yum update still only show 0.100.2.

That is correct. Updating the scanning engine (not the signatures) is a rather large and tricky job. It is not something we can easily detail here.

v0.100.x is fine, and we are devoting our extremely limited resources and attention to building v10.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: ClamAV updated
« Reply #2 on: July 13, 2020, 08:31:41 AM »
Why can't you send out mail? That is not due to the engine version.

First thank you for your reply, There have an error come up when I enable "virus scan" under email setting and than sending out email "Error 452 unable to scan for viruses", we are using MS outlook 2013.

After I disable it....all is was success to send out.
« Last Edit: July 13, 2020, 09:01:38 AM by edwardtseung »

Offline ReetP

  • *
  • 2,726
Re: ClamAV updated
« Reply #3 on: July 13, 2020, 09:37:22 AM »
There have an error come up when I enable "virus scan" under email setting and than sending out email "Error 452 unable to scan for viruses", we are using MS outlook 2013.

After I disable it....all is was success to send out.

Have you checked your logs for errors?

/var/log/messages
/var/log/qpsmtpd/current
/var/log/freshclam/current
/var/log/clamd/current

If you search the forums and bugs for "Error 452" you will find some information.

I think this is most likely this is related to a bad update to your signatures.

Do you have any additional signatures installed?

Have a look a refreshclam first:

https://wiki.contribs.org/Clamav:freshclam_update
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,515
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: ClamAV updated
« Reply #4 on: July 14, 2020, 07:35:29 PM »
it is likely your answer is in /var/log/clamd/current

you might see either an issue with the db or an issue with clamd missing memory to load the db or that it is restarting every hours after db update and is taking 10 min to load the db.

it could be a mix of those situation: too long to load db with few times missing memory leading to few other restart leaving only few minutes up and running per hour.

Re: ClamAV updated
« Reply #5 on: July 15, 2020, 04:11:22 AM »
it is likely your answer is in /var/log/clamd/current

you might see either an issue with the db or an issue with clamd missing memory to load the db or that it is restarting every hours after db update and is taking 10 min to load the db.

it could be a mix of those situation: too long to load db with few times missing memory leading to few other restart leaving only few minutes up and running per hour.

Thanks for your help....I checked my limit is 1400000000 and now using 1152366K, how to expand this limit under clamd?

Thank you.

Offline TerryF

  • grumpy old man
  • *
  • 1,268
Re: ClamAV updated
« Reply #6 on: July 15, 2020, 04:47:52 AM »
See a number of Bugzilla/forum entries re mem issue, this Bug has good info and pointers  https://bugs.contribs.org/show_bug.cgi?id=10961

--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 1,515
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: ClamAV updated
« Reply #7 on: July 15, 2020, 11:21:12 PM »
Thanks for your help....I checked my limit is 1400000000 and now using 1152366K, how to expand this limit under clamd?

Thank you.

you do not point any error message and just ask how to to fix one thing without showing this is the issue.
1152366K < 1400000000

also you could increase to 3gb but if you only have 2 gb and using 500mb for the rest of system nothing will change.

increasing the allowed space will still not change neither the clamd availability it it takes 15 min to load db and reload it twice an hour.


the wiki has all the setting available for clamd once you properly diagnosed the issue.