Koozali.org formerly Contribs.org

Wordpress - dependency problem from remi repo

Online holck

  • *
  • 278
Wordpress - dependency problem from remi repo
« on: March 26, 2020, 11:08:36 PM »
If I try to install the newest version of Wordpress from the remi repository, I get a dependency eror:
Code: [Select]
---> Package wordpress.noarch 0:5.1.4-1.el6_10 will be updated
---> Package wordpress.noarch 0:5.3.2-1.el6.remi will be an update
--> Processing Dependency: php(language) >= 5.6.20 for package: wordpress-5.3.2-1.el6.remi.noarch
--> Running transaction check
---> Package wordpress.noarch 0:5.1.4-1.el6_10 will be updated
---> Package wordpress.noarch 0:5.3.2-1.el6.remi will be an update
--> Finished Dependency Resolution

Packages skipped because of dependency problems:
    wordpress-5.3.2-1.el6.remi.noarch from remi

I have php version php-5.3.3-50.el6_10.x86_64, but also php56-php-fpm-5.6.40-19.el6.remi.x86_64. Will I be able to run the newest wordpress from the remi repository?
......

Offline ReetP

  • *
  • 2,359
Re: Wordpress - dependency problem from remi repo
« Reply #1 on: March 27, 2020, 12:00:42 AM »
Please have a read around about php versions. This has been answered several times already.

In short you should either use installed 5.3.x or now minimum 7.2.x (again read around for why)

You cut out the important bit of the log to show what wordpress depended ON.

The reality is it most likely won't run on 5.3.x and you therefore need at least 7.2.x

It you install manually it has a built in updater as well.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,469
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Wordpress - dependency problem from remi repo
« Reply #2 on: March 27, 2020, 02:53:25 AM »
answer simple and short:

do not use remi repo

remi-safe is safe, remi repo might break your install as it want to change all your php.  and this is not about your scl package but also the main php version. which is the issue.


so keep using the wordpress from epel, unless you want to break something few months before the eol of sme 9.