Koozali.org formerly Contribs.org

OpenVPN configuration Error: CSRF token is invalid or outdated.

Offline leonp

Hello, all.
I tried to configure OpenVPN-bridge after I configured PHPki as written in WiKi.
When I entered bridge configuration, there was red line saying "There's a problem with the configuration of your certificates, you should check it.". I thought that this is OK as I still didn't configured the bridge as written in WiKi.
Then I followed the WiKi: https://wiki.contribs.org/OpenVPN_Bridge#Using_PHPki_to_manage_the_certificates.
But when I pressed SAVE button I received the error message: "Operation status report
Error: CSRF token is invalid or outdated."
I will be very thankful for the help, as I don't understand much in all this stuff...

Offline ReetP

  • *
  • 2,359
Re: OpenVPN configuration Error: CSRF token is invalid or outdated.
« Reply #1 on: March 22, 2020, 12:59:04 AM »
It is a timeout in the server manager due the page security token expiring I think.

A refresh should fix it but not sure why you got a config error.

Either way, before you go ANY further note there is an updated version of phpki about to be released with increased security and updates.

You CANNOT upgrade your old certificates so will be better afresh with the new version.

See my last post here:

https://forums.contribs.org/index.php/topic,52486.0/all.html#lastPost

I am going to commit the code to smecontribs tomorrow.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline leonp

Re: OpenVPN configuration Error: CSRF token is invalid or outdated.
« Reply #2 on: March 22, 2020, 09:26:52 AM »
After 3 unsuccessful attempts I did the following:
I copied all 4 certificates into a file and then as fast as possible copied its content to the windows of open-vpn.
This time it worked!
Thank you for the solution!
(Although i think this at least must be mentioned somewhere in the wiki)...

Offline ReetP

  • *
  • 2,359
Re: OpenVPN configuration Error: CSRF token is invalid or outdated.
« Reply #3 on: March 22, 2020, 11:20:00 AM »
Please open a bug against server manager and we'll look.

Note my comments about phpki.

Your certificates are not that strong and you should really use the new version available later today.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 2,359
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation