Koozali.org formerly Contribs.org

Please help with Zabbix install

Please help with Zabbix install
« on: March 20, 2020, 07:32:56 PM »
I have attempted to follow the instructions at https://wiki.contribs.org/Zabbix to get Zabbix installed on SME Server 9.2. After the command to actually do the install, I get results which include lines like this:

Code: [Select]
Package zabbix-server-mysql is obsoleted by smeserver-zabbix-proxy, but obsoleting package does not provide for requirements
At the end of the output is this:

Code: [Select]
Error: Package: smeserver-zabbix-server-0.1-17.el6.sme.noarch (smecontribs)
           Requires: zabbix-server-mysql
           Available: zabbix-server-mysql-4.2.7-1.el6.fws.i386 (fws)
               zabbix-server-mysql = 4.2.7-1.el6.fws
           Available: zabbix-server-mysql-4.2.8-2.el6.fws.i386 (fws)
               zabbix-server-mysql = 4.2.8-2.el6.fws
Error: Package: smeserver-zabbix-server-0.1-17.el6.sme.noarch (smecontribs)
           Requires: zabbix-server >= 4.2.6
           Available: zabbix-server-4.2.7-1.el6.fws.i386 (fws)
               zabbix-server = 4.2.7-1.el6.fws
           Available: zabbix-server-4.2.8-2.el6.fws.i386 (fws)
               zabbix-server = 4.2.8-2.el6.fws
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have attached the full output, if it helps.

I have looked through the forms and could not find anything to help me. Has anyone recently gotten a Zabbix server successfully installed and started? The most recent posts here were from 2017, and nothing seemed to match the issue I am seeing here. Please help!

Offline ReetP

  • *
  • 2,563
Re: Please help with Zabbix install
« Reply #1 on: March 20, 2020, 09:58:00 PM »
HOW did you try and install this please? Please explain EXACTLY the steps you took.

My guess is you have tried to enable a repo you did not need or there is a difference between the smecontribs and fws repos
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Please help with Zabbix install
« Reply #2 on: March 20, 2020, 10:06:43 PM »
The exact steps I took were to issue the following commands, per the above referenced Wiki:

Code: [Select]
db yum_repositories set fws repository \
BaseURL http://repo.firewall-services.com/centos/\$releasever \
EnableGroups no GPGCheck yes \
Name "Firewall Services" \
GPGKey http://repo.firewall-services.com/RPM-GPG-KEY \
Visible no status disabled

db yum_repositories set fws-testing repository \
BaseURL http://repo.firewall-services.com/centos-testing/\$releasever \
EnableGroups no GPGCheck yes \
Name "Firewall Services Testing" \
GPGKey http://repo.firewall-services.com/RPM-GPG-KEY \
Visible no status disabled

/sbin/e-smith/db yum_repositories set remi-safe repository \
Name 'Remi-safe' \
BaseURL 'http://rpms.famillecollet.com/enterprise/$releasever/safe/$basearch/' \
EnableGroups no \
GPGCheck yes \
GPGKey http://rpms.famillecollet.com/RPM-GPG-KEY-remi \
Visible yes \
status enabled

signal-event yum-modify

yum --enablerepo=smecontribs,fws,remi-safe install smeserver-zabbix-server

Offline ReetP

  • *
  • 2,563
Re: Please help with Zabbix install
« Reply #3 on: March 21, 2020, 01:20:55 AM »
I think this has missed some love and it needs sorting out.

I am going to pull all the various rpms into SME Contribs and then see if we can't fix them.

Might take me a day to two so bear with me.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,490
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Please help with Zabbix install
« Reply #4 on: March 21, 2020, 03:29:35 AM »
you do not need
smeserver-zabbix-proxy

seems Dani has made some update on this package and yum feels it needs it....


Code: [Select]
yum --enablerepo=smecontribs,fws,remi-safe install smeserver-zabbix-server --exclude=smeserver-zabbix-proxy

Code: [Select]
Le paquet zabbix-server-mysql est rendu obsolète par smeserver-zabbix-proxy, mais l'obsolescence n'affecte pas les dépendances
--> Résolution des dépendances terminée

I have asked Dani to check for his proxy package.

Offline Jean-Philippe Pialasse

  • *
  • 1,490
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Please help with Zabbix install
« Reply #5 on: March 23, 2020, 05:35:13 PM »
i have updated the wiki with this workaround.

i have also given you write access to the wiki if you are keen to help. 

notes that should be added:

- now we could use the rpms smeserver-extrarepos to allow to configure epel, remi, fws , zabbix repos...

- server must be same version or newer than proxy and clients.

- proxy i havent’ tested , but now Daniel use the upstream zabbix repo and they have the db schema in a zabbix-mysql-proxy rpm  , while before he used the zabbix-mysql-server rom to get it, that is the reason of the conflict  he had to find n easy way to obsolete this and it makes smeserver-zabbix-server to tey to install smerserver-zabbix-proxy when pulling zabbix-mysql-server.

i think the real fix should be to Requires the file providing the schema.

- we could test the use of zabbix repo with zabbix-4.2 for client and proxy on the wiki, but beware they do not propose any server rpm for centos 6. which is understandable considering it is going eol and the server needs a newer rpm than the stock one.
i could build it locally buy is it worth for 6 months while we need to focus on getting sme10 out.