Koozali.org formerly Contribs.org

CLAMD choking on emails with attachments

Offline Jean-Philippe Pialasse

  • *
  • 1,585
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: CLAMD choking on emails with attachments
« Reply #15 on: March 03, 2020, 09:06:00 PM »
I had a similar issue with outlook, by default I now set outlook server timeout to 3 minutes, under advanced settings.
this is one thing, as clamd will need to download the whole file and then scan it and finally give a result, it could take time when file are larger


also to avoid delay because of 24 update daily you can do this

Code: [Select]
# config setprop clamav Checks 2
# service freshclam restart

where it will only update the db twice daily.

the default from clamav is 12, SME default is 24, i.e. once hourly at least + multiple tries if it fails.