Koozali.org formerly Contribs.org

Updates SME9.2

Offline TerryF

  • grumpy old man
  • *
  • 1,159
Updates SME9.2
« on: January 29, 2020, 07:56:38 AM »
The following are in the process of being pushed to the mirrors for updates to Koozali SME9, the syncing of mirrors may take up to 24hrs to complete, while we have tested and validated all, it is on OUR test systems, not yours, as always be vigilant and report any issues.

This and other work of late is due to a very small team, we need more hands, if you want to be involved let us know.

29 January 2020

SME built or modified packages - Basic ChangeLogs including Bug number

DCC
Update to 1.3.145-25.el6.sme

clamav
Was 0.100.2-4.el6.sme Now 0.100.2-6.el6.sme
- Update clamav-db as per epel last spec file [SME: 10754]
to add clamav-update as provides

e-smith-backup
Was 2.4.0-44.el6.sme Now 2.4.0-46.el6.sme
- fixed bug on the dar catalog when backups are not added in it [SME: 10781]
- Backported from [SME: 9563]
- Added e-smith-backup-2.4.0.bz10781.UpdateDarCatalogFollowingBackups.patch
- Console Backup, use lsblk instead of hal [SME: 9126]

e-smith-base
Was 5.6.0-34.el6.sme Now 5.6.0-36.el6.sme
- fix unwanted start of non SME dhcpd deamon on update [SME: 10455]
- Eliminated rpmbuild "bogus date" warnings due to inconsistent weekday,
by assuming the date is correct and changing the weekday.
- modify the default city and company [SME: 8168]

e-smith-formmagick
Was 2.4.0-1.el6.sme Now 2.4.0-3.el6.sme
- add translation for CSRF [SME: 10626]
- add CSRF patch [SME: 10626] - thank you to Daniel Berteaud

e-smith-lib
Was 2.4.0-16.el6.sme Now 2.4.0-18.el6.sme
- Revert prev change regarding tap_soft, as it's not needed [SME: 10444]

e-smith-manager
Was 2.6.0-22.el6.sme Now 2.6.0-25.el6.sme
- add message to indicate EOL after Nov 30 2020 [SME: 10171]

initscripts
Was 9.03.58-1.el6.sme.1 Now 9.03.61-2.el6.sme
- Rebase on upstream 9.03.61 [SME: 10615]
- Don't try to run plymouth if disabled [SME: 8375]
- Make slapd service an alias for ldap [SME: 8635]
- Add -n 1 to the dmesg line in rc.sysinit to prevent unwanted
messages appearing on the console [SME: 8277]
- Add hack for running rc7.d script during runlevel 4 [SME: 7217]

perl-CGI-FormMagick
Was 0.93-2.el6.sme Now 0.93-6.el6.sme
- add timeout 2min on CSRF token [SME: 10626]
- new patch version [SME: 10626]
- add perl(Session::Token) [SME: 10626]
- add CSRF patch [SME: 10626] - thank you to Daniel Berteaud

perl-Geography-Countries
Was 2009041301-1.el6.rf Now 2009041301-1.el6.sme

perl-IP-Country
Was 2.27-1.el6.rf Now 2.28-1.el6.sme
- First build using cpanspec [SME: 9328]

perl-Net-Ident
Was 1.23-1.el6.rf Now 1.24-1.el6.sme
- First build using cpanspec [SME: 9323]

qmail
Was 1.03-18.el6.sme Now 1.03-24.el6.sme
- update to last version of patch [SME: 9349]
- update using last patch for netqmail, only qmail-remote part [SME: 9349]
- add DEBUG flag for the moment to help configuring -DDEBUG=1
- fixed compilation line in spec file [SME: 9349]
- now TLS and EHLO are defined to allow proper compilation
- add remote tls transport for qmail-remote [SME: 9349]
- used qmail-1.03-tls-20021228-renato_v2.patch without qmail-smtpd parts
- added documentation [SME: 9704]
- added binaries ipmetest et ipmeprint to help configuration
- add moreip to avoid loop [SME: 9704]
- patch from Scott Gifford
- remove qmail-0.0.0.0.patch as it is included

smeserver-clamav
Was 2.4.0-5.el6.sme Now 2.4.0-6.el6.sme
- fix deprecated AllowSupplementaryGroups warning [SME: 10837]
- increase lower memory limit to 1GB [SME: 10832]

smeserver-locale
Was 2.4.0-27.el6.sme Now 2.4.0-32.el6.sme
- apply locale 2019-12-06 patch
- fix forgotten %patch line
- apply locale 2018-12-14 patch
- apply locale 2017-12-02 patch

smeserver-yum
Was 2.4.0-23.el6.sme Now 2.4.0-27.el6.sme
- add requirement for perl(File::Slurp) [SME: 10250]
- switch to vault for upstream repos after EOL [SME: 10250]

spamassassin
Was 3.4.1-1.el6.sme Now 3.4.2-2.el6.sme
- Obsolete sought.rules.yerp.org references [SME:10597]
- Comment out sought.rules.yerp.org in channels
- update to 3.4.2 [SME: 10597]
- add build require perl(Net::DNS::Nameserver) and import dependencies [SME: 10597]

These are new SME modified Packages

perl-Session-Token
- Update to 1.503
- First build using cpanspec

« Last Edit: January 29, 2020, 07:58:57 AM by TerryF »
--
qui scribit bis legit