Koozali.org formerly Contribs.org

Dev-Tools pour SME 9.2...

Offline STRyk

  • ***
  • 101
Dev-Tools pour SME 9.2...
« on: December 19, 2019, 04:30:16 PM »
Coucou,
Cela fait pas mal de temps que j'essaye de trouver les outils de developpement pour SME 9.2 mais je ne trouve pas.
Sur SME 7 il y avait un script super bien fait, j'ai tenté de le bidouiller, mais c'est sans succès.  :lol:
Si vous pouvez me dire où trouver des outils je serait comblé. Je dois compiler un petit programme tout simple "id3v2".
J'ai donc besoin des devtool pour SME 9.2 !
Merci par avance.  :D
« Last Edit: December 19, 2019, 04:34:15 PM by STRyk »

Offline Jean-Philippe Pialasse

  • *
  • 1,448
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Dev-Tools pour SME 9.2...
« Reply #1 on: December 23, 2019, 04:28:15 AM »
As tu bien cherché si un rpm etait pas dispo ? Cela ressemble à un probleme XY ;)

En fait je suggererais plus installer uniquement les outils dont tu as besoin. Voir mieux de compiler cela ailleur.

J'avais fait cela à l'époque mais, encore une fois des chances qu'il te manque l'outil pour ton logiciel et que tu mette des choses inutiles : https://smeserver.pialasse.com/index.php/Dev-tools

en cherchant c'est disponible dans quelques depos pour centos6 https://pkgs.org/download/id3v2 A essayer en premier, à moins que cela te demande des dépendances de fous.

Offline STRyk

  • ***
  • 101
Re: Dev-Tools pour SME 9.2...
« Reply #2 on: December 23, 2019, 09:40:01 AM »
Hooo !! Alors ca c'est fort !
Effectivement je n'avais pas trouvé ça. Je t'avoue aussi que ton coup de pouce m'a bien aisé car même si j'avais trouvé ce lien je me serais de toute façon demandé si c'etait valable pour SME 9.2.
Même si à bien réfléchir, c'est forcément évident, on a toujours peur de faire une erreur quand on ne maitrise pas tout dans le domaine.

Pour ceux qui, comme moi, ont cherché, voici ma méthode :

Je télécharge les outils (pour servir plus tard) :
# yum install --downloadonly --downloaddir=/root/packages --enablerepo=smecontribs zlib-devel rpm-python rpm-build rpm-devel rpm rpm-libs readline-devel pam-devel ncurses-devel mkisofs m4 libtool libstdc++-devel libattr libacl-devel libacl  glibc-kernheaders glibc-devel gcc-c++ gcc cpp automake autoconf glib2-devel gtk+-devel gtk2-devel krb5-devel

Et grand merci pour ID3v2 car je suis super étonné de la trouvaille !!
Du coups j'ai pris ceci pour X64 :
id3lib-3.8.3-25.1.el6.x86_64.rpm
id3v2-0.1.12-3.el6.x86_64.rpm

Pour X32 :
id3lib-3.8.3-25.1.el6.i686.rpm
id3v2-0.1.12-3.el6.i686.rpm

# id3v2 -v
id3v2 0.1.12
Uses id3lib-3.8.3

J'essaye ça d'ici peu.

Merci et joyeux Noël à toutes et à tous !!
 ;)
« Last Edit: December 23, 2019, 10:29:45 AM by STRyk »