Koozali.org formerly Contribs.org

How do I set the php version for the Primary iBay?

How do I set the php version for the Primary iBay?
« on: March 12, 2019, 03:47:35 PM »
I need to update the php version from the 5.3 default to the newer 7.3 version in my Primary iBay.  I've already performed the installation and have the php-scl available.  However, since I only have the Primary iBay, I can't find a way to change its php version since Primary is not listed in the php-scl list.

Can I change this via the Terminal?

EDIT - I do also have the "I-bays - Web Hosting" scl installed.  It shows the Primary iBay, but does not offer any options.


« Last Edit: March 12, 2019, 05:16:47 PM by tolistim »

Offline mmccarn

  • *
  • 2,464
Re: How do I set the php version for the Primary iBay?
« Reply #1 on: March 13, 2019, 03:51:29 AM »
It's not possible to upgrade the Primary ibay to use php-scl.
[edit] See ReetP's post below.

However, you can make the default host URL serve a different i-bay, which can then be set to use php-scl.

Here's a post describing just this solution in order to run Wordpress at the root of the main domain:
https://forums.contribs.org/index.php/topic,53719.msg279608.html#msg279608
« Last Edit: March 13, 2019, 12:44:52 PM by mmccarn »

Online ReetP

  • *
  • 2,188
Re: How do I set the php version for the Primary iBay?
« Reply #2 on: March 13, 2019, 11:56:20 AM »
It's not possible to upgrade the Primary ibay to use php-scl.

If you use the sme contrib you can run PHP SCL globally which will include the Primary Ibay.

https://wiki.contribs.org/PHP_Software_Collections

smeserver-php-scl

Go to server-manager, PHP-SCL Versions

Select PHP-mod version button

Select your version and Save.

This will apply to ALL ibays. (Note the minimum recommended/supported version is now PHP 7.1)

Add a test.php file to Primary/html containing this:

Code: [Select]
<?php
// version only
$version phpversion();
print 
$version;
// Or use this for the full settings
phpinfo();
?>

Then try:

http://your.server.com/test.php

What you CAN'T do is set a PHP version for JUST the Primary ibay, at least not from the server-manager panel.

Also note other limitations on using PHP per ibay a the wiki page.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation