Koozali.org formerly Contribs.org

geoipupdate errors

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #15 on: January 01, 2019, 12:00:07 PM »
Cool.

Openfusion rpm was just a update to other repository rpms and it auto regenerates this one so not likely.


Seems you are still on the old version of geoip? 1.2-3 is the updated one.

The rpm -qa was before I did the update, this is what I got now:

[root@bjsserver ~]# rpm -qa | grep geoip
smeserver-geoip-1.2-3.el6.sme.noarch
geoipupdate-2.2.1-2.el6.x86_64
[root@bjsserver ~]#




Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #16 on: January 01, 2019, 12:45:44 PM »
Ok.

Try:

Code: [Select]
rpm -qa | grep -i geoip
as well. You should see the perl geoip2 modules.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #17 on: January 01, 2019, 01:38:38 PM »
Code: [Select]
rpm -qa | grep -i geoipas well. You should see the perl geoip2 modules.

Code: [Select]
rpm -qa | grep -i geoip
smeserver-geoip-1.2-3.el6.sme.noarch
GeoIP-1.6.5-1.el6.x86_64
GeoIP-GeoLite-data-2018.04-1.el6.noarch
GeoIP-GeoLite-data-extra-2018.04-1.el6.noarch
geoipupdate-2.2.1-2.el6.x86_64
perl-GeoIP2-2.001002-1.of.el6.noarch
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #18 on: January 01, 2019, 01:56:05 PM »
... and I try the same on one of my other (remote) servers, and get the same dependancy failure for the apache test rpm.

Can't see why it started to work on mine, unless you need a 24 hour gap between trying it, loading the openfusion repo and then trying it again?

Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #19 on: January 01, 2019, 02:03:02 PM »
Cool. That is about correct. The old v1 stuff stays as it is a dependency of proftpd.

Geoipupdate will update the v2 DBs only and the WBL plugin to qpsmtpd should work.

There are a couple of minor enhancements we'll look at when I get home..... see the wiki page for links.

Re your other servers are you updating via the panel or CLI?

We are waiting to add the openfusion gpg key to SME. So when you first try their repo you have to accept their key.

Try it on the CLI as per the wiki and check the output.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #20 on: January 01, 2019, 06:10:29 PM »
Re your other servers are you updating via the panel or CLI?
We are waiting to add the openfusion gpg key to SME. So when you first try their repo you have to accept their key.
Try it on the CLI as per the wiki and check the output.

It was on the CLI and I had to accept the GPG key.  Still failed though.
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #21 on: January 01, 2019, 06:56:36 PM »
Please show your CLI for install.

Also:

db yum_repositories show openfusion

Are you getting the apacheTest module as above or another error?
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • *
  • 1,040
Re: geoipupdate errors
« Reply #22 on: January 01, 2019, 09:25:01 PM »
Just for a base line this is the list of packages an updated sme9.2 vm with the dansguardian contrib pulls for a  smeserver-geoip install:

Dependencies Resolved

============================================================
 Package                     Arch    Version           Repository   Size
============================================================
Installing:
 smeserver-geoip             noarch  1.2-3.el6.sme     smecontribs  21 k
Installing for dependencies:
 perl-Algorithm-C3           noarch  0.09-1.of.el6     openfusion   13 k
 perl-App-cpanminus          noarch  1.7006-1.el6      openfusion   291 k
 perl-B-Hooks-EndOfScope     noarch  0.13-1.of.el6     openfusion   26 k
 perl-B-Hooks-OP-Check       x86_64  0.19-1.of.el6     openfusion   34 k
 perl-CPAN-Meta              noarch  2.150001-1.of.el6 openfusion   141 k
 perl-Carp                   noarch  1.32-1.of.el6     openfusion   22 k
 perl-Class-C3               noarch  0.23-1.of.el6     openfusion   24 k
 perl-Class-Load             noarch  0.20-1.of.el6     openfusion   21 k
 perl-Class-Load-XS          x86_64  0.08-1.of.el6     openfusion   38 k
 perl-Class-Method-Modifiers noarch  2.10-1.of.el6     openfusion   16 k
 perl-Class-Singleton        noarch  1.4-6.el6         base         17 k
 perl-Class-XSAccessor    x86_64     1.19-1.of.el6   openfusion  89 k
 perl-Clone-PP     noarch     1.06-1.of.el6   openfusion  11 k
 perl-Data-Dumper-Concise   noarch     2.022-1.of.el6  openfusion  18 k
 perl-Data-IEEE754   noarch     0.01-1.of.el6   openfusion  11 k
 perl-Data-OptList   noarch     0.107-1.of.el6  openfusion  17 k
 perl-Data-Printer   noarch     0.35-1.of.el6   openfusion  68 k
 perl-Data-Validate-IP    noarch     0.24-1.of.el6   openfusion  16 k
 perl-DateTime     x86_64     1:1.10-1.of.el6  openfusion     168 k
 perl-DateTime-Locale noarch     0.4500-1.of.el6  openfusion     1.8 M
 perl-DateTime-TimeZone    noarch     1.46-1.of.el6   openfusion     328 k
 perl-Devel-GlobalDestruction   noarch     0.12-1.of.el6   openfusion     8.8 k
 perl-Dist-CheckConflicts   noarch     0.02-1.of.el6   openfusion  19 k
 perl-Eval-Closure   noarch     0.11-1.of.el6   openfusion  20 k
 perl-Exporter-Tiny  noarch     1.002001-1.of.el6   openfusion  48 k
 perl-ExtUtils-CBuilder    noarch     1:0.280205-1.of.el6     openfusion  41 k
 perl-ExtUtils-Install    noarch     1.68-1.of.el6   openfusion  41 k
 perl-ExtUtils-Manifest    noarch     1.64-3.of.el6   openfusion  30 k
 perl-File-HomeDir   noarch     1.002-1.of.el6  openfusion  58 k
 perl-File-Which    noarch     1.09-2.el6    base   18 k
 perl-GeoIP2  noarch     2.001002-1.of.el6   openfusion     107 k
 perl-Hash-FieldHash  x86_64     0.14-1.of.el6   openfusion  49 k
 perl-IPC-Cmd     noarch     1:0.76-1.of.el6  openfusion  33 k
 perl-Lexical-SealRequireHints  x86_64     0.007-1.of.el6  openfusion  40 k
 perl-List-AllUtils  noarch     0.08-1.of.el6   openfusion  24 k
 perl-Locale-Maketext-Simple noarch     1:0.21-1.of.el6  openfusion  13 k
 perl-MRO-Compat    noarch     0.12-1.of.el6   openfusion  13 k
 perl-Math-Int128   x86_64     0.18-1.of.el6   openfusion     101 k
 perl-Math-Int64    x86_64     0.34-1.of.el6   openfusion  92 k
 perl-MaxMind-DB-Common    noarch     0.040000-1.of.el6   openfusion  23 k
 perl-MaxMind-DB-Reader    noarch     1.000004-1.of.el6   openfusion  30 k
 perl-Module-Build   noarch     1:0.4211-1.of.el6   openfusion     263 k
 perl-Module-CoreList noarch     2.85-1.of.el6   openfusion  60 k
 perl-Module-Implementation  noarch     0.07-1.of.el6   openfusion  15 k
 perl-Module-Load   x86_64     1:0.16-144.el6  base   29 k
 perl-Module-Load-Conditional   noarch     0.48-1.of.el6   openfusion  18 k
 perl-Module-Runtime  noarch     0.014-1.of.el6  openfusion  18 k
 perl-Moo    noarch     2.003004-1.of.el6   openfusion  64 k
 perl-MooX-StrictConstructor noarch     0.006-1.of.el6  openfusion  20 k
 perl-MooX-Types-MooseLike  noarch     0.25-1.of.el6   openfusion  19 k
 perl-Moose   x86_64     2.1210-2.of.el6  openfusion     1.1 M
 perl-Net-Works    noarch     0.21-1.of.el6   openfusion  39 k
 perl-Package-DeprecationManager     noarch     0.13-1.of.el6   openfusion  15 k
 perl-Package-Stash  noarch     0.33-1.of.el6   openfusion  28 k
 perl-Package-Stash-XS    x86_64     0.25-1.of.el6   openfusion  55 k
 perl-Params-Check   noarch     1:0.32-1.of.el6  openfusion  17 k
 perl-Params-Classify x86_64     0.013-1.of.el6  openfusion  51 k
 perl-Params-Validate x86_64     1.13-1.of.el6   openfusion     136 k
 perl-Perl-OSType   noarch     1.002-4.of.el6  openfusion  16 k
 perl-Role-Tiny    noarch     2.000006-1.of.el6   openfusion  22 k
 perl-Scalar-List-Utils    x86_64     1.49-1.of.el6   openfusion     100 k
 perl-Socket  x86_64     2.009-1.of.el6  openfusion  75 k
 perl-Sort-Naturally  noarch     1.03-1.of.el6   openfusion  16 k
 perl-Sub-Exporter   noarch     0.982-4.el6    base   66 k
 perl-Sub-Exporter-Progressive  noarch     0.001011-1.of.el6   openfusion     9.9 k
 perl-Sub-Identify   x86_64     0.10-1.of.el6   openfusion  30 k
 perl-Sub-Install   noarch     0.928-1.of.el6  openfusion  18 k
 perl-Sub-Name     x86_64     0.12-1.of.el6   openfusion  32 k
 perl-Sub-Quote    noarch     2.005000-1.of.el6   openfusion  22 k
 perl-Task-Weaken   noarch     1.04-1.of.el6   openfusion  16 k
 perl-Term-ANSIColor  noarch     4.03-2.of.el6   openfusion  40 k
 perl-Test-Warnings  noarch     0.016-1.of.el6  openfusion  27 k
 perl-Throwable    noarch     0.200011-1.of.el6   openfusion  24 k
 perl-Try-Tiny     noarch     0.22-1.of.el6   openfusion  19 k
 perl-Variable-Magic  x86_64     0.53-1.of.el6   openfusion  80 k
 perl-bareword-filehandles  x86_64     0.003-1.of.el6  openfusion  40 k
 perl-indirect     x86_64     0.31-1.of.el6   openfusion  58 k
 perl-multidimensional    x86_64     0.009-1.of.el6  openfusion  39 k
 perl-namespace-autoclean   noarch     0.24-1.of.el6   openfusion  24 k
 perl-namespace-clean noarch     0.25-1.of.el6   openfusion  15 k
 perl-strictures    noarch     2.000001-1.of.el6   openfusion  20 k
Updating for dependencies:
 perl-Devel-StackTrace    noarch     1:2.03-1.of.el6  openfusion  31 k
 perl-ExtUtils-MakeMaker   noarch     6.98-1.of.el6   openfusion     279 k
 perl-List-MoreUtils  x86_64     0.415-1.of.el6  openfusion     130 k
 perl-parent  noarch     1:0.228-1.of.el6 openfusion     8.9 k
 perl-version     x86_64     3:0.9908-1.of.el6   openfusion     110 k

Transaction Summary
============================================================
Install   82 Package(s)
Upgrade    5 Package(s)

Total download size: 7.2 M
Is this ok [y/N]: y
--
qui scribit bis legit

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #23 on: January 02, 2019, 01:56:11 AM »
A few more for your list Brian......

yum info mod_perl

And these just for good measure.

/sbin/e-smith/audittools/newrpms |grep dev
/sbin/e-smith/audittools/newrpms |grep test
/sbin/e-smith/audittools/newrpms |grep reetp
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • *
  • 1,040
Re: geoipupdate errors
« Reply #24 on: January 02, 2019, 02:17:27 AM »
Hi Brian

Just to add to johns post, all that from the remote system that is throwing the error like your original system and a list of the repos configured on same along with the command being issued for the install...

Have been pushing things down the throat of a clean new VM trying to get it to throw a tanty but not yet, just trying to get it to reproduce so as to be prepared for any in future..

Thanks mate
--
qui scribit bis legit

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #25 on: January 02, 2019, 02:59:44 PM »
Here's the details asked for:
The Errors:

Transaction Check Error:
  file /usr/share/man/man3/Apache::Test.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestConfig.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestMB.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestMM.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestReport.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRequest.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRun.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRunPHP.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRunPerl.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestServer.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestSmoke.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestTrace.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestUtil.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Bundle::ApacheTest.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch

OpenFusion Repo:

openfusion=repository
    BaseURL=http://repo.openfusion.net/centos$releasever-$basearch
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://repo.openfusion.net/RPM-GPG-KEY-openfusion
    Name=Openfusion
    Visible=yes
    status=disabled

Mod_perl

Loading mirror speeds from cached hostfile
 * base: mirror.bytemark.co.uk
 * smeaddons: www.mirrorservice.org
 * smeextras: www.mirrorservice.org
 * smeos: www.mirrorservice.org
 * smeupdates: www.mirrorservice.org
 * updates: mirrors.ukfast.co.uk
Installed Packages
Name        : mod_perl
Arch        : x86_64
Version     : 2.0.4
Release     : 12.1.el6.sme
Size        : 6.1 M
Repo        : installed
From repo   : smeupdates
Summary     : An embedded Perl interpreter for the Apache HTTP Server
URL         : http://perl.apache.org/
License     : ASL 2.0
Description : Mod_perl incorporates a Perl interpreter into the Apache web
            : server, so that the Apache web server can directly execute Perl
            : code. Mod_perl links the Perl runtime library into the Apache web
            : server and provides an object-oriented Perl interface for Apache's
            : C language API.  The end result is a quicker CGI script turnaround
            : process, since no external Perl interpreter has to be started.
            :
            : Install mod_perl if you're installing the Apache web server and
            : you'd like for it to directly incorporate a Perl interpreter.

and install extra rpm's (mmmh - why smetest I wonder?)

smeserver-geoip.noarch                   1.1.2-7.el6.sme            @smetest   
smeserver-mailstats.noarch               1.1-9.el6.sme              @smetest   



Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #26 on: January 02, 2019, 03:29:51 PM »
Ahhhhh.... OK - this should not be installed and hence your basic error:

 mod_perl-2.0.9-1.of.el6.x86_64

That package is in openfusion and I presume that for whatever good reason your system is trying to update it.

I'm not sure why because it hasn't on any of our test setups.

I can patch that with the openfusion extra repo rpm but in the meantime try:

Code: [Select]
db yum_repositories setprop openfusion Exclude mod_perl
Code: [Select]
signal-event yum-modify
Latest in sme-updates is

 mod_perl-2.0.4-12.1.el6.sme.x86_64

https://bugs.contribs.org/show_bug.cgi?id=10685

I'll patch that shortly if you can confirm this allows you to update geoip.

And these are pretty obvious - you have installed them from test....

smeserver-geoip.noarch                   1.1.2-7.el6.sme            @smetest   
smeserver-mailstats.noarch               1.1-9.el6.sme              @smetest   

geoip was in contribs but superceded by the new version.

mailstats still has that version as current in contribs.

After you fix the openfusion repo then rip them out and reinstall from contribs :-)
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #27 on: January 02, 2019, 03:47:43 PM »
I can patch that with the openfusion extra repo rpm but in the meantime try:
Code: [Select]
db yum_repositories setprop openfusion Exclude mod_perl
Code: [Select]
signal-event yum-modifyLatest in sme-updates is
 mod_perl-2.0.4-12.1.el6.sme.x86_64
https://bugs.contribs.org/show_bug.cgi?id=10685
I'll patch that shortly if you can confirm this allows you to update geoip.

Yup, confirming that worked - patch away!
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,772
Re: geoipupdate errors
« Reply #28 on: January 02, 2019, 03:57:34 PM »
Yup, confirming that worked - patch away!

Thanks Brian - on it now.

I have one gotcha that I have just realised.

If you do:

Code: [Select]
yum --enablerepo=smecontribs,openfusion update
It may well drag in a load of updated files which we don't want. I need to test this as it could get messy.

The correct form is:

Code: [Select]
yum --enablerepo=smecontribs,openfusion install smeserver-geoip
Problem is the 'Include' line would be 80 + packages, and probably similar for 'Exclude'

I need to go through and see what else to exclude.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #29 on: January 02, 2019, 05:54:45 PM »
... and the bad news is that server that I updated has lost the ability to resolve through DNS.

I can ping internet IP addresses (e.g .8.8.8.8 ), but not "google.com".

As it is a "live" system I have set its external DNS entry to 8.8.8.8, but that does not seem to allow workstations to work (unless I guess I set there DNS to 8.8.8.8 as well).

I can still login remotely, but not dmagent or Teamviewer through to the workstations.  Luckily it is only a few minutes walk from me.

PS This ought to be in bugzilla?
Brian j Read
(retired, but still looking after 5 SME installations)
.........