Koozali.org formerly Contribs.org

geoipupdate errors

Offline ReetP

  • *
  • 1,771
geoipupdate errors
« on: December 24, 2018, 04:49:28 PM »
If you use smeserver-geoip you are likely to experience errors in early January for the reasons outlines here:

https://forums.contribs.org/index.php/topic,53857.msg280613.html#new

Please don't open a bug....

Thanks.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: geoipupdate errors
« Reply #1 on: December 30, 2018, 08:04:02 AM »

FYI, This issue is now causing a dependency issue with the open vpn bridge update released today.
...

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #2 on: December 30, 2018, 12:11:05 PM »
Can you be more specufic and show us what happens please. Geoip and openvpn are totally unrelated so it may be due to other factors.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline mmccarn

  • *
  • 2,351
Re: geoipupdate errors
« Reply #3 on: December 30, 2018, 03:00:52 PM »
I ran into the same problem yesterday with missing dependencies for smeserver-geoip. I was hoping the error was due to outdated repositories, but I'm still seeing the same errors today.

smeserver-geoip has perl-GeoIP2 as a dependency, but I don't have that package in any repo I'm using.

I am also running into a problem with both smeserver-spamassassin and spamassassin.


Code: [Select]
# yum --enablerepo=smeupdates --enablerepo=smecontribs update smeserver-geoip
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: centos2.zswap.net
 * smeaddons: mirror.canada.pialasse.com
 * smecontribs: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: centos2.zswap.net
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
The program yum-complete-transaction is found in the yum-utils package.
--> Running transaction check
---> Package smeserver-geoip.noarch 0:1.1.2-7.el6.sme will be updated
---> Package smeserver-geoip.noarch 0:1.2-3.el6.sme will be an update
--> Processing Dependency: perl-GeoIP2 for package: smeserver-geoip-1.2-3.el6.sme.noarch
--> Processing Dependency: perl(GeoIP2::Database::Reader) for package: smeserver-geoip-1.2-3.el6.sme.noarch
--> Finished Dependency Resolution
Error: Package: smeserver-geoip-1.2-3.el6.sme.noarch (smecontribs)
           Requires: perl(GeoIP2::Database::Reader)
Error: Package: smeserver-geoip-1.2-3.el6.sme.noarch (smecontribs)
           Requires: perl-GeoIP2
 You could try using --skip-broken to work around the problem
** Found 13 pre-existing rpmdb problem(s), 'yum check' output follows:
php56-php-common-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-common-5.6.38-2.el6.remi.x86_64
php56-php-enchant-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-enchant-5.6.38-2.el6.remi.x86_64
php56-php-gd-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-gd-5.6.38-2.el6.remi.x86_64
php56-php-imap-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-imap-5.6.38-2.el6.remi.x86_64
php56-php-ldap-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-ldap-5.6.38-2.el6.remi.x86_64
php56-php-soap-5.6.39-1.el6.remi.x86_64 is a duplicate with php56-php-soap-5.6.38-2.el6.remi.x86_64
php70-php-common-7.0.33-1.el6.remi.x86_64 is a duplicate with php70-php-common-7.0.32-1.el6.remi.x86_64
php70-php-enchant-7.0.33-1.el6.remi.x86_64 is a duplicate with php70-php-enchant-7.0.32-1.el6.remi.x86_64
php70-php-gd-7.0.33-1.el6.remi.x86_64 is a duplicate with php70-php-gd-7.0.32-1.el6.remi.x86_64
php70-php-imap-7.0.33-1.el6.remi.x86_64 is a duplicate with php70-php-imap-7.0.32-1.el6.remi.x86_64
php70-php-json-7.0.33-1.el6.remi.x86_64 is a duplicate with php70-php-json-7.0.32-1.el6.remi.x86_64
smeserver-spamassassin-2.4.0-9.el6.sme.noarch has missing requires of DCC
spamassassin-3.4.1-1.el6.sme.x86_64 has missing requires of /usr/bin/dccproc

Code: [Select]
# yum --enablerepo=* list "*GeoIP*"
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: centos2.zswap.net
 * centosplus: centos2.zswap.net
 * contrib: centos2.zswap.net
 * epel: la-mirrors.evowise.com
 * epel-nodejs: la-mirrors.evowise.com
 * extras: centos2.zswap.net
 * fasttrack: centos2.zswap.net
 * smeaddons: mirror.canada.pialasse.com
 * smecontribs: mirror.canada.pialasse.com
 * smedev: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smetest: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * smeupdates-testing: mirror.canada.pialasse.com
 * updates: centos2.zswap.net
Installed Packages
GeoIP.x86_64                               1.6.5-1.el6                           @smeos     
GeoIP-GeoLite-data.noarch                  2018.04-1.el6                         @smeupdates
GeoIP-GeoLite-data-extra.noarch            2018.04-1.el6                         @smeupdates
geoipupdate.x86_64                         2.2.1-2.el6                           @smeos     
smeserver-geoip.noarch                     1.1.2-7.el6.sme                       @smecontribs
Available Packages
GeoIP.i686                                 1.6.5-1.el6                           epel       
GeoIP-devel.i686                           1.6.5-1.el6                           epel       
GeoIP-devel.x86_64                         1.6.5-1.el6                           epel       
geoip-geolite.noarch                       2013.04-1.el6                         epel       
geoipupdate-cron.noarch                    2.2.1-2.el6                           epel       
geoipupdate-cron6.noarch                   2.2.1-2.el6                           epel       
lighttpd-mod_geoip.x86_64                  1.4.47-2.el6                          epel       
mod_geoip.x86_64                           1.2.10-1.el6                          epel       
nginx-mod-http-geoip.x86_64                1.10.2-1.el6                          epel       
opensips-mmgeoip.x86_64                    1.7.2-2.el6                           epel       
php-pecl-geoip.x86_64                      1.0.8-3.el6                           epel       
php54-php-pecl-geoip.x86_64                1.1.1-1.el6.remi                      remi-safe   
php55-php-pecl-geoip.x86_64                1.1.1-1.el6.remi                      remi-safe   
php56-php-pecl-geoip.x86_64                1.1.1-1.el6.remi                      remi-safe   
php70-php-pecl-geoip.x86_64                1.1.1-1.el6.remi                      remi-safe   
php71-php-pecl-geoip.x86_64                1.1.1-3.el6.remi                      remi-safe   
php72-php-pecl-geoip.x86_64                1.1.1-4.el6.remi                      remi-safe   
php73-php-pecl-geoip.x86_64                1.1.1-6.el6.remi                      remi-safe   
python-GeoIP.x86_64                        1.2.5-0.2.20090931cvs.el6             epel       
python-pygeoip.noarch                      0.2.6-1.el6                           epel       
smeserver-geoip.noarch                     1.2-3.el6.sme                         smecontribs
uwsgi-plugin-geoip.x86_64                  2.0.17.1-1.el6                        epel

Code: [Select]
# yum --enablerepo=* repolist
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: centos2.zswap.net
 * centosplus: centos2.zswap.net
 * contrib: centos2.zswap.net
 * epel: mirror.us.leaseweb.net
 * epel-nodejs: mirror.us.leaseweb.net
 * extras: centos2.zswap.net
 * fasttrack: centos2.zswap.net
 * smeaddons: mirror.canada.pialasse.com
 * smecontribs: mirror.canada.pialasse.com
 * smedev: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smetest: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * smeupdates-testing: mirror.canada.pialasse.com
 * updates: centos2.zswap.net
repo id                                repo name                                     status
base                                   CentOS - os                                    6,710+3
centos-sclo-rh                         Centos - RH Software Collections                 2,880
centos-sclo-sclo                       CentOS-6 - SCLo sclo                               406
centos-sclo-sclo-debuginfo             CentOS-6 - SCLo sclo Debuginfo                     145
centos-sclo-sclo-source                CentOS-6 - SCLo sclo Sources                         0
centos-sclo-sclo-testing               CentOS-6 - SCLo sclo Testing                       537
centosplus                             CentOS - centosplus                                 42
contrib                                CentOS - contrib                                     0
epel                                   Epel - EL6                                    12,503+1
epel-nodejs                            Epel - EL6                                      12,504
extras                                 CentOS - extras                                     35
fasttrack                              CentOS - fasttrack                                   2
fws                                    Firewall Services                                  440
puppet5                                Puppet 5 Repository el 6 - x86_64                  112
remi-safe                              Remi - safe                                      2,732
smeaddons                              SME Server - addons                                 28
smecontribs                            SME Server - contribs                              383
smedev                                 SME Server - dev                                   108
smeextras                              SME Server - extras                                165
smeos                                  SME Server - os                                    905
smetest                                SME Server - test                                  129
smeupdates                             SME Server - updates                               138
smeupdates-testing                     SME Server - updates testing                        88
sogo3                                  Inverse SOGo Repository                             49
sogo4                                  Inverse Sogo4 Repository                            42
stephdl                                Mirror de Labrusse                                 112
updates                                CentOS - updates                                 256+1
wazuh                                  Wazuh repository                                    88
repolist: 41,539

[edit]
I am able to update if I specify "--except=smeserver-geoip" when running yum update...
« Last Edit: December 30, 2018, 03:29:17 PM by mmccarn »

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #4 on: December 31, 2018, 02:33:03 AM »
If you follow the link above you will see:

"As a result you will need to install the OpenFusion repo to install the updated contrib"

Read here as well.

https://wiki.contribs.org/GeoIP

You can either continue using the old contrib with the exclude line but note you will most likely get update errors from the geoipupdate tool when the old DBs are pulled, or add the OpenFusion repo to use the new version. If you use geoip with mail then this is really the best route in the absence of a better solution..

There has been some discussion about how best to do this and there is no easy solution.

The DBs can sit alongside each other, but the updater tool will be overwritten in the new version. The old DBs stopped being maintained in April, and by then were pretty poor (I first noticed issues nearly 2 years ago, and with the shortage of IPv4 IPs, the remaining ones are being swapped around a lot leading to location issues). The v1 DBs will disappear entirely on 2nd Jan 2019.

The only core package that relies on the old GeoIP is Proftd which has the geoip module built in by upstream, even though it is never used. Regrettably no one has bothered to attend to this issue upstream, either at RH or Proftpd, despite knowing about it for nearly 2 years, so we can't deprecate/remove the old geoIP packages currently.

Note current spamassassin 3.4.1 can use geoip v1 if enabled, but it is not a install dependency.

Spamassassin 3.4.2 can use geoip v2 if enabled, but again geoip is not an install dependency. I was intending at looking if I can add some keys to enable it in spamassassin.

All in all it is messy and I wish there was a better way. But I haven't found one yet.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #5 on: December 31, 2018, 11:41:22 AM »
Using the openfusion repo to update geoip, results in 206 extra rpms being installed and results in this:

Transaction Check Error:
  file /usr/share/man/man3/Apache::Test.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestConfig.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestMB.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestMM.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestReport.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRequest.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRun.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRunPHP.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestRunPerl.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestServer.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestSmoke.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestTrace.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Apache::TestUtil.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
  file /usr/share/man/man3/Bundle::ApacheTest.3pm.gz from install of mod_perl-2.0.9-1.of.el6.x86_64 conflicts with file from package perl-Apache-Test-1.30-2.el6.rf.noarch
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #6 on: December 31, 2018, 11:48:54 AM »
Yup there are a lot of packages.

Thank maxmind who supply the dbs.....

Your error is due to having installed something from smetest or elsewhere.

I have seen someone else report the same a while back. Have a search for perl-Apache-Test here or in bugs.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #7 on: December 31, 2018, 12:22:04 PM »
Nothing in bugzilla.

A few in here, but nothing recent AFAICS

I get this:
[root@bjsserver ~]# rpm -qa | grep "perl-Apache-Test"
perl-Apache-Test-1.30-2.el6.rf.noarch
[root@bjsserver ~]# rpm -e perl-Apache-Test
error: Failed dependencies:
   perl(Apache::Test) is needed by (installed) spamassassin-3.4.1-1.el6.sme.x86_64
[root@bjsserver ~]#
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #8 on: December 31, 2018, 12:26:05 PM »
https://bugs.contribs.org/show_bug.cgi?id=10523

And I can't remember the version required.

I think it may be 2.72 but I test built 2.67 in smetest.

I need to check this when home as I can't do much with my phone.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #9 on: December 31, 2018, 12:33:42 PM »
Fond this now,

https://forums.contribs.org/index.php?topic=53754.0

But problem there was disabled smeupdates, which is not my problem.

Regarding the bug - I already have the updated mod_perl as far as I can see:

[root@bjsserver ~]# rpm -qa | grep mod_perl
mod_perl-2.0.4-12.1.el6.sme.x86_64
[root@bjsserver ~]#
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #10 on: December 31, 2018, 01:17:41 PM »
I'm pretty sure this is because at some stage you have probably installed a test package which is causing the conflict.

Seems to be a common problem where over time people have installed test packages etc and things end up in a bit of a pickle.

Can you check what is installed from where with audittools?

It may need a package remived/downgraded to let it update properly.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #11 on: December 31, 2018, 02:47:52 PM »
Having had a quick look on some of my more stock install it seems that installing geoip 2 does not pull in a higher mod_perl.

rpm -qa |grep mod_perl
mod_perl-2.0.4-12.1.el6.sme.x86_64


rpm -qa |grep -i geoip
perl-GeoIP2-2.001002-1.of.el6.noarch
GeoIP-1.6.5-1.el6.x86_64
GeoIP-GeoLite-data-2018.04-1.el6.noarch
smeserver-geoip-1.2-3.el6.sme.noarch
GeoIP-GeoLite-data-extra-2018.04-1.el6.noarch
geoipupdate-2.2.1-2.el6.x86_64


So we have geoip v2 installed but with mod_perl 2.0.4 so mu guess is to look at the mod_perl issue.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #12 on: January 01, 2019, 11:20:05 AM »
Brian, did you get this resolved?
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline brianr

  • *
  • 876
Re: geoipupdate errors
« Reply #13 on: January 01, 2019, 11:45:26 AM »
Brian, did you get this resolved?

No (New Year intervened).

This is what I have:

[root@bjsserver ~]# rpm -qa | grep mod_perl
mod_perl-2.0.4-12.1.el6.sme.x86_64
[root@bjsserver ~]# rpm -qa | grep geoip
smeserver-geoip-1.1.2-7.el6.sme.noarch
geoipupdate-2.2.1-2.el6.x86_64
[root@bjsserver ~]#

So I seem to have the same mod_perl as you.

So, I tried the install again - and it went through ok!

 I notice that a new version of the smeserver-openfusion rpm came in this morning -so perhaps that fixed it?

As usual - thanks for the help.

PS Only 96 new perl rpms this time (it was 206 last time!). Clearly something has changed.
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline ReetP

  • *
  • 1,771
Re: geoipupdate errors
« Reply #14 on: January 01, 2019, 11:50:23 AM »
Cool.

Openfusion rpm was just a update to other repository rpms and it auto regenerates this one so not likely.


Seems you are still on the old version of geoip? 1.2-3 is the updated one.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation