Koozali.org formerly Contribs.org

smeserver-geoip

Offline ReetP

  • *
  • 1,767
smeserver-geoip
« on: December 24, 2018, 04:47:48 PM »
I have mentioned this a number of times but on or around 4th January 2019 the old Maxmind V1 DBs are going to be withdrawn. They have not been maintained for several months. At this point you are likely to get errors that geoipupdate cannot find the databases.

We have updated the smeserver-geoip contrib to use the new v2 databases and want to release this.

However, a couple of modules required for GeoIP require a large number of dependencies and it is not practical for the team to maintain all of them.

As a result you will need to install the OpenFusion repo to install the updated contrib. JPP has been in conversation with the owners of the OpenFusion repo and we are going to run a sync/mirror to aid installation and updates.

This mirror also has a number of packages that will help us make some updates to other core packages in due course.

We are going to release the updated smeserver-geoip package in the next few days. If you do not want to do this you will have to Exclude smeserver-geoip from updates, typically like this:

Code: [Select]
db yum_repositories setprop smecontribs Exclude smeserver-geoip
signal-even yum-modify

However, we would recommend that you update unless you have good reasons not too.

Please see these links for more information.

https://wiki.contribs.org/GeoIP

https://bugs.contribs.org/show_bug.cgi?id=9033

Thank you.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation