Koozali.org formerly Contribs.org

500 errors with Horde and Server-Manager

Offline ReetP

  • *
  • 1,772
500 errors with Horde and Server-Manager
« on: December 15, 2018, 04:26:20 PM »
We have noticed a number of posts with these errors.

Having tested this it seems the primary issue is due to enabling PHP-SCL version 7.x globally which appears to break the stock Horde 3 due to stricter checking and changing methods in PHP 7.x

It seems that the Server-Manager itself is OK with globally enabling PHP 7.x

I will log a bug for this and we will have to see if we can possibly patch Horde.

As a stop gap to prevent this happening only enable PHP on an ibay and not globally, or install the updated Horde 5 (see the Wiki)

To get back to a standard installation you can do the following:

Global - set disabled where $phpver is php70/php71/php72/php73

Code: [Select]
config setprop $phpver PhpModule disabled
signal-event php-update

e.g.
Code: [Select]
config setprop php70 PhpModule disabled
signal-event php-update


This is the manual configuration for an individual ibay which should be OK:

Code: [Select]
db {$ibayname} setprop PhpVersion disabled|enabled
signal-event php-update

Please note that some of the issues reported are a result of wrongly enabled repositories. Care should be taken not to confuse issues.

Please make sure you only have the recommended repos enabled permanently.
smetest and  smeupdates-testing should NEVER be permanently enabled on a production server under any circumstances.

If you experience any issues the first thing to do is check your server logs.

tailf /var/log/messages
tailf /var/log/httpd/error_log
tailf  /var/log/httpd/admin_error_log

I'll post back here with more information as we have it.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline ReetP

  • *
  • 1,772
Re: 500 errors with Horde and Server-Manager
« Reply #1 on: December 15, 2018, 04:36:50 PM »
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation