Koozali.org formerly Contribs.org

smeserver-php-scl preventing yum update

smeserver-php-scl preventing yum update
« on: December 15, 2018, 01:58:32 PM »
Hi all
Noticed this on an update and maybe unrelated but server-manager is also not working giving an 500 error
Quote
[root@tsi ~]# yum update --enablerepo=smecontribs
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.sov.uk.goscomb.net
 * smeaddons: mirror.pialasse.com
 * smecontribs: mirror.pialasse.com
 * smeextras: mirror.pialasse.com
 * smeos: mirror.pialasse.com
 * smeupdates: mirror.pialasse.com
 * smeupdates-testing: mirror.pialasse.com
 * updates: mirror.sov.uk.goscomb.net
Resolving Dependencies
--> Running transaction check
---> Package smeserver-letsencrypt.noarch 0:0.4-4 will be updated
---> Package smeserver-letsencrypt.noarch 0:0.4-6 will be an update
---> Package smeserver-php-scl.noarch 0:0.4-17.el6.sme will be updated
---> Package smeserver-php-scl.noarch 0:0.4-21.el6.sme will be an update
--> Processing Dependency: php73-php-xml for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-tidy for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-soap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-pecl-zip for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-pecl-mysql for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-pear for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-pdo for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-mysqlnd for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-mbstring for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-ldap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-imap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-gd for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-enchant for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php-bcmath for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73-php for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php73 for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-xml for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-tidy for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-soap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-pecl-zip for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-pecl-mysql for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-pecl-mcrypt for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-pear for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-pdo for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-mysqlnd for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-mbstring for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-ldap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-imap for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-gd for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-enchant for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php-bcmath for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72-php for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Processing Dependency: php72 for package: smeserver-php-scl-0.4-21.el6.sme.noarch
--> Finished Dependency Resolution
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-mbstring
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-soap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-enchant
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-pecl-mcrypt
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-ldap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-xml
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-soap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-tidy
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-xml
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-mbstring
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-imap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-pear
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-pear
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-gd
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-pecl-mysql
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-enchant
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-pdo
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-pecl-zip
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-mysqlnd
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-imap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-pdo
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-pecl-mysql
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-pecl-zip
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-gd
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-bcmath
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-ldap
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-tidy
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php73-php-bcmath
Error: Package: smeserver-php-scl-0.4-21.el6.sme.noarch (smecontribs)
           Requires: php72-php-mysqlnd
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
[root@tsi ~]#

Offline mmccarn

  • *
  • 2,404
Re: smeserver-php-scl preventing yum update
« Reply #1 on: December 15, 2018, 02:38:54 PM »
It looks to me like the wiki page for smeserver-scl-php now assumes that the remi-safe repository is "enabled" instead of "disabled".

You have two choices:
* Permanently "enable" the remi-safe repository
* Temporarily enable remi-safe when updating smecontribs-scl-php

I do not believe in permanently enabling non-standard repositories, but if you want to do that you would use:
Code: [Select]
db yum_repositories setprop remi-safe status enabled
expand-template /etc/yum.smerepos.d/sme-base.repo

Confirm success by executing "yum repolist":
Quote from: yum repolist
# yum repolist
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: centos2.zswap.net
 * smeaddons: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: centos2.zswap.net
base                                                                                                            | 3.7 kB     00:00     
remi-safe                                                                                                       | 3.0 kB     00:00     
remi-safe/primary_db                                                                                            | 1.1 MB     00:00     
smeaddons                                                                                                       | 2.9 kB     00:00     
smeextras                                                                                                       | 2.9 kB     00:00     
smeos                                                                                                           | 3.1 kB     00:00     
smeupdates                                                                                                      | 2.9 kB     00:00     
updates                                                                                                         | 3.4 kB     00:00     
repo id                                                    repo name                                                            status
base                                                       CentOS - os                                                          6,710+3
remi-safe                                                  Remi - safe                                                            2,730
smeaddons                                                  SME Server - addons                                                       28
smeextras                                                  SME Server - extras                                                      165
smeos                                                      SME Server - os                                                        1,810
smeupdates                                                 SME Server - updates                                                     138
updates                                                    CentOS - updates                                                       250+1
repolist: 11,831

If like me you prefer to leave all non-standard repositories disabled, you can enable the repo while you update smecontribs-php-scl:

Code: [Select]
yum --enablerepo=smecontribs --enablerepo=remi-safe update smecontribs-php-scl

Once "smecontribs-php-scl" has been updated from smecontribs, and all of the dependent php7x- and php5x- packages have been updated from remi-safe, run a second update to update smeserver-letsencrypt:

Code: [Select]
yum --enablerepo=smecontribs update

Offline ReetP

  • *
  • 2,028
Re: smeserver-php-scl preventing yum update
« Reply #2 on: December 15, 2018, 02:42:19 PM »
It is generally considered that the remi-safe repo is ok to enable as it has no rpms that will conflict with the base repo (see note in Wiki)

The same cannot be said of the remi repo itself which should be used with caution.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • grumpy old man
  • *
  • 1,078
Re: smeserver-php-scl preventing yum update
« Reply #3 on: December 15, 2018, 03:47:17 PM »
If epel is also enabled for the install two packages are pulled from epel

libmcrypt  x86_64  2.5.8-9.el6  epel 96 k
libwebp    x86_64  0.4.3-3.el6  epel 210 k

If epel is not enabled both packages are available from the smecontribs repo, versions are same
--
qui scribit bis legit

Re: smeserver-php-scl preventing yum update
« Reply #4 on: December 18, 2018, 10:58:34 AM »
Many Thanks.
Remi-safe wasnt there so added it.
Update complete