Koozali.org formerly Contribs.org

Letsencrypt/Dehydrated

Offline ReetP

  • *
  • 1,771
Letsencrypt/Dehydrated
« on: December 12, 2018, 04:01:54 PM »
OK, we have been using the V1 API to date.

There is a V2 API and I have had a rpm in smetest to use this for some time and all my servers are on the V2 APi now.

https://bugs.contribs.org/show_bug.cgi?id=10595 (main work)
https://bugs.contribs.org/show_bug.cgi?id=10636 (small bug fix)

yum --enablerepo=smetest install smeserver-letsencrypt

smeserver-letsencrypt-0.5-3.noarch.rpm
dehydrated-0.6.2-13.el6.sme.noarch.rpm

By default it *should* remain using the V1 API and you will carry on as normal.

To change to the V2 API you need to set a key:

Code: [Select]
config setprop letsencrypt API 2
or

Code: [Select]
config setprop letsencrypt API auto

Code: [Select]
signal-event console-save
You then need to run dehydrated again.

I'd like to push this out reasonably soon, but I am sure there will probably be some breakages etc so please test it if you can and let me know via here or the bug tracker.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation