Koozali.org formerly Contribs.org

SME server-admin no longer accessable

SME server-admin no longer accessable
« on: December 12, 2018, 02:59:02 AM »
I did some updates via yum about a week ago and apparently something happened that now whenever I try to access server-admin I get an Internal error (500).

I uninstalled (I beleive) all the updates and wonder how I might reinstall the server-admin

Thanks.

Re: SME server-admin no longer accessable
« Reply #1 on: December 12, 2018, 07:51:31 PM »
Hi Parsival1973,

I confirm. it is the update that does that. I saw it today at a friend's place.

Michel-André

Offline warren

  • *
  • 264
Re: SME server-admin no longer accessable
« Reply #2 on: December 12, 2018, 09:49:10 PM »
Hi Parsival1973,

I confirm. it is the update that does that. I saw it today at a friend's place.

Michel-André


Which updates ?
I ran updates as below and am not seeing any issues ( server-gateway mode )
Code: [Select]
================================================================================
 Package                           Arch   Version              Repository  Size
================================================================================
Installing:
 kernel                            x86_64 2.6.32-754.9.1.el6   updates     32 M
Updating:
 clamav                            x86_64 0.100.2-4.el6.sme    smeupdates 1.3 M
 clamav-db                         x86_64 0.100.2-4.el6.sme    smeupdates 162 M
 clamd                             x86_64 0.100.2-4.el6.sme    smeupdates 234 k
 e-smith-base                      noarch 5.6.0-34.el6.sme     smeupdates 344 k
 e-smith-ntp                       noarch 2.4.0-7.el6.sme      smeupdates  52 k
 e-smith-samba                     noarch 2.4.0-26.el6.sme     smeupdates 107 k
 kernel-firmware                   noarch 2.6.32-754.9.1.el6   updates     29 M
 kernel-headers                    x86_64 2.6.32-754.9.1.el6   updates    4.5 M
 perl-Mail-DMARC                   noarch 1.20141206-2.el6.sme smeupdates 994 k
 smeserver-extrarepositories-epel  noarch 0.1-7                smeaddons  5.2 k
 smeserver-extrarepositories-fws   noarch 0.1-7                smeaddons  5.6 k
 smeserver-extrarepositories-remi-safe
                                   noarch 0.1-7                smeaddons  4.4 k
 smeserver-qpsmtpd                 noarch 2.4.0-39.el6.sme     smeupdates 133 k
 smeserver-spamassassin            noarch 2.4.0-9.el6.sme      smeupdates  30 k
Removing:
 kernel                            x86_64 2.6.32-754.2.1.el6   @updates   133 M

Transaction Summary
================================================================================
Install       1 Package(s)
Upgrade      14 Package(s)
Remove        1 Package(s)

Re: SME server-admin no longer accessable
« Reply #3 on: December 12, 2018, 10:07:11 PM »
Hi warren,

My friend installed a brand new SME-9.2 then updated without problem.

Then he installed PHP collection and again made a update. While updating, the message appeared.

I was watching with a TeamViewer connection.

Michel-André

Offline TerryF

  • *
  • 1,047
Re: SME server-admin no longer accessable
« Reply #4 on: December 13, 2018, 12:43:28 AM »
So time for you and your mate to explain exactly what you did, What PHP Collection?

Below is what I observed with  PHP_Software_Collections - Server-Manager fully accessible as admin

New sme9.2 VM, update 13 dec actually 45 mins ago :-)

Added repos as per wiki for PHP Software Collections https://wiki.contribs.org/PHP_Software_Collections

 # signal-event yum-modify
and just to make sure a
 # signal-event post-upgrade; signal-event reboot

Server-Manager fully accessable as admin

yum install smeserver-php-scl --enablerepo=smecontribs

# signal-event php-update; config set UnsavedChanges no
and again just to make sure
# signal-event post-upgrade; signal-event reboot

# Yum update - again as per forum post - no updates avail

[root@sme92 ~]# yum update
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.intergrid.com.au
 * smeaddons: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: mirror.overthewire.com.au
No Packages marked for Update

again as per post

# signal-event post-upgrade; signal-event reboot

Details of VM as at now
[root@sme92 ~]# uname -r
2.6.32-754.9.1.el6.x86_64

[root@sme92 ~]# rpm -qa smeserver-php-scl
smeserver-php-scl-0.4-20.el6.sme.noarch

Server-Manager fully accessable as admin
--
qui scribit bis legit

Re: SME server-admin no longer accessable
« Reply #5 on: December 13, 2018, 12:45:20 AM »
Then he installed PHP collection and again made a update. While updating, the message appeared.

What message? I guess you mean "I get an Internal error (500)". Correct?

Look in /var/log/httpd/error_log and /var/log/httpd/admin_error_log for further details of what is not working correctly. From what you say I would guess that "installed PHP collection" is the cause of the problem.

Offline ReetP

  • *
  • 1,872
Re: SME server-admin no longer accessable
« Reply #6 on: December 13, 2018, 02:50:01 AM »
I would guess that "installed PHP collection" is the cause of the problem.

"Guess" is about right as nothing is proven ;-)

That would be the only incidence we know of so far. I  have several boxes in server/gateway and server only all updated and no issues at all. No bugs either currently. This may have more to do with other applications installed/updated, or modified configurations, than just PHP-SCL.

Note that there WAS an update to PHP-SCL pushed earlier today 0.4-20 that fixed another bug
https://bugs.contribs.org/show_bug.cgi?id=10662

It did not resemble this error. The previous commit added 7.3 support. Again, unless you activated it, it was unlikely to give a 500 error.

For reference the last few changes in php-scl - not likely to cause a 500 error.

%changelog
* Tue Dec 11 2018 John Crisp <jcrisp@safendsountit.co.uk> 0.4-20.sme
- fix spec file permissions [SME: 10662]

* Wed Aug 15 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.4-19.sme
- add php73 support [SME: 10508]
- fixed translation for php7* versions

* Wed Aug 15 2018 Jean-Philipe Pialasse <tests@pialasse.com> 0.4-18.sme
- add php72 support [SME: 10508]

* Tue Aug 14 2018 John Crisp <jcrisp@safeandsoundit.co.uk> 0.4-17.sme
- Fix typo in Soap template

* Sat Dec 02 2017 SME Translation Server <translations@contribs.org> 0.4-16.sme
- apply locale 2017-12-02 patch

Yes there could be a potential issues with the rpms pulled from remi-safe, but we haven't seen any as yet.

As you rightly state, looking for some facts in the logs and some details on the install, and hacks to it, rather than aimlessly pointing fingers, might help :-)
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: SME server-admin no longer accessable
« Reply #7 on: December 13, 2018, 03:06:52 AM »
Hi Charlie,

At least, as a real pro, you read before asking...

I was writing a complete explaination when I received an email as someone wrote a reply before I finish. It was ReetP. So I will forget about it as he will say I hacked something as usual. It was in France and I have nothing to do with it.


Quote
That would be the only incidence we know of so far.

Parsival1973 and my friend = 2...

Michel-André
PS: Just wait and see what he will write...

Offline ReetP

  • *
  • 1,872
Re: SME server-admin no longer accessable
« Reply #8 on: December 13, 2018, 10:10:19 AM »
Michel, just don't make assumptions, that's all.

I have no idea what has happened. You don't either.

The only way to find out is to properly debug it and the first step in that, as you are fully aware, is check the logs

If the OP can check his logs for errors we may be able to start diagnosing the issue.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline mmccarn

  • *
  • 2,373
Re: SME server-admin no longer accessable
« Reply #9 on: December 13, 2018, 12:33:25 PM »
Check the yum configuration, installed packages,  recent yum history, and logs.

yum configuration
Enabling a non-standard repository or enabling a repository with non-standard settings when running "yum update" can result in the installation of packages that are incompatible with SME components.

Here is what I see on my SME 9.2 server:
Quote from: yum repolist
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Loading mirror speeds from cached hostfile
 * base: mirrors.centos.webair.com
 * smeaddons: mirror.hakkers.com
 * smeextras: mirror.hakkers.com
 * smeos: mirror.hakkers.com
 * smeupdates: mirror.hakkers.com
 * updates: mirrors.gigenet.com
repo id                                                    repo name                                                            status
base                                                       CentOS - os                                                          6,710+3
smeaddons                                                  SME Server - addons                                                       28
smeextras                                                  SME Server - extras                                                      165
smeos                                                      SME Server - os                                                        1,810
smeupdates                                                 SME Server - updates                                                     138
updates                                                    CentOS - updates                                                       250+1
repolist: 9,101


Installed Packages
SME includes a tool that will tell you what non-SME RPMs are installed on your server.  Since SME 9 it also tells you what repository each non-SME package was installed from.  Run it to see what it returns:
Code: [Select]
/sbin/e-smith/audittools/newrpms

A common problem occurs if an admin installs a package from any non-standard repository, then enables that repo when doing updates using yum --enablerepo=<non-standard-repo> update.  This would result in unexpected updates to many SME-specific packages that should only be installed or updated from "smeos", "smeupdates", etc.

My SME 9.2 is currently up-to-date. yum update returns "No packages marked for update".

However, if I run "yum --enablerepo=epel update", I am offered 127 updates including horde and many php components, which would be expected to break webmail and anything that uses php.


Recent yum history
/var/log/yum/yum.log will show you what packages have been installed or updated by date - you can use this to figure out which packages were updated on the date that server-manager stopped working.

Logs
One or both of these logs should give you some indication why server-manager is not working:
- /var/log/httpd/admin/admin_error_log
- /var/log/messages


More Information
Here's a forum post that provides guidance on uninstalling non-standard rpms and re-installing the SME versions:
https://forums.contribs.org/index.php/topic,51299.0/topicseen.html

Here's a wiki page with a brief discussion of the risks of maintaining servers with non-standard rpms installed, and providing info on how to get a script that will only update packages from the same repo they were installed from:
https://wiki.contribs.org/Update_contribs


Annoying advice
If you find you need to revert non-SME rpms, have a backup before proceeding

Offline ReetP

  • *
  • 1,872
Re: SME server-admin no longer accessable
« Reply #10 on: December 13, 2018, 01:34:18 PM »
Check the yum configuration, installed packages,  recent yum history, and logs.
......

Great advice thanks Mike.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: SME server-admin no longer accessable
« Reply #11 on: December 13, 2018, 05:32:05 PM »
Hi mmccarn,

I just received an email from my friend this morning that webmail was not working.

He included this link: https://support.plesk.com/hc/en-us/articles/213937465-Horde-webmail-does-not-work-with-500-Internal-Server-Error-IfModule-not-allowed-here

I looked at his "messages log" in Server Manager and found:

Code: [Select]
PHP Fatal error:  Cannot use 'String' as class name as it is reserved in /home/httpd/html/horde/lib/Horde/String.php on line 20
This server is a brand new one.
- Installed.
- Updated through Server Manager.
- Recuperated the december 5th backup (as the original server was updated december 6th or 7th).
- Installed only the PHP Collection according to the Contrib. No update after installing PHP Collection as afraid of the problem may come back. (He did the same procedures the first time he tried to recuperate and when he updated after installing PHP Collection, after about 10-15 lines into the update, the 500 problem occured: I was watching and saw this myself with a TeamViewer connection. So this time he does't upgrade after the Collection).
- PHP56 used with the complete server; adjust that with Server Manager.

Is this related?

Quote
However, if I run "yum --enablerepo=epel update", I am offered 127 updates including horde and many php components, which would be expected to break webmail and anything that uses php.

Michel-André

Offline Daniel B.

  • *
  • 1,690
    • Firewall Services, la sécurité des réseaux
Re: SME server-admin no longer accessable
« Reply #12 on: December 13, 2018, 06:08:45 PM »
A 500 error on the server-manager and on the webmail are most likely completely unrelated. @Michel André please open another thread. This one is about an issue when accessing the server-manager.

To the op, please, check:

Code: [Select]
httpd -t
httpd -tf /etc/httpd/admin-conf/httpd.conf

And look at /var/log/httpd/admin_error_log and /var/log/httpd/error_log. Also, tell us what you did to "uninstalled (I beleive) all the updates"
C'est la fin du monde !!! :lol:

Offline ReetP

  • *
  • 1,872
Re: SME server-admin no longer accessable
« Reply #13 on: December 13, 2018, 06:15:03 PM »
A 500 error on the server-manager and on the webmail are most likely completely unrelated. @Michel André please open another thread. This one is about an issue when accessing the server-manager.

Thank you - you beat me to it.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: SME server-admin no longer accessable
« Reply #14 on: December 13, 2018, 06:49:45 PM »
Hi Daniel B.

This server is new so, no "500 error on the server-manager".

My friend told me he did nothing except updating december 6th or 7th (the one with the error) and he uninstalled nothing.

Michel-André