Koozali.org formerly Contribs.org

Owncloud v 10.0.10

Owncloud v 10.0.10
« on: October 17, 2018, 08:41:37 AM »
Bonjour à tous,

smeserver v9.2

J'utilise la contrib PHP Software Collections disponible sur wiki.contrib.org pour bénéficier de Php 71.
Avec cette nouvelle version Owncloud il faut php-intl qui n'est pas implémentée dans php71.
Pour l'installer:
Télécharger php-intl.71.zip à l'url suivante https://www.diligent.fr/cloud/index.php/s/ongfyGHvCPKORzw
Cette archive contient: intl.so et 20-intl.ini
copier intl.so dans /opt/remi/php71/root/usr/lib64/php/modules
copier 20-intl.ini dans /etc/opt/remi/php71/php.d
Redémarrer le serveur apache

AD

Offline ReetP

  • *
  • 1,981
Re: Owncloud v 10.0.10
« Reply #1 on: October 18, 2018, 08:15:40 PM »
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #2 on: January 24, 2019, 06:36:54 PM »
Merci pour cette info.
Visiblement avec les repos, il se télécharge.
Par contre j'a ivu que php v7 est nécssaire : est il compliqué de mettre à jour "php" sur SME ?
Merci !

Offline ReetP

  • *
  • 1,981
Re: Owncloud v 10.0.10
« Reply #3 on: January 24, 2019, 08:52:30 PM »
De votre premier message, vous semblez avoir installé 7.1?

Quote
J'utilise la contrib PHP Software Collections disponible sur wiki.contrib.org pour bénéficier de Php 71.

https://wiki.contribs.org/PHP_Software_Collections

From your first message you seem to have installed 7.1??
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #4 on: January 25, 2019, 06:03:51 AM »
De votre premier message, vous semblez avoir installé 7.1?

https://wiki.contribs.org/PHP_Software_Collections
Désolé mais je ne comprends pas, ce n'est pas moi qui ai posté au début mais "adili" qui dit avoir installé 7.1.
J'ai juste vu que via yum on peut le récuperer.

Ma question est bien "est il compliqué de mettre à jour 'php' sur SME ?"

Sinon j'ouvre un autre topic mais puisque le sujet était en cours...
Merci.

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #5 on: January 29, 2019, 09:24:08 AM »
Le sujet n'a pas trop l'air d'intéresser.
Est-ce que Owncloud est utilisé sur SME ?
Les dernières version demandent php v7. Est il compliqué de mettre à jour en version 7 de php ?
Et enfin : est-ce que ca peut entrainer des problèmes dans SME ?
Merci. ;)

Re: Owncloud v 10.0.10
« Reply #6 on: January 29, 2019, 10:42:52 AM »
Le sujet n'a pas trop l'air d'intéresser.
Est-ce que Owncloud est utilisé sur SME ?
Les dernières version demandent php v7. Est il compliqué de mettre à jour en version 7 de php ?
Et enfin : est-ce que ca peut entrainer des problèmes dans SME ?
Merci. ;)
Sur mon premier post, j'indique:
J'utilise la contrib PHP Software Collections disponible sur wiki.contrib.org pour bénéficier de Php 71
Il suffit de suivre cette contrib pour avoir php7, c'est facile et çà ne casse rien dans smeserver.

Offline ReetP

  • *
  • 1,981
Re: Owncloud v 10.0.10
« Reply #7 on: January 29, 2019, 03:42:42 PM »
Désolé mais je ne comprends pas, ce n'est pas moi qui ai posté au début mais "adili" qui dit avoir installé 7.1.
J'ai juste vu que via yum on peut le récuperer.
Quote

Ooops :-)

Lo siento !
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #8 on: January 29, 2019, 05:03:02 PM »
Sur mon premier post, j'indique:
J'utilise la contrib PHP Software Collections disponible sur wiki.contrib.org pour bénéficier de Php 71
Il suffit de suivre cette contrib pour avoir php7, c'est facile et çà ne casse rien dans smeserver.
Ah oui, là c'est top avec ce lien :
https://wiki.contribs.org/PHP_Software_Collections
Beau travail !!  :eek: :shock:
Merci pour l'info.

Ooops :-)

Lo siento !
:grin:

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #9 on: January 30, 2019, 03:42:43 PM »
J'ai un souci. J'ai suivi le lien (https://wiki.contribs.org/PHP_Software_Collections) et installé les rpm.
J'ajoute ce qu'il faut comme demandé, puis j'arrive à ceci :
# vi /etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/99allow_url_fopen
#---------------------------------------ajouter ceci:---------------------------------------------
<Directory /home/e-smith/files/ibays/owncloud/html>
    php_admin_flag allow_url_fopen on
    </Directory>
#-------------------------------------------------------------------------------------------------

Et au moment de jouer avec :
# expand-template /etc/httpd/conf/httpd.conf

Il n'est pas content, il me dit ceci :
Code: [Select]
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php54{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 138.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php55{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 139.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php56{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 140.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php70{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 141.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php71{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 142.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php72{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 143.
WARNING in /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl: Use of uninitialized value $esmith::__TEMPLATE__::1::php73{"PhpModule"} in string eq at /etc/e-smith/templates//etc/httpd/conf/httpd.conf/90php_rhscl line 144.
WARNING: Template processing succeeded for //etc/httpd/conf/httpd.conf: 7 fragments generated warnings
 at /sbin/e-smith/expand-template line 45
C'est grâve docteur ?
 :(

J'ai tout de même continué, lancé Owncloud et j'ai la page qui dit :
Quote
    Le module PHP intl n’est pas installé.

    Veuillez demander à votre administrateur d’installer le module.
    Les modules PHP ont été installés mais sont toujours indiqués comme manquants ?

    Veuillez demander à votre administrateur serveur de redémarrer le serveur web.

Je suis sur Linux SME 9.2.0 X64.
« Last Edit: January 30, 2019, 04:27:46 PM by STRyk »

Offline ReetP

  • *
  • 1,981
Re: Owncloud v 10.0.10
« Reply #10 on: January 30, 2019, 05:58:59 PM »
Vous devez vraiment lire plus attentivement.

Vous n'avez pas besoin de ce modèle pour Software Collections - il ne fonctionnerait de toute façon que sur PHP 5.3 installé.

Les modèles personnalisés pour PHP SCL sont placés dans un répertoire différent.

Mais si vous lisez ceci, vous verrez que vous n'en avez pas besoin:

https://wiki.contribs.org/PHP_Software_Collections#Usage

config set php71  AllowUrlFopen On
signal-event php-update


=====================


You really must read more carefully.

You do not need that template for software collections - it would only work on the installed PHP 5.3 anyway.

Custom templates for PHP SCL go in a different directory.

But if you read this you wil see you do not need them:

https://wiki.contribs.org/PHP_Software_Collections#Usage

config set php71  AllowUrlFopen On
signal-event php-update
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #11 on: January 31, 2019, 09:12:29 AM »
Bonjour ReetP,
Je ne comprends pas car ceci :
# config set php71  AllowUrlFopen On
# signal-event php-update

Renvoi cette erreur :
# /sbin/e-smith/db dbfile set key type [prop1 val1] [prop2 val2] ...

Je suppose qu'il faut utiliser cela:
# config setprop php71  AllowUrlFopen On
# signal-event php-update

Mais OwnCloud ne marchepas plus. J'ai la même erreur.
« Last Edit: January 31, 2019, 09:17:19 AM by STRyk »

Offline ReetP

  • *
  • 1,981
Re: Owncloud v 10.0.10
« Reply #12 on: January 31, 2019, 10:13:47 AM »
Oui. Ma faute alors que je me précipitais....

config setprop php71 AllowUrlFopen On


Quote
Mais OwnCloud ne marchepas plus. J'ai la même erreur.

Quelle erreur? Avez-vous supprimé le modèle 99allow_url_fopen ?

Veuillez énumérer les mesures que vous avez prises. Je ne peux pas voir votre écran .....

=========
Yes. Sorry I was rushing....

Which error? Did you remove the template 99allow_url_fopen

Please list the steps you have taken. I cannot see your screen.....
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline STRyk

Re: Owncloud v 10.0.10
« Reply #13 on: January 31, 2019, 10:21:09 AM »
Quote
Quelle erreur? Avez-vous supprimé le modèle 99allow_url_fopen ?
Hummm, supprimer ? Pourquoi ? A quel moment doit on supprimer le modèle 99allow_url_fopen ?

J'ai toujours la même erreur (qu ne change pas) :
Quote
    Le module PHP intl n’est pas installé.

    Veuillez demander à votre administrateur d’installer le module.
    Les modules PHP ont été installés mais sont toujours indiqués comme manquants ?

    Veuillez demander à votre administrateur serveur de redémarrer le serveur web.

J'ai scrupuleusement suivi ce tuto:
https://wiki.contribs.org/OwnCloud

Re: Owncloud v 10.0.10
« Reply #14 on: January 31, 2019, 11:01:48 AM »
Le module PHP intl n’est pas installé.

Pour installer php intl :
yum install php71-php-intl
« Last Edit: January 31, 2019, 11:05:21 AM by adili »