Koozali.org formerly Contribs.org

[ SOLVED ] Roundcube IMAP Connection issue

Offline ReetP

  • *
  • 2,146
Re: [ SOLVED ] Roundcube IMAP Connection issue
« Reply #15 on: August 17, 2018, 01:09:42 AM »
Here is the php56* rpms on my system :

Cool, and thanks for taking the time to do that.

Let's see what he has then :-)
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Bud

  • *
  • 487
Re: [ SOLVED ] Roundcube IMAP Connection issue
« Reply #16 on: August 18, 2018, 04:53:06 PM »
these are my findings

Code: [Select]
rpm -qa |grep php56

php56-php-soap-5.6.37-1.el6.remi.x86_64
php56-runtime-2.3-1.el6.remi.x86_64
php56-php-xml-5.6.37-1.el6.remi.x86_64
php56-php-5.6.37-1.el6.remi.x86_64
php56-php-fpm-5.6.37-1.el6.remi.x86_64
php56-php-gd-5.6.37-1.el6.remi.x86_64
php56-php-magickwand-1.0.9.2-14.el6.remi.x86_64
php56-php-pecl-zip-1.15.3-1.el6.remi.x86_64
php56-php-snmp-5.6.37-1.el6.remi.x86_64
php56-php-pecl-rar-4.0.0-1.el6.remi.x86_64
php56-php-bcmath-5.6.37-1.el6.remi.x86_64
php56-php-pecl-xattr-1.3.0-1.el6.remi.x86_64
php56-php-pdo-5.6.37-1.el6.remi.x86_64
php56-php-process-5.6.37-1.el6.remi.x86_64
php56-php-opcache-5.6.37-1.el6.remi.x86_64
php56-php-ldap-5.6.37-1.el6.remi.x86_64
php56-php-cli-5.6.37-1.el6.remi.x86_64
php56-php-xmlrpc-5.6.37-1.el6.remi.x86_64
php56-php-mcrypt-5.6.37-1.el6.remi.x86_64
php56-php-pear-1.10.5-5.el6.remi.noarch
php56-php-libvirt-0.4.8-2.el6.remi.x86_64
php56-php-imap-5.6.37-1.el6.remi.x86_64
php56-2.3-1.el6.remi.x86_64
php56-php-common-5.6.37-1.el6.remi.x86_64
php56-php-mbstring-5.6.37-1.el6.remi.x86_64
php56-php-tidy-5.6.37-1.el6.remi.x86_64
php56-php-pecl-jsonc-1.3.10-1.el6.remi.x86_64
php56-php-mysqlnd-5.6.37-1.el6.remi.x86_64
php56-php-enchant-5.6.37-1.el6.remi.x86_64
php56-php-intl-5.6.37-1.el6.remi.x86_64

Code: [Select]
/var/log/messages

Aug 18 16:42:19 sme httpd: PHP Warning:  Declaration of rcmail::get_instance($env = '') should be compatible with rcube::get_instance($mode = 0, $env = '') in /usr/share/roundcubemail/program/include/rcmail.php on line 30
Aug 18 16:42:40 sme httpd: PHP Warning:  Declaration of rcmail::get_instance($env = '') should be compatible with rcube::get_instance($mode = 0, $env = '') in /usr/share/roundcubemail/program/include/rcmail.php on line 30


Code: [Select]
/var/log/httpd/error_log

ocsinventory-server: Bad setting. `SNMP` is not set. Default: `1`
ocsinventory-server: Bad setting. `DOWNLOAD_EXECUTION_TIMEOUT` is not set. Default: `120`
ocsinventory-server: Bad setting. `SNMP_INVENTORY_DIFF` is not set. Default: `1`
[Sat Aug 18 12:46:17 2018] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat Aug 18 12:46:17 2018] [warn] RSA server certificate CommonName (CN) `sme.myserver.com' does NOT match server name!?
ocsinventory-server: Bad setting. `SNMP` is not set. Default: `1`
ocsinventory-server: Bad setting. `DOWNLOAD_EXECUTION_TIMEOUT` is not set. Default: `120`
ocsinventory-server: Bad setting. `SNMP_INVENTORY_DIFF` is not set. Default: `1`
[Sat Aug 18 12:46:18 2018] [notice] Digest: generating secret for digest authentication ...
[Sat Aug 18 12:46:18 2018] [notice] Digest: done
[Sat Aug 18 12:46:18 2018] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Sat Aug 18 12:46:18 2018] [warn] RSA server certificate CommonName (CN) `sme.myserver.com' does NOT match server name!?
[Sat Aug 18 12:46:18 2018] [notice] FastCGI: process manager initialized (pid 2474)
[Sat Aug 18 12:46:18 2018] [notice] Apache/2.2.15 (Unix) DAV/2 mod_ssl/2.2.15 OpenSSL/1.0.1e-fips mod_fastcgi/2.4.6 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sat Aug 18 13:18:51 2018] [error] [client 37.49.231.105] File does not exist: /home/e-smith/files/ibays/Primary/html/libs

that's it. any ideas?


Offline Bud

  • *
  • 487
Re: Roundcube IMAP Connection issue
« Reply #17 on: August 18, 2018, 04:53:49 PM »
guys please can you help

using SME 9.2

installed roundcube contrib as per https://wiki.contribs.org/RoundCube

i have disabled webmail in server console
when i try to login with any user credentials i get " Connection to IMAP server failed "

i have checked the imap service and it is running

generic " HORDE " webmail client works when i " ENABLE " webmail in server console

any help greatly appreciated  :-)

Offline Bud

  • *
  • 487
Re: Roundcube IMAP Connection issue
« Reply #18 on: August 18, 2018, 04:54:37 PM »
guys please can you help

using SME 9.2

installed roundcube contrib as per https://wiki.contribs.org/RoundCube

i have disabled webmail in server console
when i try to login with any user credentials i get " Connection to IMAP server failed "

i have checked the imap service and it is running

generic " HORDE " webmail client works when i " ENABLE " webmail in server console

any help greatly appreciated  :-)

Offline Bud

  • *
  • 487
Re: Roundcube IMAP Connection issue
« Reply #19 on: August 18, 2018, 04:54:59 PM »
Cool, and thanks for taking the time to do that.

Let's see what he has then :-)

Offline ReetP

  • *
  • 2,146
Re: [ SOLVED ] Roundcube IMAP Connection issue
« Reply #20 on: August 18, 2018, 06:29:13 PM »
Ok, just for the record I installed it on my testbox with php56 and absolutely no issues barring some plugins moaning that they were either missing or out of date. I could happily login and check mail without issues. So next is figuring what you have done to yours to break it....

these are my findings

Code: [Select]
rpm -qa |grep php56

OK, I can only see a few files different and I'm not sure (especially when we look further down here) that they make a difference.

Yours misses:
php56-php-gmp-5.6.37-1.el6.remi.x86_64
php56-php-pecl-json-post-1.0.1-1.el6.remi.x86_64
php56-php-pspell-5.6.37-1.el6.remi.x86_64

But now you have provided some logs (ALWAYS provide logs - they tell you so much) we get to the nitty gritty

Quote
Code: [Select]
/var/log/messages

Aug 18 16:42:19 sme httpd: PHP Warning:  Declaration of rcmail::get_instance($env = '') should be compatible with rcube::get_instance($mode = 0, $env = '') in /usr/share/roundcubemail/program/include/rcmail.php on line 30
Aug 18 16:42:40 sme httpd: PHP Warning:  Declaration of rcmail::get_instance($env = '') should be compatible with rcube::get_instance($mode = 0, $env = '') in /usr/share/roundcubemail/program/include/rcmail.php on line 30

So there's a roundcube error (though it may not be the whole problem - just a signpost to other things). However, that's an odd one one.

You shouldn't get it. Your server is supplying:
Code: [Select]
$mode = 0, $env = ''
To a function that is only expecting:
Code: [Select]
$env = ''
Now I can see an issue, and a patch here for a later version:
https://github.com/roundcube/roundcubemail/issues/5649
https://github.com/roundcube/roundcubemail/commit/1b39d9a6c744a393e7930c2493cc2ddc9c9e95bf

-    static function get_instance($env = '')
+    static function get_instance($mode = 0, $env = '')

That patch allows for the $mode var in the get_instance function. The question is why is yours supplying it ?

What have you done to your roundcube install that may have modified some of the code? Have you tried to patch it or update it in any way?

Next, can you just show:

Code: [Select]
config show roundcube
Code: [Select]
config show imap
Code: [Select]
config show imaps
And see what is in:
/var/log/roundcubemail/errors

Ignore the plugin stuff. Anything else besides when you try to login?

I note you have some issues with ocsinventory too. I'd fix those config entries too:

Quote
Code: [Select]
/var/log/httpd/error_log

ocsinventory-server: Bad setting. `SNMP` is not set. Default: `1`
ocsinventory-server: Bad setting. `DOWNLOAD_EXECUTION_TIMEOUT` is not set. Default: `120`
ocsinventory-server: Bad setting. `SNMP_INVENTORY_DIFF` is not set. Default: `1`
that's it. any ideas?


...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Bud

  • *
  • 487
Re: [ SOLVED ] Roundcube IMAP Connection issue
« Reply #21 on: August 19, 2018, 07:13:33 AM »
ReetP and warren

ReetP i will have a look at OCS, thank you for your input

[root@sme ~]# config show roundcube
roundcube=service
    DbName=roundcube
    DbPassword=569275064234720
    DbUser=roundcube
    Name=RoundCube IMAP Client
    PluginsList=globaladdressbook,contextmenu,markasjunk2,vcard_attachments,newmail_notifier,emoticons,managesieve
    PublicAccess=global
    URL=webmail
    status=enabled

[root@sme ~]# config show imap
imap=service
    TCPPort=143
    access=private
    status=enabled

[root@sme ~]# config show imaps
imaps=service
    TCPPort=993
    access=public
    status=enabled
[root@sme ~]#

i have not touched Rouncube or made any changes to it, so i'm just in the dark as you

hope this helps