Koozali.org formerly Contribs.org

affa --rise --all /etc/passwd missmatch UID GID

affa --rise --all /etc/passwd missmatch UID GID
« on: July 30, 2018, 08:59:23 AM »
SME9 64bit affa to new hardware. I have done many times in the past. This time I am getting a strang affect after the rise. If I use the /sbin/e-smith/console 'configure this server' and scroll through screens not making any changes - I am still prompted to apply changes and reboot. The same occurs again if I try it again after the reconfigure/reboot.
Before the rise , I did install all updates and contribs.

smeserver-userpanel \
smeserver-thinclient \
smeserver-geoip \
smeserver-phpmyadmin \
smeserver-crontab_manager \
smeserver-nfs \
smeserver-dhcpmanager \
smeserver-wbl \
smeserver-sme9admin \
smeserver-tftp-server \
smeserver-phpldapadmin \
smeserver-vacation \
smeserver-lazy_admin_tools \
smeserver-mailsorting \
smeserver-tw-logonscript \
smeserver-remoteuseraccess \
smeserver-denyhosts \
smeserver-roundcube \
smeserver-openvpn-s2s \
install smeserver-affa \
ImageMagick \
iotop
and
iftop smeserver-webfilter smeserver-fail2ban cacti phpvitualbox.

So I reverted back to the old server and did some searching.

The one thing I could see was the UID GID number mismatch between the two.
Just one example:
cacti:x:392:392::/usr/share/cacti:/sbin/nologin -- New Hardware
cacti:x:394:393::/usr/share/cacti:/sbin/nologin -- Old Prod Server

Do the UID GID numbers need to match between both servers ?
If so then should some contribs be installed post rise?
Is there a way to see what the console command thought was being changed ??


Offline ReetP

  • *
  • 2,497
Re: affa --rise --all /etc/passwd missmatch UID GID
« Reply #1 on: August 03, 2018, 03:01:52 PM »
I can't remember exactly off the top of my head but remember seeing am issue with mismatched IDs before.

Have a good search in foros/wiki/bugs

I *think* it is better to install contribs post rise as otherwise they will create a new user with new ID.

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: affa --rise --all /etc/passwd missmatch UID GID
« Reply #2 on: August 03, 2018, 06:10:17 PM »
Hi ReetP,
 
Thanks for the reply,

   I did check the bugs first. I think I figured what I did wrong after the rise and that was to run the console command - configure this server - but not make any changes - but then was prompted to reconfigure/reboot.

On my next try on a fresh load with all the contribs installed - I ran affa and rise - and just reboot as instructed.
This time I no longer get the issue with the console command when I made no changes.

I can still verify that at least with cacti -  grep cacti  /etc/passwd - on the new hardware post rise
cacti:x:392:392::/usr/share/cacti:/sbin/nologin

cacti:x:394:393::/usr/share/cacti:/sbin/nologin -- Old Prod Server
The  UID GID still mismatch but I dont see any ill effects.

I will in the future install contribs that create user IDs post rise.


Offline ReetP

  • *
  • 2,497
Re: affa --rise --all /etc/passwd missmatch UID GID
« Reply #3 on: August 03, 2018, 09:42:24 PM »
Cool, and glad you got it sorted.

I don't guarantee it, but contribs tend to look for already created users before adding a new one.

So better to let it 'rise' and then install contribs.

On a first reboot you may get odd messages about missing bits if contribs are not installed, but those should resolve themselves once they are.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation