Koozali.org formerly Contribs.org

Grub re-install

Offline smnirosh

  • ****
  • 321
  • Learning never ends
Grub re-install
« on: July 24, 2018, 12:32:34 PM »
I have implemented a file system as following and install sme server 9.2 without raid and vlms.
/dev/sda1 - /boot
/dev/sda2 - swap
/dev/sda3 - /

I formated partition sda1 to experiment perpose in a virtual environment.
I installed grub and edited fstab, but still os is booting to grub menu. Is there any specific procedure to restore or reinstall the grub on sda1 partition and boot the system back to normal. Thanks for your answers.

Offline byte

  • *
  • 2,182
Re: Grub re-install
« Reply #1 on: July 24, 2018, 12:49:27 PM »
This should help fix your issue...

https://wiki.contribs.org/Grub
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline smnirosh

  • ****
  • 321
  • Learning never ends
Re: Grub re-install
« Reply #2 on: July 24, 2018, 01:19:11 PM »
thanks very much byte. I've a little doubt about this [root (hd0,0)]
where hd0,0 is the location of the boot partition or root partition?

Offline smnirosh

  • ****
  • 321
  • Learning never ends
Re: Grub re-install
« Reply #3 on: July 25, 2018, 11:52:26 AM »
Hi friends, still no positive article found. The link you supplied is not working for my senario. It installs grub folder and grub.cfg but there no image files and EFI folder and other required files that there were before i format this partition.
What is the point that i have missed here?

Offline sages

Re: Grub re-install
« Reply #4 on: July 26, 2018, 04:09:06 AM »
What is the point that i have missed here?
Providing enough detailed information about exactly what you have done to allow someone to determine what you may have missed rather than expecting them to have clairvoyant powers.  :-?
...

Offline smnirosh

  • ****
  • 321
  • Learning never ends
Re: Grub re-install
« Reply #5 on: July 26, 2018, 09:57:04 AM »
In addition to above details, I created this partition as ext4 using fdisk.
The partition is marked as boot partition.
I used grub-install /dev/sda, grub-install /dev/sda1 and grub-install /dev/sda3 to try out the installation following an article about this.
the root partition (/dev/sda3) is ok, has data on it just as before.
I think the kernel image cannot find by the grub. Bcos after installing grub on sda1, no EFI folder, vmlunz and menu.list files are created yet.
When the os boots up, even its welcome screen is not showing up.
I think we need a procedure to restore or install grub to the sda1 by the correct procedure which sme server deserves.

Offline smnirosh

  • ****
  • 321
  • Learning never ends
Re: Grub re-install
« Reply #6 on: July 27, 2018, 10:33:05 AM »
Hi dear friends, I am in a step ahead than yesterday. I used SME server installation disk and jump to upgrade the installation booting from the installation disk. Now i have the boot menu "Sme 9.2 ********** kernel". But when I hit enter " Grub error 15 file not found". ??????? what kind of procedure do i have to follow now??