Koozali.org formerly Contribs.org

SMTP email ( server only mode )

SMTP email ( server only mode )
« on: July 11, 2018, 03:50:19 PM »
I have SME 9.2 setup in server only configuration and use smtp-auth-proxy set to peer port 465 to forward outgoing server emails to my rackspace smtp account.

The setup works fine when I have my default domain set-up as "mydomain.local"  however, If I change the domain in the server setup to "mydomain.com" then server emails stop and the log at /var/log/smtp-auth-proxy/current shows no activity since the point I rebooted the server with the domain change.

Is there something I am missing as to why emails are not sent with the change ?  If I change back to the .local domain, server emails immediately startup again.


Offline mmccarn

  • *
  • 2,275
Re: SMTP email ( server only mode )
« Reply #1 on: July 12, 2018, 02:22:41 PM »
The SME server will process email for the domain locally unless you have also configured it to forward the email elsewhere.

Here's the relevent (though brief) wiki section:
https://wiki.contribs.org/Email#Deliver_ALL_email_to_a_single_internal_or_external_mail_server

Re: SMTP email ( server only mode )
« Reply #2 on: July 13, 2018, 04:54:30 PM »
So I was unable to get my server email alerts to send via smpt-proxy when the domain was set to xxxxxx.com, but as soon as I change the server configuration to xxxxx.local from xxxxx.com the server emails immediately start to send.

So I have left the domain as xxxxx.local for now so I get server email alerts.  Within the last hour I  added another domain xxxxx.com thru server mananger and now emails thru smtp-proxy no longer work.  If I remove the xxxxx.com domain I added, emails again work.



Anyone have any idea what is going on ?

Offline Jean-Philippe Pialasse

  • *
  • 1,180
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SMTP email ( server only mode )
« Reply #3 on: July 17, 2018, 08:39:12 AM »
Well, as you do not give us any clue on what you are trying to achive and only let us guess, my guess is that the server is actually doing what it is intended for, ie delivering to its local accounts the mails for its configured domains, while this is not what you seem to expect...

So where do you want to access and recieve your emails for mydomain.com ?

Re: SMTP email ( server only mode )
« Reply #4 on: July 17, 2018, 03:12:04 PM »
Well, as you do not give us any clue on what you are trying to achive and only let us guess, my guess is that the server is actually doing what it is intended for, ie delivering to its local accounts the mails for its configured domains, while this is not what you seem to expect...

So where do you want to access and recieve your emails for mydomain.com ?

My bad.  Ok, I have the system installed as server only.  We have our company email hosted by an outside provider, rackspace.  In the server manager settings I have :

E-mail settings
POP3 server access    Disabled
IMAP server access    Disabled
Webmail access    Disabled

Change e-mail access settings

Virus scanning    Enabled
Spam filtering    Disabled
Executable content blocking    Disabled

Change e-mail filtering settings

E-mail retrieval mode    Standard (SMTP)
SMTP authentication    Allow both SMTP and SSMTP

Change e-mail reception settings

E-mail to unknown users    Reject
Address of internal mail server    
Address of Internet provider's mail server    smtp.emailsrvr.com

Change e-mail delivery settings

I also set-up smtp-auth-proxy to use port 587 to forward emails to my company email address and I have all server messages set to forward to my rackspace email address.

All of this works when the domain is set to xxxxxxx.local

If I change the server domain to xxxxxxx.com, ( and that is the only change I make ) then none of the above settings work.  No server messages are ever forwarded to my email.

I am using the .local domain as I need to receive server messages.  The reason I tried to use xxxxxxx.com is too avoid the certificate mistmatch errors when employees log into the nextcloud app that is installed.

As mentioned in an earlier post, the email also stops if I keep xxxxxxx.local and add xxxxxxx.com as a secondary domain.  As a test, I removed all the hostnames and addresses for the secondary domain server-manager and it had no effect on email delivery.




Offline Jean-Philippe Pialasse

  • *
  • 1,180
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: SMTP email ( server only mode )
« Reply #5 on: July 19, 2018, 09:30:46 AM »