Koozali.org formerly Contribs.org

SME Bloccato all'avvio SLAPD

Offline Spillo

  • ***
  • 107
SME Bloccato all'avvio SLAPD
« on: June 19, 2018, 03:29:18 PM »
Salve,

SME versione 8 che avrei dovuto migrare...... questione di tempo per quanto possa sembrare strano ma è cosi....non è stato possibile...

Al riavvio della macchina si blocca con errore "Waiting for Slapd to startup"

Ieri avevo avuto un problema simile ma siccome era accaduto in prima mattinata dopo aver cercato tra i vari log non trovando nulla in proposito ho deciso di ripartire con il backup della mezzanotte e ttuo era andato ok.

Suggerimenti in proposito?



Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME Bloccato all'avvio SLAPD
« Reply #1 on: June 19, 2018, 03:31:41 PM »
cerca in messages.. 90% hai ldap corrotto
P.S. SME8 non ha supporto quindi, per usare una espressione inglese, you're on your own
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline Spillo

  • ***
  • 107
Re: SME Bloccato all'avvio SLAPD
« Reply #2 on: June 19, 2018, 03:59:39 PM »
Ok.. come facilmente prevedibile.

Sto facendo ripartire il tutto dauna snapshot recente..... ho gia messo su SME9 ..... non ho trovato la procedura per migrare da SME8 a SME9 tutti i dati e utenti etc... mi dai una dritta...?
I contribs.dalla versione 8 li devo eliminare?


Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME Bloccato all'avvio SLAPD
« Reply #3 on: June 19, 2018, 04:34:16 PM »
scusa ma non riesco a credere tu non abbia visto alcuna procedura per migrare SME8 a SME9.
Puoi:
- backup su workstation (disco usb, share di rete) -> restore
- backup da console su disco usb -> restore alla prima configurazione della 9
- affa
- script personalizzati (see https://wiki.contribs.org/Backup_server_config ma senza gli exclude)
- rsync

direi che hai tutto quello che necessiti :-)

Relativamente ai contribs, è buona cosa prendersi la lista di quelli installati, rimuoverli e poi reinstallarli sulla 9 dopo il restore (se ancora esistenti)

se non hai terabytes di dati, consiglierei una VM sulla quale provare la migrazione (da tenere sconnessa dalla rete dopo il restore e successivo reboot, solo per verificare che tutto vada liscio)

HTH
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline Spillo

  • ***
  • 107
Re: SME Bloccato all'avvio SLAPD
« Reply #4 on: June 19, 2018, 09:22:11 PM »
Salve,

Situazione recuperata quasi al 100%, migrato su 9.2..... qualche piccolo dettaglio da riconfigurare ma dovrebbe essere ok.

Grazie Stefano

Re: SME Bloccato all'avvio SLAPD
« Reply #5 on: November 16, 2018, 04:42:13 PM »

Relativamente ai contribs, è buona cosa prendersi la lista di quelli installati, rimuoverli e poi reinstallarli sulla 9 dopo il restore (se ancora esistenti)


Esiste un comando che mi restituisca la lista dei contribs installati ?

Offline ReetP

  • *
  • 1,772
Re: SME Bloccato all'avvio SLAPD
« Reply #6 on: November 18, 2018, 01:12:19 PM »
/sbin/e-smith/audittools/newrpms

server-manager
Miscellaneous
Report a bug

...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation